summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/alien/alien-8.95-r2.ebuild')
-rw-r--r--app-arch/alien/alien-8.95-r2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-arch/alien/alien-8.95-r2.ebuild b/app-arch/alien/alien-8.95-r2.ebuild
new file mode 100644
index 000000000000..9155c848fb61
--- /dev/null
+++ b/app-arch/alien/alien-8.95-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit perl-module
+
+DESCRIPTION="Converts between the rpm, dpkg, stampede slp, and slackware tgz file formats"
+HOMEPAGE="https://sourceforge.net/projects/alien-pkg-convert"
+SRC_URI="mirror://debian/pool/main/a/${PN}/${PN}_${PV}.tar.xz -> ${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~hppa ppc ppc64 ~riscv x86"
+IUSE="+bzip2"
+
+RDEPEND="
+ app-arch/rpm
+ app-arch/dpkg
+ dev-util/debhelper
+ >=app-arch/tar-1.14.91
+ bzip2? ( app-arch/bzip2 )"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-tar-extensions.patch" )