summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/arj')
-rw-r--r--app-arch/arj/arj-3.10.22-r8.ebuild7
-rw-r--r--app-arch/arj/files/arj-3.10.22-interix.patch45
2 files changed, 3 insertions, 49 deletions
diff --git a/app-arch/arj/arj-3.10.22-r8.ebuild b/app-arch/arj/arj-3.10.22-r8.ebuild
index 571c5777b086..411fee4059d2 100644
--- a/app-arch/arj/arj-3.10.22-r8.ebuild
+++ b/app-arch/arj/arj-3.10.22-r8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -9,21 +9,20 @@ PATCH_LEVEL=15
MY_P="${PN}_${PV}"
DESCRIPTION="Utility for opening arj archives"
-HOMEPAGE="http://arj.sourceforge.net/"
+HOMEPAGE="https://arj.sourceforge.net/"
SRC_URI="
mirror://debian/pool/main/a/arj/${MY_P}.orig.tar.gz
mirror://debian/pool/main/a/arj/${MY_P}-${PATCH_LEVEL}.debian.tar.xz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+KEYWORDS="amd64 ~arm ~arm64 ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
PATCHES=(
"${FILESDIR}/${P}-implicit-declarations.patch"
"${FILESDIR}/${P}-glibc2.10.patch"
"${WORKDIR}"/debian/patches/
"${FILESDIR}/${P}-darwin.patch"
- "${FILESDIR}/${P}-interix.patch"
)
DOCS=( doc/compile.txt doc/debug.txt doc/glossary.txt doc/rev_hist.txt doc/xlation.txt )
diff --git a/app-arch/arj/files/arj-3.10.22-interix.patch b/app-arch/arj/files/arj-3.10.22-interix.patch
deleted file mode 100644
index 8294f1e96bb4..000000000000
--- a/app-arch/arj/files/arj-3.10.22-interix.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-diff -ru arj-3.10.22.orig/environ.c arj-3.10.22/environ.c
---- arj-3.10.22.orig/environ.c 2008-03-30 16:51:40 +0200
-+++ arj-3.10.22/environ.c 2008-03-30 16:50:16 +0200
-@@ -61,7 +61,7 @@
- #elif defined(__FreeBSD__)||defined(__NetBSD__)||defined(__APPLE__)
- #include <sys/param.h>
- #include <sys/mount.h>
-- #elif defined(__QNXNTO__)
-+ #elif defined(__QNXNTO__) || defined(__INTERIX)
- #include <sys/statvfs.h>
- #else
- #include <sys/statfs.h>
-@@ -2286,7 +2286,7 @@
- else
- return((LONG_MAX/(spclu*bps)<fclu)?LONG_MAX:spclu*bps*fclu);
- #elif TARGET==UNIX
-- #if defined(__QNXNTO__)||defined(__sco__)||defined(SUNOS)
-+ #if defined(__QNXNTO__)||defined(__sco__)||defined(SUNOS)||defined(__INTERIX)
- struct statvfs vfs;
-
- if(statvfs(name, &vfs)==-1)
-@@ -3802,7 +3802,9 @@
- #elif TARGET==WIN32
- return(0);
- #elif TARGET==UNIX
-+ #ifndef __INTERIX
- sync();
-+ #endif
- return(0);
- #endif
- }
-diff -ru arj-3.10.22.orig/gnu/configure.in arj-3.10.22/gnu/configure.in
---- arj-3.10.22.orig/gnu/configure.in 2008-03-30 16:51:40 +0200
-+++ arj-3.10.22/gnu/configure.in 2008-03-30 16:41:37 +0200
-@@ -67,8 +67,9 @@
- DLL_EXT=".dylib"
- DLL_FLAGS=""
- ;;
--interix3*)
-+interix*)
- # not ELF
-+ DYN_LIBS="-ldl"
- DLL_FLAGS="-shared"
- DLL_CFLAGS=""
- ;;