summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/brotli')
-rw-r--r--app-arch/brotli/Manifest1
-rw-r--r--app-arch/brotli/brotli-1.0.9-r6.ebuild (renamed from app-arch/brotli/brotli-1.0.9-r4.ebuild)28
-rw-r--r--app-arch/brotli/brotli-1.1.0.ebuild (renamed from app-arch/brotli/brotli-1.0.9-r3.ebuild)65
-rw-r--r--app-arch/brotli/brotli-9999.ebuild36
-rw-r--r--app-arch/brotli/metadata.xml1
5 files changed, 92 insertions, 39 deletions
diff --git a/app-arch/brotli/Manifest b/app-arch/brotli/Manifest
index 3af0701200a7..9f804bc4a3fd 100644
--- a/app-arch/brotli/Manifest
+++ b/app-arch/brotli/Manifest
@@ -1,2 +1,3 @@
DIST brotli-1.0.9.tar.gz 486984 BLAKE2B 8b9939d5224396ef33b43e019250ba4bc8949903583615e8dc02c85340fc0a1e2d1632161e00b0ee7355d77f05529ac772f482e05d2089afd71a0bf71e803904 SHA512 b8e2df955e8796ac1f022eb4ebad29532cb7e3aa6a4b6aee91dbd2c7d637eee84d9a144d3e878895bb5e62800875c2c01c8f737a1261020c54feacf9f676b5f5
DIST brotli-1.0.9.testdata.tar.xz 3771536 BLAKE2B e22a7e926a68b64cf3ddcf90d2381201d0bac6486f28c3a675c83a2a685108491011195faf48df9abd478a011e874df560ae81988348f7605197805cc3be20dd SHA512 d98c48dbc7772959a9cf276b638cf773a05a896c9daf4f6235f7d7fd625490b3f538e0690afcd6968ff81ad3745c7d78419850c2518048c44d73b470bcd08c97
+DIST brotli-1.1.0.tar.gz 511969 BLAKE2B 7ac767fd6dafaabfb4e3834d690f71abceb4d4e7f131849d6c328a04f3a16c54d0a9463a37f03663a4158c35e970a089512c8a5bc43eda79fb43c1f61223379e SHA512 6eb280d10d8e1b43d22d00fa535435923c22ce8448709419d676ff47d4a644102ea04f488fc65a179c6c09fee12380992e9335bad8dfebd5d1f20908d10849d9
diff --git a/app-arch/brotli/brotli-1.0.9-r4.ebuild b/app-arch/brotli/brotli-1.0.9-r6.ebuild
index f206ce927497..7a77db722acd 100644
--- a/app-arch/brotli/brotli-1.0.9-r4.ebuild
+++ b/app-arch/brotli/brotli-1.0.9-r6.ebuild
@@ -1,19 +1,20 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+DISTUTILS_EXT=1
DISTUTILS_OPTIONAL="1"
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
-inherit cmake-multilib distutils-r1
+inherit cmake-multilib distutils-r1 flag-o-matic
if [[ ${PV} == *9999* ]] ; then
EGIT_REPO_URI="https://github.com/google/${PN}.git"
inherit git-r3
else
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
SRC_URI="
https://github.com/google/${PN}/archive/v${PV}.tar.gz
-> ${P}.tar.gz
@@ -38,6 +39,16 @@ RDEPEND="
DEPEND="
${RDEPEND}
"
+BDEPEND="
+ python? (
+ ${DISTUTILS_DEPS}
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/unittest-or-fail[${PYTHON_USEDEP}]
+ ' 3.{9..11})
+ )
+ )
+"
DOCS=( README.md CONTRIBUTING.md )
@@ -56,6 +67,8 @@ multilib_src_configure() {
}
src_configure() {
+ append-lfs-flags
+
cmake-multilib_src_configure
use python && distutils-r1_src_configure
}
@@ -83,4 +96,11 @@ multilib_src_install() {
multilib_src_install_all() {
use python && distutils-r1_src_install
+
+ doman docs/brotli.1
+
+ local page
+ for page in constants decode encode types ; do
+ newman docs/${page}.h.3 ${PN}_${page}.h.3
+ done
}
diff --git a/app-arch/brotli/brotli-1.0.9-r3.ebuild b/app-arch/brotli/brotli-1.1.0.ebuild
index 1db41cf450c3..af761fb90b3f 100644
--- a/app-arch/brotli/brotli-1.0.9-r3.ebuild
+++ b/app-arch/brotli/brotli-1.1.0.ebuild
@@ -1,39 +1,54 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+DISTUTILS_EXT=1
DISTUTILS_OPTIONAL="1"
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit cmake-multilib distutils-r1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit cmake-multilib distutils-r1 flag-o-matic
if [[ ${PV} == *9999* ]] ; then
EGIT_REPO_URI="https://github.com/google/${PN}.git"
inherit git-r3
else
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
- SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="
+ https://github.com/google/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+ "
fi
DESCRIPTION="Generic-purpose lossless compression algorithm"
-HOMEPAGE="https://github.com/google/brotli"
+HOMEPAGE="https://github.com/google/brotli/"
LICENSE="MIT python? ( Apache-2.0 )"
SLOT="0/$(ver_cut 1)"
-IUSE="python static-libs test"
-
+IUSE="python test"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-# tests are currently broken, see https://github.com/google/brotli/issues/850
-RESTRICT="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ python? (
+ ${DISTUTILS_DEPS}
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/unittest-or-fail[${PYTHON_USEDEP}]
+ ' 3.{9..11})
+ )
+ )
+"
DOCS=( README.md CONTRIBUTING.md )
-PATCHES=( "${FILESDIR}/${PV}-linker.patch" )
-
-RDEPEND="python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}"
-
src_prepare() {
cmake_src_prepare
use python && distutils-r1_src_prepare
@@ -45,26 +60,23 @@ multilib_src_configure() {
)
cmake_src_configure
}
+
src_configure() {
+ append-lfs-flags
+
cmake-multilib_src_configure
use python && distutils-r1_src_configure
}
-multilib_src_compile() {
- cmake_src_compile
-}
src_compile() {
cmake-multilib_src_compile
use python && distutils-r1_src_compile
}
python_test() {
- esetup.py test || die
+ eunittest -s python -p "*_test.py"
}
-multilib_src_test() {
- cmake_src_test
-}
src_test() {
cmake-multilib_src_test
use python && distutils-r1_src_test
@@ -72,8 +84,15 @@ src_test() {
multilib_src_install() {
cmake_src_install
- use static-libs || rm "${ED}"/usr/$(get_libdir)/*.a || die
}
+
multilib_src_install_all() {
use python && distutils-r1_src_install
+
+ doman docs/brotli.1
+
+ local page
+ for page in constants decode encode types ; do
+ newman docs/${page}.h.3 ${PN}_${page}.h.3
+ done
}
diff --git a/app-arch/brotli/brotli-9999.ebuild b/app-arch/brotli/brotli-9999.ebuild
index f206ce927497..53768510bba9 100644
--- a/app-arch/brotli/brotli-9999.ebuild
+++ b/app-arch/brotli/brotli-9999.ebuild
@@ -1,13 +1,14 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+DISTUTILS_EXT=1
DISTUTILS_OPTIONAL="1"
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
-inherit cmake-multilib distutils-r1
+inherit cmake-multilib distutils-r1 flag-o-matic
if [[ ${PV} == *9999* ]] ; then
EGIT_REPO_URI="https://github.com/google/${PN}.git"
@@ -17,9 +18,6 @@ else
SRC_URI="
https://github.com/google/${PN}/archive/v${PV}.tar.gz
-> ${P}.tar.gz
- test? (
- https://dev.gentoo.org/~mgorny/dist/${P}.testdata.tar.xz
- )
"
fi
@@ -28,7 +26,7 @@ HOMEPAGE="https://github.com/google/brotli/"
LICENSE="MIT python? ( Apache-2.0 )"
SLOT="0/$(ver_cut 1)"
-IUSE="python static-libs test"
+IUSE="python test"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RESTRICT="!test? ( test )"
@@ -38,11 +36,19 @@ RDEPEND="
DEPEND="
${RDEPEND}
"
+BDEPEND="
+ python? (
+ ${DISTUTILS_DEPS}
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/unittest-or-fail[${PYTHON_USEDEP}]
+ ' 3.{9..11})
+ )
+ )
+"
DOCS=( README.md CONTRIBUTING.md )
-PATCHES=( "${FILESDIR}/${PV}-linker.patch" )
-
src_prepare() {
cmake_src_prepare
use python && distutils-r1_src_prepare
@@ -56,6 +62,8 @@ multilib_src_configure() {
}
src_configure() {
+ append-lfs-flags
+
cmake-multilib_src_configure
use python && distutils-r1_src_configure
}
@@ -76,11 +84,15 @@ src_test() {
multilib_src_install() {
cmake_src_install
- if ! use static-libs; then
- rm "${ED}"/usr/$(get_libdir)/*.a || die
- fi
}
multilib_src_install_all() {
use python && distutils-r1_src_install
+
+ doman docs/brotli.1
+
+ local page
+ for page in constants decode encode types ; do
+ newman docs/${page}.h.3 ${PN}_${page}.h.3
+ done
}
diff --git a/app-arch/brotli/metadata.xml b/app-arch/brotli/metadata.xml
index f2f000701cc0..2b14295d52d7 100644
--- a/app-arch/brotli/metadata.xml
+++ b/app-arch/brotli/metadata.xml
@@ -16,6 +16,7 @@
deflate but offers denser compression.
</longdescription>
<upstream>
+ <remote-id type="cpe">cpe:/a:google:brotli</remote-id>
<remote-id type="github">google/brotli</remote-id>
</upstream>
</pkgmetadata>