summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/bzip2/bzip2-9999.ebuild')
-rw-r--r--app-arch/bzip2/bzip2-9999.ebuild41
1 files changed, 19 insertions, 22 deletions
diff --git a/app-arch/bzip2/bzip2-9999.ebuild b/app-arch/bzip2/bzip2-9999.ebuild
index a5f4b823c2f1..e8b4774ac56e 100644
--- a/app-arch/bzip2/bzip2-9999.ebuild
+++ b/app-arch/bzip2/bzip2-9999.ebuild
@@ -1,24 +1,28 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit meson-multilib usr-ldscript
DESCRIPTION="A high-quality data compressor used extensively by Gentoo Linux"
-HOMEPAGE="https://gitlab.com/federicomenaquintero/bzip2"
-if [[ "${PV}" == 9999 ]] ; then
+HOMEPAGE="https://gitlab.com/bzip2/bzip2"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://gitlab.com/bzip2/bzip2"
inherit git-r3
- EGIT_REPO_URI="https://gitlab.com/federicomenaquintero/bzip2.git"
else
- SRC_URI=""
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos"
fi
+
LICENSE="BZIP2"
SLOT="0/1" # subslot = SONAME
IUSE="static-libs"
+PDEPEND="
+ app-alternatives/bzip2
+"
+
multilib_src_configure() {
local emesonargs=(
-Ddefault_library=$(usex static-libs both shared)
@@ -32,25 +36,19 @@ multilib_src_configure() {
multilib_src_install() {
meson_src_install
- # Install libbz2.so.1.0 due to accidental soname change in 1.0.7.
- # Reference: 98da0ad82192d21ad74ae52366ea8466e2acea24.
- # OK to remove one year after 2020-04-11.
- if [[ ! -L "${ED}/usr/$(get_libdir)/libbz2.so.1.0" ]]; then
- dosym libbz2.so.1 "/usr/$(get_libdir)/libbz2.so.1.0"
- fi
-
if multilib_is_native_abi ; then
gen_usr_ldscript -a bz2
-
- dodir /bin
- mv "${ED}"/usr/bin/bzip2 "${ED}"/bin || die
fi
}
multilib_src_install_all() {
- # move "important" bzip2 binaries to /bin and use the shared libbz2.so
- dosym bzip2 /bin/bzcat
- dosym bzip2 /bin/bunzip2
+ dodir /bin
+ mv "${ED}"/usr/bin/bzip2 "${ED}"/bin/bzip2-reference || die
+ mv "${ED}"/usr/share/man/man1/bzip2{,-reference}.1 || die
+
+ # moved to app-alternatives/bzip2
+ rm "${ED}"/usr/bin/{bzcat,bunzip2} || die
+ rm "${ED}"/usr/share/man/man1/{bzcat,bunzip2.1} || die
dosym bzdiff /usr/bin/bzcmp
dosym bzmore /usr/bin/bzless
@@ -59,8 +57,7 @@ multilib_src_install_all() {
dosym bzgrep /usr/bin/${x}
done
- dosym bzip2.1 /usr/share/man/man1/bzip2recover.1
+ dosym bzip2-reference.1 /usr/share/man/man1/bzip2recover.1
- local DOCS=( AUTHORS NEWS{,-pre-1.0.7} README.md )
einstalldocs
}