summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/bzip3')
-rw-r--r--app-arch/bzip3/Manifest1
-rw-r--r--app-arch/bzip3/bzip3-1.4.0.ebuild32
-rw-r--r--app-arch/bzip3/metadata.xml21
3 files changed, 54 insertions, 0 deletions
diff --git a/app-arch/bzip3/Manifest b/app-arch/bzip3/Manifest
new file mode 100644
index 000000000000..ae651b30a1be
--- /dev/null
+++ b/app-arch/bzip3/Manifest
@@ -0,0 +1 @@
+DIST bzip3-1.4.0.tar.xz 278424 BLAKE2B d3e4ae283d3b4512e70ffe3ef63c4ee4fe6f7a0a272aacfe67aae155aed547b54c7e46bce2448b140c7af58ec968b33a1ea7660ffa492bd6bf6eed9fd9f9c4d1 SHA512 584eb77b3071b09c15f20ec88248c9295ca2107107fdcb0495364ac60807c688d167a6cbbdd1b67cc851cbebc0791661ecb44b4d03ca5fb7d2b89ce839452062
diff --git a/app-arch/bzip3/bzip3-1.4.0.ebuild b/app-arch/bzip3/bzip3-1.4.0.ebuild
new file mode 100644
index 000000000000..7cdf987ce525
--- /dev/null
+++ b/app-arch/bzip3/bzip3-1.4.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A better and stronger spiritual successor to BZip2"
+HOMEPAGE="https://github.com/kspalaiologos/bzip3"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kspalaiologos/${PN}.git"
+else
+ SRC_URI="https://github.com/kspalaiologos/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="amd64 arm64 ~loong x86"
+fi
+
+LICENSE="LGPL-3+"
+SLOT="0"
+
+src_configure() {
+ # ./configure script will default to Clang if it is found on the system,
+ # force the use of CC selected by the user with CC=$(tc-getCC)
+ econf CC=$(tc-getCC)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}
diff --git a/app-arch/bzip3/metadata.xml b/app-arch/bzip3/metadata.xml
new file mode 100644
index 000000000000..5dee14e0081f
--- /dev/null
+++ b/app-arch/bzip3/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ A better, faster and stronger spiritual successor to BZip2. Features higher
+ compression ratios and better performance thanks to a order-0 context
+ mixing entropy coder, a fast Burrows-Wheeler transform code making use of
+ suffix arrays and a RLE with Lempel Ziv+Prediction pass based on LZ77-style
+ string matching and PPM-style context modeling.
+ Like its ancestor, BZip3 excels at compressing text or code.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/kspalaiologos/bzip3/issues/</bugs-to>
+ <remote-id type="github">kspalaiologos/bzip3</remote-id>
+ </upstream>
+</pkgmetadata>