summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/dpkg/dpkg-1.21.1.ebuild')
-rw-r--r--app-arch/dpkg/dpkg-1.21.1.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/app-arch/dpkg/dpkg-1.21.1.ebuild b/app-arch/dpkg/dpkg-1.21.1.ebuild
index 2a6982311b44..1155e0f445a1 100644
--- a/app-arch/dpkg/dpkg-1.21.1.ebuild
+++ b/app-arch/dpkg/dpkg-1.21.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit multilib autotools toolchain-funcs
+inherit autotools toolchain-funcs
DESCRIPTION="Package maintenance system for Debian"
HOMEPAGE="https://packages.qa.debian.org/dpkg"
@@ -10,7 +10,7 @@ SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.xz"
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="+bzip2 libmd +lzma nls selinux static-libs test unicode +update-alternatives +zlib"
RESTRICT="!test? ( test )"
@@ -35,7 +35,7 @@ DEPEND="
)
"
BDEPEND="
- sys-devel/flex
+ app-alternatives/lex
nls? (
app-text/po4a
>=sys-devel/gettext-0.18.2
@@ -78,7 +78,7 @@ src_configure() {
}
src_compile() {
- emake AR=$(tc-getAR)
+ emake AR="$(tc-getAR)"
}
src_install() {