summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/dpkg')
-rw-r--r--app-arch/dpkg/Manifest1
-rw-r--r--app-arch/dpkg/dpkg-1.19.1.ebuild90
-rw-r--r--app-arch/dpkg/metadata.xml1
3 files changed, 92 insertions, 0 deletions
diff --git a/app-arch/dpkg/Manifest b/app-arch/dpkg/Manifest
index 832ba163aa0a..224d399150fa 100644
--- a/app-arch/dpkg/Manifest
+++ b/app-arch/dpkg/Manifest
@@ -1 +1,2 @@
DIST dpkg_1.19.0.5.tar.xz 4557428 BLAKE2B 99c31705bfad1cfa024366c788264f4e747a7143f87c581730797975303c1054003e41fd65ecf80df1dc053ba87c0e8449ec574ddcb158228b41ae57a23db18f SHA512 60d7198ffe6ea759c30ad82143b3107d41ce59224b853cb5a7beb79af0de6ba6a69414c365e6b3555a0a9c60e3cf9b543a3a448d80a734be38ccecb77ae963a9
+DIST dpkg_1.19.1.tar.xz 4600848 BLAKE2B daadc95f0f66312e6012a5c9ce053dba055d87f766d8e9b9e99ed3eed59e83616b89cb2324fc61205bf4e22388cc0f9f62d191cbdd858250a50f7c6d141adf7d SHA512 d2c745f8cc3db94be15ce3ef74f9317768b316d9bb96aac2c681c2f47433524774e0c2d5ff3daf6e7cc779e5ffc4ce96783de12802f32dab1d72022786ca6c20
diff --git a/app-arch/dpkg/dpkg-1.19.1.ebuild b/app-arch/dpkg/dpkg-1.19.1.ebuild
new file mode 100644
index 000000000000..fba3abe2ea03
--- /dev/null
+++ b/app-arch/dpkg/dpkg-1.19.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils multilib autotools toolchain-funcs
+
+DESCRIPTION="Package maintenance system for Debian"
+HOMEPAGE="https://packages.qa.debian.org/dpkg"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
+IUSE="+bzip2 libmd +lzma nls selinux static-libs test unicode +update-alternatives +zlib"
+
+RDEPEND="
+ >=dev-lang/perl-5.14.2:=
+ bzip2? ( app-arch/bzip2 )
+ libmd? ( app-crypt/libmd )
+ lzma? ( app-arch/xz-utils )
+ selinux? ( sys-libs/libselinux )
+ zlib? ( >=sys-libs/zlib-1.1.4 )
+"
+DEPEND="
+ ${RDEPEND}
+ app-arch/xz-utils
+ sys-devel/flex
+ virtual/pkgconfig
+ nls? (
+ app-text/po4a
+ >=sys-devel/gettext-0.18.2
+ )
+ test? (
+ dev-perl/IO-String
+ dev-perl/Test-Pod
+ virtual/perl-Test-Harness
+ )
+"
+DOCS=(
+ ChangeLog
+ THANKS
+ TODO
+)
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.18.12-dpkg_buildpackage-test.patch
+ "${FILESDIR}"/${PN}-1.18.12-flags.patch
+ "${FILESDIR}"/${PN}-1.18.12-rsyncable.patch
+)
+
+src_prepare() {
+ use nls && strip-linguas -i po
+
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+ econf \
+ $(use_enable nls) \
+ $(use_enable static-libs static) \
+ $(use_enable unicode) \
+ $(use_enable update-alternatives) \
+ $(use_with bzip2 libbz2) \
+ $(use_with libmd) \
+ $(use_with lzma liblzma) \
+ $(use_with selinux libselinux) \
+ $(use_with zlib libz) \
+ --disable-compiler-warnings \
+ --disable-dselect \
+ --disable-silent-rules \
+ --disable-start-stop-daemon \
+ --localstatedir="${EPREFIX}"/var
+}
+
+src_compile() {
+ emake AR=$(tc-getAR)
+}
+
+src_install() {
+ default
+
+ keepdir \
+ /usr/$(get_libdir)/db/methods/{mnt,floppy,disk} \
+ /var/lib/dpkg/{alternatives,info,parts,updates}
+# /usr/$(get_libdir)/db/{alternatives,info,parts,updates} \
+
+ prune_libtool_files
+}
diff --git a/app-arch/dpkg/metadata.xml b/app-arch/dpkg/metadata.xml
index 029c83c94699..f7244bcd0e2b 100644
--- a/app-arch/dpkg/metadata.xml
+++ b/app-arch/dpkg/metadata.xml
@@ -6,6 +6,7 @@
<name>Gentoo Debian Tools Project</name>
</maintainer>
<use>
+<flag name="libmd">Use <pkg>app-crypt/libmd</pkg> library for message digest functions</flag>
<flag name="update-alternatives">Install update-alternatives</flag>
</use>
</pkgmetadata>