summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/file-roller')
-rw-r--r--app-arch/file-roller/Manifest4
-rw-r--r--app-arch/file-roller/file-roller-44.1.ebuild103
-rw-r--r--app-arch/file-roller/file-roller-44.3.ebuild103
-rw-r--r--app-arch/file-roller/file-roller-44.ebuild (renamed from app-arch/file-roller/file-roller-3.40.0.ebuild)38
-rw-r--r--app-arch/file-roller/files/3.36-packages.match2
-rw-r--r--app-arch/file-roller/metadata.xml23
6 files changed, 245 insertions, 28 deletions
diff --git a/app-arch/file-roller/Manifest b/app-arch/file-roller/Manifest
index e754e09a8ae1..06e2e2041ad3 100644
--- a/app-arch/file-roller/Manifest
+++ b/app-arch/file-roller/Manifest
@@ -1 +1,3 @@
-DIST file-roller-3.40.0.tar.xz 876424 BLAKE2B fa2483677869d5a6b4ac91938eac6bf09965177ffa07bab76a77a0be58e331466f939e7e0728d5eeeb5703c6ff12f178f8080922f8ae9d726e77700bbbd518ed SHA512 224dbe4f4358aa62589d084d67244ad8d65d718f9b6adf708ba1425b38fca68e08b07a6163f66d95c6acfd164b6062939cfeb27873ea41353e0551e322b0eb26
+DIST file-roller-44.1.tar.xz 927156 BLAKE2B 60ced1711298989eda90a675095b5e7b8f1e9b84b5f4cf364bce4683ba9eac6a8a4a1857b0248cd9a49ea2161cbc5c2c36df94ebc164e195de528ba50220d1da SHA512 de0d0ce93ecba822ec495227cd484cb164a81f8b5349033d80207acc19584985f0c88bfa766a46468349e2b16b020371e2e6b73b4fb7f2f18f40f115f2391b30
+DIST file-roller-44.3.tar.xz 1042572 BLAKE2B 8fa5c474f96e739f141ee3c94ed002a127c09e941125832f043c914fcdbc1a2306ad1649bb51e9a6207ad7147c7862f0fdc5ad3703a244b447fe4262801107a3 SHA512 940e67cef0a3e71f7c60aea67419666d92c3861b6c7e20dfd50cd055ec590013702b941c938eea3375878a997c377102bc8480d06fd28e0eb8d8f6660ba1df38
+DIST file-roller-44.tar.xz 924236 BLAKE2B 12eebd312afdec8f87141d384d1476be7296073f911791328158af1ab93fcb4092ee79e0c65743c36eaa28e06b5b59503357b6c4cff87b4896d3969a67d08e45 SHA512 d40ac036161397828ded2bab7bdf1c029ef0b53fad65e0922e6eeec40442eb7a9898a7d5c3208f6dfda3ad6f51b0771f248ab64c177769b655493a44c403f824
diff --git a/app-arch/file-roller/file-roller-44.1.ebuild b/app-arch/file-roller/file-roller-44.1.ebuild
new file mode 100644
index 000000000000..6b9c0f7cfa2c
--- /dev/null
+++ b/app-arch/file-roller/file-roller-44.1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson readme.gentoo-r1 xdg
+
+DESCRIPTION="Archive manager for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/FileRoller"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="gtk-doc +introspection nautilus"
+REQUIRED_USE="gtk-doc? ( introspection )"
+
+# gdk-pixbuf used extensively in the source
+# cairo used in eggtreemultidnd.c
+# pango used in fr-window
+RDEPEND="
+ >=dev-libs/glib-2.38:2
+ >=gui-libs/gtk-4.8.1:4[introspection?]
+ >=gui-libs/libadwaita-1.2:1
+ nautilus? ( >=gnome-base/nautilus-43.0 )
+ >=dev-libs/json-glib-0.14
+ >=app-arch/libarchive-3.2:=
+ introspection? ( dev-libs/gobject-introspection )
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gi-docgen )
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+${PN} is a frontend for several archiving utilities. If you want a
+particular archive format support, see ${HOMEPAGE}
+and install the relevant package. For example:
+7-zip - app-arch/p7zip
+ace - app-arch/unace
+arj - app-arch/arj
+brotli - app-arch/brotli
+cpio - app-alternatives/cpio
+deb - app-arch/dpkg
+iso - app-cdr/cdrtools
+jar,zip - app-arch/zip and app-arch/unzip
+lha - app-arch/lha
+lzop - app-arch/lzop
+lz4 - app-arch/lz4
+rar - app-arch/unrar or app-arch/unar
+rpm - app-arch/rpm
+unstuff - app-arch/stuffit
+zstd - app-arch/zstd
+zoo - app-arch/zoo"
+
+src_prepare() {
+ # File providing Gentoo package names for various archivers
+ cp -v "${FILESDIR}"/3.36-packages.match data/packages.match || die
+
+ default
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Drun-in-place=false
+ $(meson_feature nautilus nautilus-actions)
+ -Dnotification=enabled
+ -Duse_native_appchooser=false
+ -Dpackagekit=false
+ -Dlibarchive=enabled
+ $(meson_feature introspection)
+ $(meson_feature gtk-doc api_docs)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/ || die
+ mv "${ED}"/usr/share/doc/file-roller "${ED}"/usr/share/gtk-doc/file-roller || die
+ fi
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/app-arch/file-roller/file-roller-44.3.ebuild b/app-arch/file-roller/file-roller-44.3.ebuild
new file mode 100644
index 000000000000..6b9c0f7cfa2c
--- /dev/null
+++ b/app-arch/file-roller/file-roller-44.3.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson readme.gentoo-r1 xdg
+
+DESCRIPTION="Archive manager for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/FileRoller"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="gtk-doc +introspection nautilus"
+REQUIRED_USE="gtk-doc? ( introspection )"
+
+# gdk-pixbuf used extensively in the source
+# cairo used in eggtreemultidnd.c
+# pango used in fr-window
+RDEPEND="
+ >=dev-libs/glib-2.38:2
+ >=gui-libs/gtk-4.8.1:4[introspection?]
+ >=gui-libs/libadwaita-1.2:1
+ nautilus? ( >=gnome-base/nautilus-43.0 )
+ >=dev-libs/json-glib-0.14
+ >=app-arch/libarchive-3.2:=
+ introspection? ( dev-libs/gobject-introspection )
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gi-docgen )
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+${PN} is a frontend for several archiving utilities. If you want a
+particular archive format support, see ${HOMEPAGE}
+and install the relevant package. For example:
+7-zip - app-arch/p7zip
+ace - app-arch/unace
+arj - app-arch/arj
+brotli - app-arch/brotli
+cpio - app-alternatives/cpio
+deb - app-arch/dpkg
+iso - app-cdr/cdrtools
+jar,zip - app-arch/zip and app-arch/unzip
+lha - app-arch/lha
+lzop - app-arch/lzop
+lz4 - app-arch/lz4
+rar - app-arch/unrar or app-arch/unar
+rpm - app-arch/rpm
+unstuff - app-arch/stuffit
+zstd - app-arch/zstd
+zoo - app-arch/zoo"
+
+src_prepare() {
+ # File providing Gentoo package names for various archivers
+ cp -v "${FILESDIR}"/3.36-packages.match data/packages.match || die
+
+ default
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Drun-in-place=false
+ $(meson_feature nautilus nautilus-actions)
+ -Dnotification=enabled
+ -Duse_native_appchooser=false
+ -Dpackagekit=false
+ -Dlibarchive=enabled
+ $(meson_feature introspection)
+ $(meson_feature gtk-doc api_docs)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/ || die
+ mv "${ED}"/usr/share/doc/file-roller "${ED}"/usr/share/gtk-doc/file-roller || die
+ fi
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/app-arch/file-roller/file-roller-3.40.0.ebuild b/app-arch/file-roller/file-roller-44.ebuild
index d3a992cb7102..dcb5b5610d53 100644
--- a/app-arch/file-roller/file-roller-3.40.0.ebuild
+++ b/app-arch/file-roller/file-roller-44.ebuild
@@ -1,39 +1,41 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
-inherit gnome.org gnome2-utils meson python-any-r1 readme.gentoo-r1 xdg
+EAPI=8
+
+inherit gnome.org gnome2-utils meson readme.gentoo-r1 xdg
DESCRIPTION="Archive manager for GNOME"
HOMEPAGE="https://wiki.gnome.org/Apps/FileRoller"
LICENSE="GPL-2+ CC-BY-SA-3.0"
SLOT="0"
-IUSE="libnotify nautilus"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 ~arm arm64 ~loong ~ppc ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux"
+IUSE="gtk-doc +introspection nautilus"
+REQUIRED_USE="gtk-doc? ( introspection )"
# gdk-pixbuf used extensively in the source
# cairo used in eggtreemultidnd.c
# pango used in fr-window
RDEPEND="
- >=app-arch/libarchive-3.2:=
>=dev-libs/glib-2.38:2
+ >=gui-libs/gtk-4.8.1:4[introspection?]
+ >=gui-libs/libadwaita-1.2:1
+ nautilus? ( >=gnome-base/nautilus-43.0 )
>=dev-libs/json-glib-0.14
- >=x11-libs/gtk+-3.22.0:3
+ >=app-arch/libarchive-3.2:=
+ introspection? ( dev-libs/gobject-introspection )
x11-libs/cairo
x11-libs/gdk-pixbuf:2
x11-libs/pango
- libnotify? ( >=x11-libs/libnotify-0.4.3:= )
- nautilus? ( >=gnome-base/nautilus-3.28.0 )
"
DEPEND="${RDEPEND}"
BDEPEND="
- ${PYTHON_DEPS}
dev-util/glib-utils
dev-util/itstool
>=sys-devel/gettext-0.19.8
virtual/pkgconfig
+ gtk-doc? ( dev-util/gi-docgen )
"
DISABLE_AUTOFORMATTING="yes"
@@ -45,7 +47,7 @@ and install the relevant package. For example:
ace - app-arch/unace
arj - app-arch/arj
brotli - app-arch/brotli
-cpio - app-arch/cpio
+cpio - app-alternatives/cpio
deb - app-arch/dpkg
iso - app-cdr/cdrtools
jar,zip - app-arch/zip and app-arch/unzip
@@ -62,22 +64,30 @@ src_prepare() {
# File providing Gentoo package names for various archivers
cp -v "${FILESDIR}"/3.36-packages.match data/packages.match || die
- xdg_src_prepare
+ default
+ xdg_environment_reset
}
src_configure() {
local emesonargs=(
-Drun-in-place=false
$(meson_feature nautilus nautilus-actions)
- $(meson_feature libnotify notification)
+ -Dnotification=enabled
+ -Duse_native_appchooser=false
-Dpackagekit=false
-Dlibarchive=enabled
+ $(meson_feature introspection)
+ $(meson_feature gtk-doc api_docs)
)
meson_src_configure
}
src_install() {
meson_src_install
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/ || die
+ mv "${ED}"/usr/share/doc/file-roller "${ED}"/usr/share/gtk-doc/file-roller || die
+ fi
readme.gentoo_create_doc
}
diff --git a/app-arch/file-roller/files/3.36-packages.match b/app-arch/file-roller/files/3.36-packages.match
index b494f5430a00..c84d4517a59b 100644
--- a/app-arch/file-roller/files/3.36-packages.match
+++ b/app-arch/file-roller/files/3.36-packages.match
@@ -3,7 +3,7 @@ arj=app-arch/arj
binutils=sys-devel/binutils
brotli=app-arch/brotli
bzip2=app-arch/bzip2
-cpio=app-arch/cpio
+cpio=app-alternatives/cpio
dpkg=app-arch/dpkg
genisoimage=app-cdr/cdrtools
gzip=app-arch/gzip
diff --git a/app-arch/file-roller/metadata.xml b/app-arch/file-roller/metadata.xml
index 9f23dc396c05..95e520228548 100644
--- a/app-arch/file-roller/metadata.xml
+++ b/app-arch/file-roller/metadata.xml
@@ -1,16 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
- </maintainer>
- <use>
- <flag name="nautilus">Build contextual menu extension for
- <pkg>gnome-base/nautilus</pkg>.</flag>
- </use>
- <upstream>
- <remote-id type="sourceforge">fileroller</remote-id>
- <remote-id type="cpe">cpe:/a:paolo_bacchilega:file_roller</remote-id>
- </upstream>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <use>
+ <flag name="nautilus">Build contextual menu extension for <pkg>gnome-base/nautilus</pkg>.</flag>
+ </use>
+ <upstream>
+ <remote-id type="cpe">cpe:/a:paolo_bacchilega:file_roller</remote-id>
+ <remote-id type="gnome-gitlab">GNOME/file-roller</remote-id>
+ </upstream>
</pkgmetadata>