summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/innoextract')
-rw-r--r--app-arch/innoextract/files/innoextract-1.9-boost-1.85.0.patch21
-rw-r--r--app-arch/innoextract/innoextract-1.9.ebuild5
2 files changed, 24 insertions, 2 deletions
diff --git a/app-arch/innoextract/files/innoextract-1.9-boost-1.85.0.patch b/app-arch/innoextract/files/innoextract-1.9-boost-1.85.0.patch
new file mode 100644
index 000000000000..23e4554fc53e
--- /dev/null
+++ b/app-arch/innoextract/files/innoextract-1.9-boost-1.85.0.patch
@@ -0,0 +1,21 @@
+https://bugs.gentoo.org/930495
+https://github.com/dscharrer/innoextract/pull/169
+
+From 264c2fe6b84f90f6290c670e5f676660ec7b2387 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Bernhard=20Rosenkr=C3=A4nzer?= <bero@lindev.ch>
+Date: Thu, 28 Mar 2024 15:11:40 +0100
+Subject: [PATCH] Fix build with boost 1.85
+
+As of boost 1.85-beta1, boost/filesystem/directory.hpp is no longer
+implicitly included by boost/filesystem/operations.hpp. Include it
+explicitly.
+--- a/src/stream/slice.cpp
++++ b/src/stream/slice.cpp
+@@ -27,6 +27,7 @@
+ #include <boost/cstdint.hpp>
+ #include <boost/algorithm/string/predicate.hpp>
+ #include <boost/filesystem/operations.hpp>
++#include <boost/filesystem/directory.hpp>
+ #include <boost/range/size.hpp>
+
+ #include "util/console.hpp"
diff --git a/app-arch/innoextract/innoextract-1.9.ebuild b/app-arch/innoextract/innoextract-1.9.ebuild
index 65728eeabe9a..2259b5ffb6d3 100644
--- a/app-arch/innoextract/innoextract-1.9.ebuild
+++ b/app-arch/innoextract/innoextract-1.9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -11,7 +11,7 @@ SRC_URI="https://constexpr.org/innoextract/files/${P}.tar.gz"
LICENSE="ZLIB"
SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~m68k x86"
+KEYWORDS="amd64 ~arm arm64 ~m68k ppc64 x86"
IUSE="debug +iconv +lzma"
RDEPEND="
@@ -22,6 +22,7 @@ DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}/${PN}-1.9-fix-linkage.patch"
+ "${FILESDIR}/${PN}-1.9-boost-1.85.0.patch"
)
src_configure() {