summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/lbzip2')
-rw-r--r--app-arch/lbzip2/files/lbzip2-2.5_p20181227-clang16-musl-info.patch21
-rw-r--r--app-arch/lbzip2/files/lbzip2-2.5_p20181227-clang16.patch27
-rw-r--r--app-arch/lbzip2/lbzip2-2.5_p20181227-r2.ebuild (renamed from app-arch/lbzip2/lbzip2-2.5_p20181227-r1.ebuild)20
-rw-r--r--app-arch/lbzip2/metadata.xml3
4 files changed, 53 insertions, 18 deletions
diff --git a/app-arch/lbzip2/files/lbzip2-2.5_p20181227-clang16-musl-info.patch b/app-arch/lbzip2/files/lbzip2-2.5_p20181227-clang16-musl-info.patch
new file mode 100644
index 000000000000..cab651805476
--- /dev/null
+++ b/app-arch/lbzip2/files/lbzip2-2.5_p20181227-clang16-musl-info.patch
@@ -0,0 +1,21 @@
+Bug: https://bugs.gentoo.org/894320
+--- a/src/common.h
++++ b/src/common.h
+@@ -35,6 +35,7 @@
+
+ /* Tracing, useful in debugging, but not officially supported. */
+ #ifdef ENABLE_TRACING
++#include "main.h" /* Needed for info */
+ #define Trace(x) info x
+ #else
+ #define Trace(x)
+--- a/src/main.h
++++ b/src/main.h
+@@ -20,6 +20,7 @@
+ along with lbzip2. If not, see <http://www.gnu.org/licenses/>.
+ */
+
++#pragma once
+ #include <limits.h> /* CHAR_BIT */
+
+ #if 8 != CHAR_BIT
diff --git a/app-arch/lbzip2/files/lbzip2-2.5_p20181227-clang16.patch b/app-arch/lbzip2/files/lbzip2-2.5_p20181227-clang16.patch
new file mode 100644
index 000000000000..7342b19cd027
--- /dev/null
+++ b/app-arch/lbzip2/files/lbzip2-2.5_p20181227-clang16.patch
@@ -0,0 +1,27 @@
+https://github.com/kjn/lbzip2/pull/33
+
+From 32b5167940ec817e454431956040734af405a9de Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Thu, 5 Jan 2023 18:02:26 +0100
+Subject: [PATCH] Define the GNULIB_XALLOC_DIE macro
+
+This avoids an implicit function declaration when building gnulib's
+xmalloc.c, addressing a build failure with future compiler version.
+
+Solution proposed by Bruno Haible here:
+
+ Re: xmalloc calling undeclared xalloc_die function
+ <https://lists.gnu.org/archive/html/bug-gnulib/2022-12/msg00038.html>
+--- a/configure.ac
++++ b/configure.ac
+@@ -31,6 +31,9 @@ AC_PROG_LN_S
+ AC_PROG_RANLIB
+ AC_PROG_CC_C89
+
++AC_DEFINE(GNULIB_XALLOC_DIE, 1,
++ [This package is providing its own definition of the xalloc_die function.])
++
+ gl_ASSERT_NO_GNULIB_TESTS
+ gl_ASSERT_NO_GNULIB_POSIXCHECK
+ gl_EARLY
+
diff --git a/app-arch/lbzip2/lbzip2-2.5_p20181227-r1.ebuild b/app-arch/lbzip2/lbzip2-2.5_p20181227-r2.ebuild
index 3cd1be6ca754..b92a6e2fff28 100644
--- a/app-arch/lbzip2/lbzip2-2.5_p20181227-r1.ebuild
+++ b/app-arch/lbzip2/lbzip2-2.5_p20181227-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=8
inherit autotools flag-o-matic
@@ -12,14 +12,13 @@ SRC_URI="https://dev.gentoo.org/~whissi/dist/${PN}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="debug static symlink"
-
-RDEPEND="symlink? ( !app-arch/pbzip2[symlink] )"
-DEPEND=""
+IUSE="debug static"
PATCHES=(
"${FILESDIR}"/${PN}-2.3-s_isreg.patch
"${FILESDIR}"/${P}-fix-unaligned.patch
+ "${FILESDIR}"/${P}-clang16.patch
+ "${FILESDIR}"/${P}-clang16-musl-info.patch
)
src_prepare() {
@@ -35,12 +34,3 @@ src_configure() {
)
econf "${myeconfargs[@]}"
}
-
-src_install() {
- default
-
- if use symlink; then
- dosym ${PN} /usr/bin/bzip2
- dosym lbunzip2 /usr/bin/bunzip2
- fi
-}
diff --git a/app-arch/lbzip2/metadata.xml b/app-arch/lbzip2/metadata.xml
index de430ef53ee7..b755b171f2bb 100644
--- a/app-arch/lbzip2/metadata.xml
+++ b/app-arch/lbzip2/metadata.xml
@@ -10,9 +10,6 @@
input-bound splitter even when decompressing .bz2 files created by standard
bzip2
</longdescription>
- <use>
- <flag name="symlink">Install symlinks which override <pkg>app-arch/bzip2</pkg> implementation</flag>
- </use>
<upstream>
<remote-id type="github">kjn/lbzip2</remote-id>
</upstream>