summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/lrzip')
-rw-r--r--app-arch/lrzip/Manifest2
-rw-r--r--app-arch/lrzip/files/lrzip-0.631-solaris.patch11
-rw-r--r--app-arch/lrzip/files/lrzip-missing-stdarg_h.patch11
-rw-r--r--app-arch/lrzip/lrzip-0.651.ebuild (renamed from app-arch/lrzip/lrzip-0.641-r1.ebuild)40
-rw-r--r--app-arch/lrzip/metadata.xml5
5 files changed, 25 insertions, 44 deletions
diff --git a/app-arch/lrzip/Manifest b/app-arch/lrzip/Manifest
index 82812d245266..4d81e8d9358a 100644
--- a/app-arch/lrzip/Manifest
+++ b/app-arch/lrzip/Manifest
@@ -1 +1 @@
-DIST lrzip-0.641.tar.gz 262761 BLAKE2B 5a81d9ca8b40c141c90488e9ffcd1dfd5bef3fe7cf9b02c00b9382cd902ef8cd891401f21c9cdd5d5750daf639c05a1e6f1f010fcbf42a9cdaa4f11921fac783 SHA512 cb14dda15485faa24cb840dd94ecd4741bd47464770ae8b27f97b5c263d8a32e40ceb17b288f0f70426598ef2acf84b091593fc8cf7a0f2db0abde88d09a301f
+DIST lrzip-0.651.tar.gz 238854 BLAKE2B 2680867ccbee6ff669581017c9bb22db4d7eba0fda80b935bd088191809cb8baa833a03e7732cd1fe5a0487edfe577b34f34dcdcda121c114145bff9fc17ba79 SHA512 97671c4705bc06dfd037e38f4384a5ffaf2e3508da217406ac43642b88eae16576818a378bce519812204fecefbd6552a75fc3e74af729ab7b11724b7a6d1998
diff --git a/app-arch/lrzip/files/lrzip-0.631-solaris.patch b/app-arch/lrzip/files/lrzip-0.631-solaris.patch
deleted file mode 100644
index d8eb95e563d2..000000000000
--- a/app-arch/lrzip/files/lrzip-0.631-solaris.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/liblrzip.c
-+++ b/liblrzip.c
-@@ -36,7 +36,7 @@
- #include "lrzip_core.h"
- #include "rzip.h"
-
--#if defined(__APPLE__) || defined(__FreeBSD__)
-+#if defined(__APPLE__) || defined(__FreeBSD__) || defined(__sun) || defined(sun)
- # define fmemopen(s, len, modes) fake_fmemopen((s), (len), (modes))
- static FILE *fake_fmemopen(void *buf, size_t buflen, const char *mode)
- {
diff --git a/app-arch/lrzip/files/lrzip-missing-stdarg_h.patch b/app-arch/lrzip/files/lrzip-missing-stdarg_h.patch
deleted file mode 100644
index 8f427d46a6a1..000000000000
--- a/app-arch/lrzip/files/lrzip-missing-stdarg_h.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -Naur Lrzip.h.orig Lrzip.h
---- a/Lrzip.h 2013-11-30 20:07:27.343086997 +0000
-+++ b/Lrzip.h 2013-11-30 20:07:44.072641056 +0000
-@@ -22,6 +22,7 @@
-
- #include <stdbool.h>
- #include <stdio.h>
-+#include <stdarg.h>
- #ifdef _WIN32
- # include <stddef.h>
- #else
diff --git a/app-arch/lrzip/lrzip-0.641-r1.ebuild b/app-arch/lrzip/lrzip-0.651.ebuild
index 6c8ec1c9d02f..6e0a4f4510ab 100644
--- a/app-arch/lrzip/lrzip-0.641-r1.ebuild
+++ b/app-arch/lrzip/lrzip-0.651.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools
@@ -11,25 +11,17 @@ SRC_URI="https://github.com/ckolivas/lrzip/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~ppc-macos ~x64-macos ~x64-solaris"
IUSE="static-libs"
-RDEPEND="
- app-arch/bzip2
- dev-libs/lzo
+RDEPEND="app-arch/bzip2
app-arch/lz4
- sys-libs/zlib
-"
-DEPEND="
- ${RDEPEND}
- dev-perl/Pod-Parser
- x86? ( dev-lang/nasm )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-missing-stdarg_h.patch
- "${FILESDIR}"/${PN}-0.631-solaris.patch
-)
+ dev-libs/lzo
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-perl/Pod-Parser
+ amd64? ( dev-lang/nasm )
+ x86? ( dev-lang/nasm )"
src_prepare() {
default
@@ -38,7 +30,15 @@ src_prepare() {
}
src_configure() {
- econf $(use_enable static-libs static)
+ # ASM optimizations are only available on amd64 and x86, bug #829003
+ local asm=no
+ if use amd64 || use x86; then
+ asm=yes
+ fi
+
+ econf \
+ $(use_enable static-libs static) \
+ --enable-asm=${asm}
}
src_install() {
@@ -47,5 +47,5 @@ src_install() {
rm -f "${ED}"/usr/bin/lrz || die
rm -f "${ED}"/usr/share/man/man1/lrz.* || die
- find "${D}" -name '*.la' -delete || die
+ find "${ED}" -name '*.la' -delete || die
}
diff --git a/app-arch/lrzip/metadata.xml b/app-arch/lrzip/metadata.xml
index a6fb81439347..85eef5cdea59 100644
--- a/app-arch/lrzip/metadata.xml
+++ b/app-arch/lrzip/metadata.xml
@@ -1,7 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!--maintainer-needed-->
+ <maintainer type="person">
+ <email>kumba@gentoo.org</email>
+ <name>Joshua Kinard</name>
+ </maintainer>
<longdescription>
This is a compression program optimised for large files. The larger the
file and the more memory you have, the better the compression advantage