summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/pack')
-rw-r--r--app-arch/pack/Manifest1
-rw-r--r--app-arch/pack/metadata.xml11
-rw-r--r--app-arch/pack/pack-0.0.0.1.ebuild35
3 files changed, 47 insertions, 0 deletions
diff --git a/app-arch/pack/Manifest b/app-arch/pack/Manifest
new file mode 100644
index 000000000000..0256fb512bdc
--- /dev/null
+++ b/app-arch/pack/Manifest
@@ -0,0 +1 @@
+DIST pack-0bd29ccae2662ef9ae1fabe707d84e4f84b36d53.tar.gz 3833 BLAKE2B f597746aa99e1cc59af3dd86a030458a2498a0649aae8f7bf9ac008c0bb6a0a26af62e5a4e76c6f8b49b5f0a6e19c0d6714c2a548231a6ce103c361b227757b9 SHA512 a75eb599aa0abcec9d151d5af7128bbbc13f7687dcc15ec5843dffd5e1084598ebabc6c1981a6ee225855435b5c4693ee4c7ad62f4e36f5e0de8205591d42439
diff --git a/app-arch/pack/metadata.xml b/app-arch/pack/metadata.xml
new file mode 100644
index 000000000000..daafb9559e2f
--- /dev/null
+++ b/app-arch/pack/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">koalaman/pack</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-arch/pack/pack-0.0.0.1.ebuild b/app-arch/pack/pack-0.0.0.1.ebuild
new file mode 100644
index 000000000000..811e9dd596ad
--- /dev/null
+++ b/app-arch/pack/pack-0.0.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit haskell-cabal
+
+EGIT_COMMIT="0bd29ccae2662ef9ae1fabe707d84e4f84b36d53"
+MY_P=${PN}-${EGIT_COMMIT}
+DESCRIPTION="Haskell implementation of pack compression from the early 1980s"
+HOMEPAGE="https://github.com/koalaman/pack/"
+SRC_URI="
+ https://github.com/koalaman/pack/archive/${EGIT_COMMIT}.tar.gz
+ -> ${MY_P}.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+
+RDEPEND="
+ dev-lang/ghc:=
+"
+BDEPEND="
+ >=dev-haskell/cabal-1.10
+"
+
+CABAL_FILE=${S}/pack-compression.cabal
+
+src_prepare() {
+ sed -i -e '/base/s:&& <4.10::' "${CABAL_FILE}" || die
+ haskell-cabal_src_prepare
+ cabal-mksetup
+}