summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/pxz')
-rw-r--r--app-arch/pxz/Manifest2
-rw-r--r--app-arch/pxz/files/pxz-5.0_pre20220509-fix-xz-path.patch21
-rw-r--r--app-arch/pxz/metadata.xml25
-rw-r--r--app-arch/pxz/pxz-5.0_pre20220509-r1.ebuild (renamed from app-arch/pxz/pxz-5.0_pre20151029-r1.ebuild)16
-rw-r--r--app-arch/pxz/pxz-9999.ebuild53
5 files changed, 48 insertions, 69 deletions
diff --git a/app-arch/pxz/Manifest b/app-arch/pxz/Manifest
index 5fd2bc75ba2c..bdad03e15579 100644
--- a/app-arch/pxz/Manifest
+++ b/app-arch/pxz/Manifest
@@ -1 +1 @@
-DIST pxz-5.0_pre20151029.tar.gz 12271 BLAKE2B 6ba2cb7629b0475761b59620375a2d0de7c6a3a61f7af20140e214383f737e046c45f0c602830c0331794fe1d38332d8d309ed0b8451e3a780ef1a2835de85e6 SHA512 d26bfdf9b70baf91c575e21824920cb42d0a9bd171254b99147a6e5e322ed3d1f7351a570358213431bdacdcbe6e7b22646a2dd2d7a127e167c8237bc4f3038a
+DIST pxz-5.0_pre20220509.tar.gz 12375 BLAKE2B 5d954d4cd1b139dc94a9ecc5aa99c19a1484812eb62fce089b8f33bfc0ce3ed3ad8053cdc58843c429a365439cd13b3a4b14ebc34de7f2a99deae7cd995cd4e6 SHA512 b1de877d2b8ee9ea5190af4c1a0dc97f7777c35a084137db6d86e23de99b332ea361a82ed995ac2ea12b7bf0670ae92a822235be3b19a1145b6cf5604074f960
diff --git a/app-arch/pxz/files/pxz-5.0_pre20220509-fix-xz-path.patch b/app-arch/pxz/files/pxz-5.0_pre20220509-fix-xz-path.patch
new file mode 100644
index 000000000000..76e1f1506157
--- /dev/null
+++ b/app-arch/pxz/files/pxz-5.0_pre20220509-fix-xz-path.patch
@@ -0,0 +1,21 @@
+https://bugs.gentoo.org/887255
+https://github.com/jnovy/pxz/issues/34
+https://github.com/jnovy/pxz/pull/40
+
+From 20014a968d2330ac90f48fc2091e15a44cb1e759 Mon Sep 17 00:00:00 2001
+From: Tobias Faller <fallert@tf.uni-freiburg.de>
+Date: Tue, 20 Dec 2022 22:41:59 +0100
+Subject: [PATCH] Updated default path for xz binary
+
+--- a/pxz.c
++++ b/pxz.c
+@@ -43,7 +43,7 @@
+ #endif
+
+ #ifndef XZ_BINARY
+-#define XZ_BINARY "xz"
++#define XZ_BINARY "/usr/bin/xz"
+ #endif
+
+ #define BUFFSIZE 0x10000
+
diff --git a/app-arch/pxz/metadata.xml b/app-arch/pxz/metadata.xml
index 8aaea027cbbd..c9d7bc294a84 100644
--- a/app-arch/pxz/metadata.xml
+++ b/app-arch/pxz/metadata.xml
@@ -1,15 +1,18 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="person">
-<email>chutzpah@gentoo.org</email>
-<name>Patrick McLean</name>
-</maintainer>
-<longdescription lang="en">
-Parallel XZ is a compression utility that takes advantage of running LZMA
-compression of different parts of an input file on multiple cores and
-processors simultaneously. Its primary goal is to utilize all resources
-to speed up compression time with minimal possible influence on compression
-ratio.
-</longdescription>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <longdescription lang="en">
+ Parallel XZ is a compression utility that takes advantage of running LZMA
+ compression of different parts of an input file on multiple cores and
+ processors simultaneously. Its primary goal is to utilize all resources
+ to speed up compression time with minimal possible influence on compression
+ ratio.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">jnovy/pxz</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/app-arch/pxz/pxz-5.0_pre20151029-r1.ebuild b/app-arch/pxz/pxz-5.0_pre20220509-r1.ebuild
index c9ad43cebe99..0968ba7b2f96 100644
--- a/app-arch/pxz/pxz-5.0_pre20151029-r1.ebuild
+++ b/app-arch/pxz/pxz-5.0_pre20220509-r1.ebuild
@@ -3,20 +3,25 @@
EAPI=8
-inherit toolchain-funcs vcs-snapshot
+inherit toolchain-funcs prefix vcs-snapshot
+PXZ_COMMIT="136e5c25daf545753329d7cee1b06ae482fb9c44"
DESCRIPTION="Parallel implementation of the XZ compression utility"
-HOMEPAGE="http://jnovy.fedorapeople.org/pxz/"
-SRC_URI="https://github.com/jnovy/pxz/archive/fcfea93957d96b7661d1439cf4b767ecfd341eed.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://jnovy.fedorapeople.org/pxz/"
+SRC_URI="https://github.com/jnovy/pxz/archive/${PXZ_COMMIT}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm64 ~ppc64 x86 ~amd64-linux"
-# needs the library from xz-utils
+# Needs the library from xz-utils
RDEPEND="app-arch/xz-utils"
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.0_pre20220509-fix-xz-path.patch
+)
+
pkg_pretend() {
[[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
}
@@ -28,6 +33,9 @@ pkg_setup() {
src_prepare() {
default
+ # bug #887255
+ eprefixify pxz.c
+
if use elibc_musl ; then
sed -i -e '/<error.h>/c\#define error(R,E,S,...) fprintf(stderr, S "\\n", ##__VA_ARGS__); exit(R)' pxz.c || die
fi
diff --git a/app-arch/pxz/pxz-9999.ebuild b/app-arch/pxz/pxz-9999.ebuild
deleted file mode 100644
index f67a5e51ae6a..000000000000
--- a/app-arch/pxz/pxz-9999.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/jnovy/pxz.git"
- inherit git-r3
-else
- MY_PV=${PV/_}
- case ${MY_PV} in
- *beta?*) MY_PV="${MY_PV/beta/beta.}git" ;;
- esac
- MY_P="${PN}-${MY_PV}"
- SRC_URI="https://jnovy.fedorapeople.org/pxz/${MY_P}.tar.xz"
- KEYWORDS="~amd64 ~x86"
- S=${WORKDIR}/${MY_P/beta*/beta}
-fi
-
-DESCRIPTION="parallel LZMA compressor (no parallel decompression!)"
-HOMEPAGE="https://jnovy.fedorapeople.org/pxz/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE=""
-
-# needs the library from xz-utils
-DEPEND="app-arch/xz-utils"
-RDEPEND="${DEPEND}"
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
-}
-
-pkg_setup() {
- [[ ${MERGE_TYPE} != binary ]] && tc-check-openmp
-}
-
-src_prepare() {
- default
-
- if use elibc_musl ; then
- sed -i -e '/<error.h>/c\#define error(R,E,S,...) fprintf(stderr, S "\\n", ##__VA_ARGS__); exit(R)' pxz.c || die
- fi
-}
-
-src_configure() {
- tc-export CC
- export BINDIR="${EPREFIX}"/usr/bin
- export MANDIR="${EPREFIX}"/usr/share/man
-}