summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/qpress')
-rw-r--r--app-arch/qpress/Manifest2
-rw-r--r--app-arch/qpress/files/qpress-1.1-fix-build-system.patch7
-rw-r--r--app-arch/qpress/files/qpress-1.1-fix-includes.patch7
-rw-r--r--app-arch/qpress/files/qpress-20220819-fix-build-system.patch39
-rw-r--r--app-arch/qpress/metadata.xml5
-rw-r--r--app-arch/qpress/qpress-1.1.ebuild32
-rw-r--r--app-arch/qpress/qpress-20220819.ebuild21
7 files changed, 65 insertions, 48 deletions
diff --git a/app-arch/qpress/Manifest b/app-arch/qpress/Manifest
index 012e32d902a3..6d228f011e70 100644
--- a/app-arch/qpress/Manifest
+++ b/app-arch/qpress/Manifest
@@ -1 +1 @@
-DIST qpress-11-source.zip 26998 BLAKE2B 08dd943f248f7211e8588fbaf7a2c2eee988d33b17aebfb5f1178647d80314fde576caec9b4aab67d69689f5931d086f88fd51204c1df6d3abc2cca583830380 SHA512 986754cca8bb2cdcfc7e197f7e123c6b2da90db840642a6385f14613f49f7ec6b2c18944838405fe35d5382d71fcd5d69050a036dda4c5de2e588d144e16ea6b
+DIST qpress-20220819.tar.gz 25150 BLAKE2B e19a2bca747ec48507288b1b1ad8e053cfb35558f5936dff4ff83c548a3ab613a640813fc3b793e7acb1b65f371af414635d7e469e92c014b580efce4f84ee90 SHA512 f9cf4f87c25fdaa9b8ed12bbfb8d95c3036a7c5c1a0548042ba460b79787a83d5cd2ad93f2da84e5b6715ade5e137024541a3f29e076d4236d0507e2c604113c
diff --git a/app-arch/qpress/files/qpress-1.1-fix-build-system.patch b/app-arch/qpress/files/qpress-1.1-fix-build-system.patch
deleted file mode 100644
index b6f7c0f2841b..000000000000
--- a/app-arch/qpress/files/qpress-1.1-fix-build-system.patch
+++ /dev/null
@@ -1,7 +0,0 @@
---- a/makefile
-+++ b/makefile
-@@ -1,2 +1 @@
--g++: qpress.cpp aio.cpp quicklz.c utilities.cpp
-- g++ -O3 -o qpress qpress.cpp aio.cpp quicklz.c utilities.cpp -lpthread
-\ No newline at end of file
-+qpress: aio.o quicklz.o utilities.o
diff --git a/app-arch/qpress/files/qpress-1.1-fix-includes.patch b/app-arch/qpress/files/qpress-1.1-fix-includes.patch
deleted file mode 100644
index 51bfee465aa9..000000000000
--- a/app-arch/qpress/files/qpress-1.1-fix-includes.patch
+++ /dev/null
@@ -1,7 +0,0 @@
---- a/qpress.cpp
-+++ b/qpress.cpp
-@@ -1,3 +1,4 @@
-+#include <unistd.h>
- /*
- qpress - portable high-speed file archiver
- Copyright Lasse Reinhold 2006-2010
diff --git a/app-arch/qpress/files/qpress-20220819-fix-build-system.patch b/app-arch/qpress/files/qpress-20220819-fix-build-system.patch
new file mode 100644
index 000000000000..3fb5750eac9b
--- /dev/null
+++ b/app-arch/qpress/files/qpress-20220819-fix-build-system.patch
@@ -0,0 +1,39 @@
+From 1627b18fdf76e978bdd05b985eb6efb1286fa1da Mon Sep 17 00:00:00 2001
+From: Davide Cavalca <dcavalca@fedoraproject.org>
+Date: Thu, 24 Nov 2022 16:13:30 -0800
+Subject: [PATCH] Rework makefile to ease packaging
+
+---
+ makefile | 22 +++++++++++++++++-----
+ 1 file changed, 17 insertions(+), 5 deletions(-)
+
+diff --git a/makefile b/makefile
+index 4890f9d..349fbb2 100755
+--- a/makefile
++++ b/makefile
+@@ -1,9 +1,20 @@
+-PREFIX = /usr/local
++DESTDIR ?=
++PREFIX ?= /usr/local
++CXX ?= g++
++CXXFLAGS ?= -O3 -Wall -Wextra -Werror
++LDFLAGS ?=
+
+-g++: qpress.cpp aio.cpp quicklz.c utilities.cpp
+- g++ -O3 -o qpress -x c quicklz.c -x c++ qpress.cpp aio.cpp utilities.cpp -lpthread -Wall -Wextra -Werror
++qpress: qpress.cpp aio.cpp quicklz.c utilities.cpp
++ $(CXX) $(CXXFLAGS) -o qpress -x c quicklz.c -x c++ qpress.cpp aio.cpp utilities.cpp -lpthread $(LDFLAGS)
+
+ install: qpress
+- install -m 0755 qpress $(PREFIX)/bin
++ install -D -p -m 0755 -t $(DESTDIR)$(PREFIX)/bin qpress
+
+-.PHONY: install g++
++clean:
++ rm -f qpress
++
++all: qpress
++
++g++: qpress
++
++.PHONY: clean install
diff --git a/app-arch/qpress/metadata.xml b/app-arch/qpress/metadata.xml
index 2bf41d5f1513..ff29f9711f94 100644
--- a/app-arch/qpress/metadata.xml
+++ b/app-arch/qpress/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person" proxied="yes">
<email>azamat.hackimov@gmail.com</email>
@@ -9,4 +9,7 @@
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
+ <upstream>
+ <remote-id type="github">PierreLvx/qpress</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/app-arch/qpress/qpress-1.1.ebuild b/app-arch/qpress/qpress-1.1.ebuild
deleted file mode 100644
index 21904daf9eb3..000000000000
--- a/app-arch/qpress/qpress-1.1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="A portable file archiver using QuickLZ algorithm"
-HOMEPAGE="http://www.quicklz.com/"
-SRC_URI="http://www.quicklz.com/${PN}-${PV/./}-source.zip"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-BDEPEND="app-arch/unzip"
-
-S="${WORKDIR}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.1-fix-includes.patch
- "${FILESDIR}"/${PN}-1.1-fix-build-system.patch
-)
-
-src_configure() {
- tc-export CC CXX
- export LDLIBS="-lpthread"
-}
-
-src_install() {
- dobin ${PN}
-}
diff --git a/app-arch/qpress/qpress-20220819.ebuild b/app-arch/qpress/qpress-20220819.ebuild
new file mode 100644
index 000000000000..c7327d69a530
--- /dev/null
+++ b/app-arch/qpress/qpress-20220819.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A portable file archiver using QuickLZ algorithm"
+HOMEPAGE="https://github.com/PierreLvx/qpress"
+SRC_URI="https://github.com/PierreLvx/qpress/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-1 GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-build-system.patch"
+)
+
+src_install() {
+ dobin qpress
+ dodoc readme.md
+}