summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/tar/tar-1.34.ebuild')
-rw-r--r--app-arch/tar/tar-1.34.ebuild74
1 files changed, 0 insertions, 74 deletions
diff --git a/app-arch/tar/tar-1.34.ebuild b/app-arch/tar/tar-1.34.ebuild
deleted file mode 100644
index d8a77bc9b826..000000000000
--- a/app-arch/tar/tar-1.34.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/tar.asc
-inherit verify-sig
-
-DESCRIPTION="Use this to make tarballs :)"
-HOMEPAGE="https://www.gnu.org/software/tar/"
-SRC_URI="mirror://gnu/tar/${P}.tar.xz
- https://alpha.gnu.org/gnu/tar/${P}.tar.xz"
-SRC_URI+=" verify-sig? (
- mirror://gnu/tar/${P}.tar.xz.sig
- https://alpha.gnu.org/gnu/tar/${P}.tar.xz.sig
- )"
-
-LICENSE="GPL-3+"
-SLOT="0"
-if [[ -z "$(ver_cut 3)" ]] || [[ "$(ver_cut 3)" -lt 90 ]] ; then
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-IUSE="acl minimal nls selinux xattr"
-
-RDEPEND="
- acl? ( virtual/acl )
- selinux? ( sys-libs/libselinux )
-"
-DEPEND="${RDEPEND}
- xattr? ( elibc_glibc? ( sys-apps/attr ) )
-"
-BDEPEND="
- nls? ( sys-devel/gettext )
- verify-sig? ( sec-keys/openpgp-keys-tar )
-"
-
-src_configure() {
- local myeconfargs=(
- --bindir="${EPREFIX}"/bin
- --enable-backup-scripts
- --libexecdir="${EPREFIX}"/usr/sbin
- $(use_with acl posix-acls)
- $(use_enable nls)
- $(use_with selinux)
- $(use_with xattr xattrs)
- )
-
- FORCE_UNSAFE_CONFIGURE=1 econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
-
- # a nasty yet required piece of baggage
- exeinto /etc
- doexe "${FILESDIR}"/rmt
-
- # autoconf looks for gtar before tar (in configure scripts), hence
- # in Prefix it is important that it is there, otherwise, a gtar from
- # the host system (FreeBSD, Solaris, Darwin) will be found instead
- # of the Prefix provided (GNU) tar
- if use prefix ; then
- dosym tar /bin/gtar
- fi
-
- mv "${ED}"/usr/sbin/backup{,-tar} || die
- mv "${ED}"/usr/sbin/restore{,-tar} || die
-
- if use minimal ; then
- find "${ED}"/etc "${ED}"/*bin/ "${ED}"/usr/*bin/ \
- -type f -a '!' '(' -name tar -o -name tar ')' \
- -delete || die
- fi
-}