summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/tar/tar-1.34.ebuild')
-rw-r--r--app-arch/tar/tar-1.34.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/app-arch/tar/tar-1.34.ebuild b/app-arch/tar/tar-1.34.ebuild
deleted file mode 100644
index b92c607064a9..000000000000
--- a/app-arch/tar/tar-1.34.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="Use this to make tarballs :)"
-HOMEPAGE="https://www.gnu.org/software/tar/"
-SRC_URI="mirror://gnu/tar/${P}.tar.xz
- https://alpha.gnu.org/gnu/tar/${P}.tar.xz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-[[ -n "$(ver_cut 3)" ]] && [[ "$(ver_cut 3)" -ge 90 ]] || \
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="acl minimal nls selinux xattr"
-
-RDEPEND="
- acl? ( virtual/acl )
- selinux? ( sys-libs/libselinux )
-"
-DEPEND="${RDEPEND}
- xattr? ( elibc_glibc? ( sys-apps/attr ) )
-"
-BDEPEND="
- nls? ( sys-devel/gettext )
-"
-
-src_configure() {
- local myeconfargs=(
- --bindir="${EPREFIX}"/bin
- --enable-backup-scripts
- --libexecdir="${EPREFIX}"/usr/sbin
- $(use_with acl posix-acls)
- $(use_enable nls)
- $(use_with selinux)
- $(use_with xattr xattrs)
- )
- FORCE_UNSAFE_CONFIGURE=1 econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
-
- # a nasty yet required piece of baggage
- exeinto /etc
- doexe "${FILESDIR}"/rmt
-
- # autoconf looks for gtar before tar (in configure scripts), hence
- # in Prefix it is important that it is there, otherwise, a gtar from
- # the host system (FreeBSD, Solaris, Darwin) will be found instead
- # of the Prefix provided (GNU) tar
- if use prefix ; then
- dosym tar /bin/gtar
- fi
-
- mv "${ED}"/usr/sbin/backup{,-tar} || die
- mv "${ED}"/usr/sbin/restore{,-tar} || die
-
- if use minimal ; then
- find "${ED}"/etc "${ED}"/*bin/ "${ED}"/usr/*bin/ \
- -type f -a '!' '(' -name tar -o -name tar ')' \
- -delete || die
- fi
-}