summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/torrentzip/torrentzip-0.2-r9.ebuild')
-rw-r--r--app-arch/torrentzip/torrentzip-0.2-r9.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-arch/torrentzip/torrentzip-0.2-r9.ebuild b/app-arch/torrentzip/torrentzip-0.2-r9.ebuild
new file mode 100644
index 000000000000..818202ef1edd
--- /dev/null
+++ b/app-arch/torrentzip/torrentzip-0.2-r9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit versionator eutils autotools
+
+DESCRIPTION="Archiver that creates standard zips to create identical files over multiple systems"
+HOMEPAGE="https://sourceforge.net/projects/trrntzip"
+
+S="${WORKDIR}/trrntzip-code-9"
+
+SRC_URI="http://sourceforge.net/code-snapshots/svn/t/tr/trrntzip/code/trrntzip-code-9.zip"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="sys-libs/zlib"
+RDEPEND=""
+
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Source-code from sf.net snapshots has CRLF...
+ EPATCH_OPTS="--binary"
+ epatch "${FILESDIR}"/fix-function-declarations.patch
+
+ eautoreconf
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc README AUTHORS
+}