summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/unzip')
-rw-r--r--app-arch/unzip/Manifest2
-rw-r--r--app-arch/unzip/metadata.xml3
-rw-r--r--app-arch/unzip/unzip-6.0_p27-r1.ebuild (renamed from app-arch/unzip/unzip-6.0_p25-r1.ebuild)52
3 files changed, 31 insertions, 26 deletions
diff --git a/app-arch/unzip/Manifest b/app-arch/unzip/Manifest
index dce593202f55..491344bfc0ce 100644
--- a/app-arch/unzip/Manifest
+++ b/app-arch/unzip/Manifest
@@ -1,2 +1,2 @@
DIST unzip60.tar.gz 1376845 BLAKE2B 5016d300b4452018a391f4ebc03c6960c068df400a0407c0c60bd7bb5ec5012031f916d8b204a6149ba291c2c35beba40d9b43c76fc093026e79471329ab0e47 SHA512 0694e403ebc57b37218e00ec1a406cae5cc9c5b52b6798e0d4590840b6cdbf9ddc0d9471f67af783e960f8fa2e620394d51384257dca23d06bcd90224a80ce5d
-DIST unzip_6.0-25.debian.tar.xz 23096 BLAKE2B 09cd89165c0354431fa0eb946bb8f8355fa09ef81cd3e3ea03e53ca7f465b323364204ffe11d8e58eeb5b46e40be598d4f709b621d163bfde09070b6847db2a6 SHA512 13c16db420fa4a34be3090a9acdd79b01320da40ac5aa89a9dfca03e64b914b28eb72aff3882d02a8197457bcb8eeb9473c998cf6920e511883c9289a949fb21
+DIST unzip_6.0-27.debian.tar.xz 24980 BLAKE2B e53a96f12af0cf5227600c73a35003484fca5de138cd37991eb1eb25b97b80371c3a566d989feeb04deb1a93acd9444253b091cd7e920b23520c87c5f5a94eeb SHA512 e1e605f023c7b314a6c5b2857a3bd630350df2d7e4bf6bb38ab8594f967336384666b4db8afad931251b85261ee4e2c38d78641c74ac7e5fd02523f26e92ddb2
diff --git a/app-arch/unzip/metadata.xml b/app-arch/unzip/metadata.xml
index ed43f8ee64f6..80e20aa4d02a 100644
--- a/app-arch/unzip/metadata.xml
+++ b/app-arch/unzip/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>base-system@gentoo.org</email>
@@ -10,6 +10,7 @@
</use>
<upstream>
<remote-id type="cpe">cpe:/a:info-zip:unzip</remote-id>
+ <remote-id type="github">madler/unzip</remote-id>
<remote-id type="sourceforge">infozip</remote-id>
</upstream>
</pkgmetadata>
diff --git a/app-arch/unzip/unzip-6.0_p25-r1.ebuild b/app-arch/unzip/unzip-6.0_p27-r1.ebuild
index 54bf325de944..5b6fb1d1abb9 100644
--- a/app-arch/unzip/unzip-6.0_p25-r1.ebuild
+++ b/app-arch/unzip/unzip-6.0_p27-r1.ebuild
@@ -1,22 +1,22 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit toolchain-funcs flag-o-matic
+inherit flag-o-matic multilib toolchain-funcs
MY_PV="${PV//.}"
MY_PV="${MY_PV%_p*}"
MY_P="${PN}${MY_PV}"
DESCRIPTION="unzipper for pkzip-compressed files"
-HOMEPAGE="http://www.info-zip.org/"
-SRC_URI="mirror://sourceforge/infozip/${MY_P}.tar.gz
+HOMEPAGE="https://infozip.sourceforge.net/UnZip.html"
+SRC_URI="https://downloads.sourceforge.net/infozip/${MY_P}.tar.gz
mirror://debian/pool/main/u/${PN}/${PN}_${PV/_p/-}.debian.tar.xz"
LICENSE="Info-ZIP"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
IUSE="bzip2 natspec unicode"
DEPEND="bzip2? ( app-arch/bzip2 )
@@ -25,15 +25,21 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
+PATCHES=(
+ "${WORKDIR}"/debian/patches
+ "${FILESDIR}"/${PN}-6.0-no-exec-stack.patch
+ "${FILESDIR}"/${PN}-6.0-format-security.patch
+ "${FILESDIR}"/${PN}-6.0-fix-false-overlap-detection-on-32bit-systems.patch
+)
+
src_prepare() {
- local deb="${WORKDIR}"/debian/patches
- rm "${deb}"/02-this-is-debian-unzip.patch || die
- eapply "${deb}"/*.patch
-
- eapply "${FILESDIR}"/${PN}-6.0-no-exec-stack.patch
- eapply "${FILESDIR}"/${PN}-6.0-format-security.patch
- eapply "${FILESDIR}"/${PN}-6.0-fix-false-overlap-detection-on-32bit-systems.patch
- use natspec && eapply "${FILESDIR}/${PN}-6.0-natspec.patch" #275244
+ # bug #275244
+ use natspec && PATCHES+=( "${FILESDIR}"/${PN}-6.0-natspec.patch )
+
+ rm "${WORKDIR}"/debian/patches/02-this-is-debian-unzip.patch || die
+
+ default
+
sed -i -r \
-e '/^CFLAGS/d' \
-e '/CFLAGS/s:-O[0-9]?:$(CFLAGS) $(CPPFLAGS):' \
@@ -52,32 +58,30 @@ src_prepare() {
# Delete bundled code to make sure we don't use it.
rm -r bzip2 || die
-
- eapply_user
}
src_configure() {
case ${CHOST} in
i?86*-*linux*) TARGET="linux_asm" ;;
*linux*) TARGET="linux_noasm" ;;
- i?86*-*bsd* | \
- i?86*-dragonfly*) TARGET="freebsd" ;; # mislabelled bsd with x86 asm
- *bsd* | *dragonfly*) TARGET="bsd" ;;
*-darwin*) TARGET="macosx" ;;
*-solaris*) TARGET="generic" ;;
- *-cygwin*) TARGET="generic" ;;
- *) die "Unknown target; please update the ebuild to handle ${CHOST} " ;;
+ *) die "Unknown target; please update the ebuild to handle ${CHOST}" ;;
esac
+ # Needed for Clang 16
+ append-flags -std=gnu89
+
[[ ${CHOST} == *linux* ]] && append-cppflags -DNO_LCHMOD
use bzip2 && append-cppflags -DUSE_BZIP2
use unicode && append-cppflags -DUNICODE_SUPPORT -DUNICODE_WCHAR -DUTF8_MAYBE_NATIVE -DUSE_ICONV_MAPPING
- append-cppflags -DLARGE_FILE_SUPPORT #281473
+
+ # bug #281473
+ append-cppflags -DLARGE_FILE_SUPPORT
}
src_compile() {
- ASFLAGS="${ASFLAGS} $(get_abi_var CFLAGS)" \
- emake -f unix/Makefile ${TARGET}
+ ASFLAGS="${ASFLAGS} $(get_abi_CFLAGS)" emake -f unix/Makefile ${TARGET}
}
src_install() {