summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/vimball/vimball-0.5.1-r1.ebuild')
-rw-r--r--app-arch/vimball/vimball-0.5.1-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-arch/vimball/vimball-0.5.1-r1.ebuild b/app-arch/vimball/vimball-0.5.1-r1.ebuild
new file mode 100644
index 000000000000..9f4edd4d930f
--- /dev/null
+++ b/app-arch/vimball/vimball-0.5.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/radhermit/vimball.git"
+ inherit git-r3
+else
+ KEYWORDS="amd64 x86"
+ inherit pypi
+fi
+
+DESCRIPTION="A command-line vimball archive extractor"
+HOMEPAGE="
+ https://github.com/radhermit/vimball/
+ https://pypi.org/project/vimball/
+"
+
+LICENSE="MIT"
+SLOT="0"
+
+distutils_enable_tests pytest