summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/vimball')
-rw-r--r--app-arch/vimball/metadata.xml2
-rw-r--r--app-arch/vimball/vimball-0.5.1-r1.ebuild28
-rw-r--r--app-arch/vimball/vimball-0.5.1.ebuild29
-rw-r--r--app-arch/vimball/vimball-9999.ebuild27
4 files changed, 42 insertions, 44 deletions
diff --git a/app-arch/vimball/metadata.xml b/app-arch/vimball/metadata.xml
index 66b3d21b657e..c2cd5d2b2de2 100644
--- a/app-arch/vimball/metadata.xml
+++ b/app-arch/vimball/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!-- maintainer-needed -->
<upstream>
diff --git a/app-arch/vimball/vimball-0.5.1-r1.ebuild b/app-arch/vimball/vimball-0.5.1-r1.ebuild
new file mode 100644
index 000000000000..9f4edd4d930f
--- /dev/null
+++ b/app-arch/vimball/vimball-0.5.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/radhermit/vimball.git"
+ inherit git-r3
+else
+ KEYWORDS="amd64 x86"
+ inherit pypi
+fi
+
+DESCRIPTION="A command-line vimball archive extractor"
+HOMEPAGE="
+ https://github.com/radhermit/vimball/
+ https://pypi.org/project/vimball/
+"
+
+LICENSE="MIT"
+SLOT="0"
+
+distutils_enable_tests pytest
diff --git a/app-arch/vimball/vimball-0.5.1.ebuild b/app-arch/vimball/vimball-0.5.1.ebuild
deleted file mode 100644
index 2ad50ff8856c..000000000000
--- a/app-arch/vimball/vimball-0.5.1.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-inherit distutils-r1
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/radhermit/vimball.git"
- inherit git-r3
-else
- KEYWORDS="amd64 x86"
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-fi
-
-DESCRIPTION="a command-line vimball archive extractor"
-HOMEPAGE="https://github.com/radhermit/vimball"
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_test() {
- esetup.py test
-}
diff --git a/app-arch/vimball/vimball-9999.ebuild b/app-arch/vimball/vimball-9999.ebuild
index b5126bad3cf2..368e668cb296 100644
--- a/app-arch/vimball/vimball-9999.ebuild
+++ b/app-arch/vimball/vimball-9999.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
inherit distutils-r1
if [[ ${PV} == *9999 ]] ; then
@@ -11,19 +13,16 @@ if [[ ${PV} == *9999 ]] ; then
inherit git-r3
else
KEYWORDS="~amd64 ~x86"
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ inherit pypi
fi
-DESCRIPTION="a command-line vimball archive extractor"
-HOMEPAGE="https://github.com/radhermit/vimball"
+DESCRIPTION="A command-line vimball archive extractor"
+HOMEPAGE="
+ https://github.com/radhermit/vimball/
+ https://pypi.org/project/vimball/
+"
LICENSE="MIT"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-python_test() {
- esetup.py test
-}
+distutils_enable_tests pytest