summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/wimlib')
-rw-r--r--app-arch/wimlib/Manifest2
-rw-r--r--app-arch/wimlib/metadata.xml5
-rw-r--r--app-arch/wimlib/wimlib-1.13.3-r1.ebuild73
-rw-r--r--app-arch/wimlib/wimlib-1.13.4-r1.ebuild2
-rw-r--r--app-arch/wimlib/wimlib-1.14.1.ebuild52
5 files changed, 56 insertions, 78 deletions
diff --git a/app-arch/wimlib/Manifest b/app-arch/wimlib/Manifest
index 3c0a53feda85..a7bd60bb4ea2 100644
--- a/app-arch/wimlib/Manifest
+++ b/app-arch/wimlib/Manifest
@@ -1,2 +1,2 @@
-DIST wimlib-1.13.3.tar.gz 1030667 BLAKE2B 2b897392bed3c4a390479f34925474c229ee835ab624c81a0baa7ebb8f3484f27aa4efb2a440debdcafe23b152b385bbe0f198d6f0560e8f88a34c7328a74edd SHA512 5c6e3bd1d7bda55812c818cc527cd241ac8a15276648f2a307db1f2a858de0b322e9f2beffda5bab991811aee3f4a953c3e31847bfa76a7d32ad5850595a15d4
DIST wimlib-1.13.4.tar.gz 1040411 BLAKE2B 4563429d42be39b959a15ef66ac4c173531ff0c0b0f1a341812a4f870c9f189478f3ce78bf6240544f71b1746d98c9eae3f7182d646355343e26526559384f07 SHA512 480fe6fa6c6e8f1bf9c3960f5e1671f3266535b18dc72e9d7c4c05c7fb833d9b00db5ae9fb49154da6e71e536cae8b562cbf81ab5a124e2a79326927e2cf7344
+DIST wimlib-1.14.1.tar.gz 1046078 BLAKE2B 56e44928229c9c4fda662fa64fc4021bd361c2c959f0786764b84fa4cc9d7f7b0d5440edb4d4079657cc7bf450ac9c755f554c7da7a8b2b7e96d69ddbeb4f22f SHA512 9f92a8ce2d386918d66a1a3e52d4fbffeeb9f8b9345b25012fd0bd07039a00be84fd83d83a9bb25bcefab09597a81e9392522be835dd6693dd00050f8624af00
diff --git a/app-arch/wimlib/metadata.xml b/app-arch/wimlib/metadata.xml
index b55da085cdf2..2c160e3ee81d 100644
--- a/app-arch/wimlib/metadata.xml
+++ b/app-arch/wimlib/metadata.xml
@@ -4,9 +4,8 @@
<!-- maintainer-needed -->
<use>
<flag name="fuse">Use fuse libraries</flag>
- <flag name="iso">Install app-cdr/cdrtools in order to prepare iso images</flag>
- <flag name="ntfs">Use libntfs-3g library from sys-fs/ntfs3g</flag>
- <flag name="openssl">Use the SHA-1 message digest from libcrypto instead of compilling another implementation</flag>
+ <flag name="iso">Install <pkg>app-cdr/cdrtools</pkg> in order to prepare iso images</flag>
+ <flag name="ntfs">Use libntfs-3g library from <pkg>sys-fs/ntfs3g</pkg></flag>
<flag name="yasm">Use yasm assembler instead of nasm</flag>
</use>
</pkgmetadata>
diff --git a/app-arch/wimlib/wimlib-1.13.3-r1.ebuild b/app-arch/wimlib/wimlib-1.13.3-r1.ebuild
deleted file mode 100644
index e1373f3790a6..000000000000
--- a/app-arch/wimlib/wimlib-1.13.3-r1.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools pax-utils
-if [[ -z ${PV%%*9999} ]]; then
- inherit git-r3
- EGIT_REPO_URI="git://wimlib.net/${PN}"
-else
- MY_PV="${PV/_/-}"
- MY_PV="${MY_PV^^}"
- SRC_URI="https://wimlib.net/downloads/${PN}-${MY_PV}.tar.gz"
- KEYWORDS="amd64 x86"
-fi
-
-DESCRIPTION="The open source Windows Imaging (WIM) library"
-HOMEPAGE="https://wimlib.net/"
-
-LICENSE="|| ( GPL-3+ LGPL-3+ ) CC0-1.0"
-SLOT="0"
-IUSE="cpu_flags_x86_ssse3 fuse iso ntfs openssl test threads yasm"
-REQUIRED_USE="cpu_flags_x86_ssse3? ( !openssl )"
-
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- virtual/pkgconfig
- cpu_flags_x86_ssse3? (
- yasm? ( dev-lang/yasm )
- !yasm? ( dev-lang/nasm )
- )
-"
-RDEPEND="
- dev-libs/libxml2:2
- ntfs? ( sys-fs/ntfs3g:= )
- fuse? ( sys-fs/fuse:0 )
- openssl? ( dev-libs/openssl:= )
- iso? (
- app-arch/cabextract
- app-cdr/cdrtools
- )
-"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_with ntfs ntfs-3g)
- $(use_with fuse)
- $(use_enable cpu_flags_x86_ssse3 ssse3-sha1)
- $(use_with openssl libcrypto)
- $(use_enable threads multithreaded-compression)
- $(use_enable test test-support)
- --disable-static
- )
- ac_cv_prog_NASM="$(usex yasm yasm nasm)" \
- econf "${myeconfargs[@]}"
-}
-
-src_compile() {
- default
- pax-mark m "${S}"/.libs/wimlib-imagex
-}
-
-src_install() {
- default
- find "${ED}" -name '*.la' -delete || die
-}
diff --git a/app-arch/wimlib/wimlib-1.13.4-r1.ebuild b/app-arch/wimlib/wimlib-1.13.4-r1.ebuild
index a914e9a0896b..13d1b0f2922b 100644
--- a/app-arch/wimlib/wimlib-1.13.4-r1.ebuild
+++ b/app-arch/wimlib/wimlib-1.13.4-r1.ebuild
@@ -9,7 +9,7 @@ DESCRIPTION="The open source Windows Imaging (WIM) library"
HOMEPAGE="https://wimlib.net"
SRC_URI="https://wimlib.net/downloads/${P}.tar.gz"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
LICENSE="|| ( GPL-3+ LGPL-3+ ) CC0-1.0"
SLOT="0"
IUSE="cpu_flags_x86_ssse3 fuse iso ntfs ssl test threads yasm"
diff --git a/app-arch/wimlib/wimlib-1.14.1.ebuild b/app-arch/wimlib/wimlib-1.14.1.ebuild
new file mode 100644
index 000000000000..14ba614885b5
--- /dev/null
+++ b/app-arch/wimlib/wimlib-1.14.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools pax-utils
+
+DESCRIPTION="The open source Windows Imaging (WIM) library"
+HOMEPAGE="https://wimlib.net"
+SRC_URI="https://wimlib.net/downloads/${P}.tar.gz"
+
+LICENSE="|| ( GPL-3+ LGPL-3+ ) MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="fuse iso ntfs test yasm"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ fuse? ( sys-fs/fuse:3 )
+ iso? (
+ app-arch/cabextract
+ app-cdr/cdrtools
+ )
+ ntfs? ( sys-fs/ntfs3g:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with ntfs ntfs-3g)
+ $(use_with fuse)
+ $(use_enable test test-support)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+ pax-mark m "${S}"/.libs/wimlib-imagex
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}