summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/zoo/zoo-2.10-r6.ebuild')
-rw-r--r--app-arch/zoo/zoo-2.10-r6.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-arch/zoo/zoo-2.10-r6.ebuild b/app-arch/zoo/zoo-2.10-r6.ebuild
new file mode 100644
index 000000000000..596ed3ada797
--- /dev/null
+++ b/app-arch/zoo/zoo-2.10-r6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Manipulate archives of files in compressed form"
+HOMEPAGE="https://github.com/jduerstock/zoo"
+SRC_URI="http://http.debian.net/debian/pool/main/z/${PN}/${PN}_${PV}.orig.tar.gz
+ http://http.debian.net/debian/pool/main/z/${PN}/${PN}_${PV}-28.debian.tar.xz"
+S="${WORKDIR}"/${P}.orig
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
+
+PATCHES=(
+ "${WORKDIR}"/debian/patches/.
+ "${FILESDIR}"/${P}-gentoo-fbsd-r1.patch
+ "${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${P}-implicit-int.patch
+)
+
+src_configure() {
+ tc-export CC
+}
+
+src_compile() {
+ emake linux
+}
+
+src_install() {
+ dobin zoo fiz
+ doman zoo.1 fiz.1
+}