summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/brotli/Manifest1
-rw-r--r--app-arch/brotli/brotli-1.0.5.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-arch/brotli/Manifest b/app-arch/brotli/Manifest
index 3cf8283860c2..0666725dbaae 100644
--- a/app-arch/brotli/Manifest
+++ b/app-arch/brotli/Manifest
@@ -1,3 +1,4 @@
DIST brotli-1.0.2.tar.gz 23736359 BLAKE2B c5467dc52f97942d790b835d5e2c06d2046c3df249446b775d58e56feeb5d5fdd3e1e8e42c5eff92df2bc2b47afabd36389e14afead5fd376e18c8517d1e67f7 SHA512 b3ec98159e63b4169dea3e958d60d89247dc1c0f78aab27bfffb2ece659fa024df990d410aa15c12b2082d42e3785e32ec248dce2b116c7f34e98bb6337f9fc9
DIST brotli-1.0.3.tar.gz 23815300 BLAKE2B 9569267782a8159d290e0f1b524a985144d1ae68a45a732443aca973dd0407c50249ce62389848d97cbc33eba3062ba471064570418c36158b97935ae4b7fb73 SHA512 93adcf437d730ac403e444285ac8aefbb2c8a6b5e1b064e8ee33684c067287a8159e0ee73d2217c167881e87da73fa494792d963a15508fd42b2ac4a5b52823c
DIST brotli-1.0.4.tar.gz 23819000 BLAKE2B 5c0a7ed2cb7e15722c2f08dbaaaa5e74f10a03b95961d77db285fac437a489158cf8f7d43a55fac75eb5423951286accf0285e3e3471e34e35868a69dbf42f16 SHA512 7d41ad37ca0755ba9e08e7355fb031e24a53a5f6d44ff827adee6d9712765af02142cb463ef558f92449ce3b73e559cffb52315a329ab702f4c46927f993b616
+DIST brotli-1.0.5.tar.gz 23825684 BLAKE2B b179f75f3e452bdd3fabbd74d9172bc0a00f797e7facf7a9061e5e81c52148297ea7dd8ab9954c3f596f59e2a96cb22ef057c4c02b1bba4ecf10db7b70e0711d SHA512 703cad94c7f250133d2cfe222f3183612c7649b184bba218907b805f423568046d42695f33acf7da95daf684be118c9d631cfa5706e5a195b611c716db4c839a
diff --git a/app-arch/brotli/brotli-1.0.5.ebuild b/app-arch/brotli/brotli-1.0.5.ebuild
new file mode 100644
index 000000000000..e06daa440b9b
--- /dev/null
+++ b/app-arch/brotli/brotli-1.0.5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+DISTUTILS_OPTIONAL="1"
+
+inherit cmake-utils distutils-r1 eapi7-ver
+
+DESCRIPTION="Generic-purpose lossless compression algorithm"
+HOMEPAGE="https://github.com/google/brotli"
+
+SLOT="0/$(ver_cut 1)"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}"
+
+IUSE="python test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+LICENSE="MIT python? ( Apache-2.0 )"
+
+DOCS=( README.md CONTRIBUTING.md )
+
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/google/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+ SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ cmake-utils_src_prepare
+ use python && distutils-r1_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ -DBUILD_TESTING="$(usex test)"
+ )
+ cmake-utils_src_configure
+ use python && distutils-r1_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ use python && distutils-r1_src_compile
+}
+
+python_test(){
+ esetup.py test || die
+}
+
+src_test() {
+ cmake-utils_src_test
+ use python && distutils-r1_src_test
+}
+
+src_install() {
+ cmake-utils_src_install
+ use python && distutils-r1_src_install
+}