summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/backintime')
-rw-r--r--app-backup/backintime/Manifest2
-rw-r--r--app-backup/backintime/backintime-1.3.1.ebuild77
-rw-r--r--app-backup/backintime/backintime-1.3.2-r1.ebuild (renamed from app-backup/backintime/backintime-1.3.2.ebuild)6
-rw-r--r--app-backup/backintime/backintime-1.3.3-r1.ebuild103
-rw-r--r--app-backup/backintime/backintime-9999.ebuild73
-rw-r--r--app-backup/backintime/metadata.xml3
6 files changed, 160 insertions, 104 deletions
diff --git a/app-backup/backintime/Manifest b/app-backup/backintime/Manifest
index 0ae4c57381e4..cdaa0118f8de 100644
--- a/app-backup/backintime/Manifest
+++ b/app-backup/backintime/Manifest
@@ -1,2 +1,2 @@
-DIST backintime-1.3.1.tar.gz 714401 BLAKE2B 5b6a294d5a22ee3928725caf1a9895b665bfcddd6b779355cd7f7e58b5a201c3d2158ef4b30fb73eb4525c1a54cacf878397874f28b06798b7bfd973df467a39 SHA512 faac8552748da75db62cf7fa7eea686fd8b262016d1072f432fff54a6c0c72929650582870b4c56efbaa4ef5984acaece9e1d76eb72abcce91c6fc92d34d52ad
DIST backintime-1.3.2.tar.gz 714459 BLAKE2B cc53bd5391155705016248511e30cdfa7bc25f0a7cb170dfeeffda397e8be1b22f8e335063289d8c192f94c469430655064899ac8059f22f3b7582e3af87d373 SHA512 19f756d03cc7533e02bb5172ae3f8c167206bf5e8d60c0f3af1f647e01297a4eeb7889bbb5b58e46636bc31392ee436249b276ddbfa41697a0538c542fa26cb8
+DIST backintime-1.3.3.tar.gz 751422 BLAKE2B 5c6723d1b190c5331b8453d4cf2b14e00a4bb64777d73e3b2a1405be51ebc5418f749fca654032154f1cec2389efcd41e52c571c1f9f1f982bbd0adcb0b7dd59 SHA512 f91157133166869665c8d7475c870cd5418135e17f5e7c8ae5788eb8cd3be39e8ea3d7652aa5945f64d9906b6baed0ed3ee16eb46b81a088210459333efe9372
diff --git a/app-backup/backintime/backintime-1.3.1.ebuild b/app-backup/backintime/backintime-1.3.1.ebuild
deleted file mode 100644
index daf1a9fd35d7..000000000000
--- a/app-backup/backintime/backintime-1.3.1.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..9} )
-
-inherit python-single-r1 xdg
-
-DESCRIPTION="Backup system inspired by TimeVault and FlyBack"
-HOMEPAGE="https://backintime.readthedocs.io/en/latest/ https://github.com/bit-team/backintime/"
-SRC_URI="https://github.com/bit-team/${PN}/releases/download/${PV}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="examples qt5"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/keyring[${PYTHON_USEDEP}]
- ')"
-RDEPEND="${DEPEND}
- net-misc/openssh
- net-misc/rsync[xattr,acl]
- qt5? ( dev-python/PyQt5[gui,widgets] )"
-
-PATCHES=( "${FILESDIR}/${PN}-1.2.1-no-compress-docs-examples.patch" )
-
-src_configure() {
- pushd common > /dev/null || die
- # Not autotools
- ./configure --python3 --no-fuse-group || die
- popd > /dev/null || die
-
- if use qt5 ; then
- pushd qt > /dev/null || die
- ./configure --python3 || die
- popd > /dev/null || die
- fi
-}
-
-src_compile() {
- pushd common > /dev/null || die
- emake
- popd > /dev/null || die
-
- if use qt5 ; then
- pushd qt > /dev/null || die
- emake
- popd > /dev/null || die
- fi
-}
-
-src_install() {
- pushd common > /dev/null || die
- emake DESTDIR="${D}" install
- popd > /dev/null || die
-
- if use qt5 ; then
- pushd qt > /dev/null || die
- emake DESTDIR="${D}" install
- popd > /dev/null || die
- fi
-
- einstalldocs
-
- if use examples ; then
- docinto examples
- dodoc common/{config-example-local,config-example-ssh}
- fi
-
- python_optimize "${D}"
-}
diff --git a/app-backup/backintime/backintime-1.3.2.ebuild b/app-backup/backintime/backintime-1.3.2-r1.ebuild
index ab2f61e19ac5..6eb50a6b1a7d 100644
--- a/app-backup/backintime/backintime-1.3.2.ebuild
+++ b/app-backup/backintime/backintime-1.3.2-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{9..10} )
inherit python-single-r1 xdg
DESCRIPTION="Backup system inspired by TimeVault and FlyBack"
@@ -23,7 +23,7 @@ DEPEND="${PYTHON_DEPS}
dev-python/keyring[${PYTHON_USEDEP}]
')"
RDEPEND="${DEPEND}
- net-misc/openssh
+ virtual/openssh
net-misc/rsync[xattr,acl]
qt5? ( dev-python/PyQt5[gui,widgets] )"
BDEPEND="sys-devel/gettext"
diff --git a/app-backup/backintime/backintime-1.3.3-r1.ebuild b/app-backup/backintime/backintime-1.3.3-r1.ebuild
new file mode 100644
index 000000000000..4168adaf8d16
--- /dev/null
+++ b/app-backup/backintime/backintime-1.3.3-r1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+inherit python-single-r1 xdg
+
+DESCRIPTION="Backup system inspired by TimeVault and FlyBack"
+HOMEPAGE="https://backintime.readthedocs.io/en/latest/ https://github.com/bit-team/backintime/"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/bit-team/backintime/"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/bit-team/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="amd64 x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="examples qt5 test"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ ')
+"
+RDEPEND="
+ ${DEPEND}
+ virtual/openssh
+ net-misc/rsync[xattr,acl]
+ qt5? ( dev-python/PyQt5[gui,widgets] )
+"
+BDEPEND="
+ sys-devel/gettext
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/pyfakefs[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-1.2.1-no-compress-docs-examples.patch" )
+
+src_prepare() {
+ default
+
+ # Looks at host system too much, so too flaky
+ rm common/test/test_tools.py || die
+ # Fails with dbus/udev issue (likely sandbox)
+ rm common/test/test_snapshots.py || die
+}
+
+src_configure() {
+ pushd common > /dev/null || die
+ # Not autotools
+ ./configure --python3 --no-fuse-group || die
+ popd > /dev/null || die
+
+ if use qt5 ; then
+ pushd qt > /dev/null || die
+ ./configure --python3 || die
+ popd > /dev/null || die
+ fi
+}
+
+src_compile() {
+ emake -C common
+
+ if use qt5 ; then
+ emake -C qt
+ fi
+}
+
+src_test() {
+ # pytest should work but it can't find the backintime binary, so
+ # use the unittest-based runner instead.
+ # https://github.com/bit-team/backintime/blob/dev/CONTRIBUTING.md#how-to-contribute-to-back-in-time
+ emake -C common test-v
+}
+
+src_install() {
+ emake -C common DESTDIR="${D}" install
+
+ if use qt5 ; then
+ emake -C qt DESTDIR="${D}" install
+ fi
+
+ einstalldocs
+
+ if use examples ; then
+ docinto examples
+ dodoc common/{config-example-local,config-example-ssh}
+ fi
+
+ python_optimize "${D}"
+}
diff --git a/app-backup/backintime/backintime-9999.ebuild b/app-backup/backintime/backintime-9999.ebuild
index 8573020d0f1c..70b61fb635db 100644
--- a/app-backup/backintime/backintime-9999.ebuild
+++ b/app-backup/backintime/backintime-9999.ebuild
@@ -1,34 +1,62 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
-inherit python-single-r1 git-r3 xdg
+PYTHON_COMPAT=( python3_{10..11} )
+inherit python-single-r1 xdg
DESCRIPTION="Backup system inspired by TimeVault and FlyBack"
HOMEPAGE="https://backintime.readthedocs.io/en/latest/ https://github.com/bit-team/backintime/"
-EGIT_REPO_URI="https://github.com/bit-team/backintime/"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/bit-team/backintime/"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/bit-team/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="examples qt5"
+IUSE="examples qt5 test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-DEPEND="${PYTHON_DEPS}
+DEPEND="
+ ${PYTHON_DEPS}
$(python_gen_cond_dep '
dev-python/dbus-python[${PYTHON_USEDEP}]
dev-python/keyring[${PYTHON_USEDEP}]
- ')"
-RDEPEND="${DEPEND}
- net-misc/openssh
+ ')
+"
+RDEPEND="
+ ${DEPEND}
+ virtual/openssh
net-misc/rsync[xattr,acl]
- qt5? ( dev-python/PyQt5[gui,widgets] )"
-BDEPEND="sys-devel/gettext"
+ qt5? ( dev-python/PyQt5[gui,widgets] )
+"
+BDEPEND="
+ sys-devel/gettext
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/pyfakefs[${PYTHON_USEDEP}]
+ ')
+ )
+"
PATCHES=( "${FILESDIR}/${PN}-1.2.1-no-compress-docs-examples.patch" )
+src_prepare() {
+ default
+
+ # Looks at host system too much, so too flaky
+ rm common/test/test_tools.py || die
+ # Fails with dbus/udev issue (likely sandbox)
+ rm common/test/test_snapshots.py || die
+}
+
src_configure() {
pushd common > /dev/null || die
# Not autotools
@@ -43,26 +71,25 @@ src_configure() {
}
src_compile() {
- pushd common > /dev/null || die
- emake
- popd > /dev/null || die
+ emake -C common
if use qt5 ; then
- pushd qt > /dev/null || die
- emake
- popd > /dev/null || die
+ emake -C qt
fi
}
+src_test() {
+ # pytest should work but it can't find the backintime binary, so
+ # use the unittest-based runner instead.
+ # https://github.com/bit-team/backintime/blob/dev/CONTRIBUTING.md#how-to-contribute-to-back-in-time
+ emake -C common test-v
+}
+
src_install() {
- pushd common > /dev/null || die
- emake DESTDIR="${D}" install
- popd > /dev/null || die
+ emake -C common DESTDIR="${D}" install
if use qt5 ; then
- pushd qt > /dev/null || die
- emake DESTDIR="${D}" install
- popd > /dev/null || die
+ emake -C qt DESTDIR="${D}" install
fi
einstalldocs
diff --git a/app-backup/backintime/metadata.xml b/app-backup/backintime/metadata.xml
index 5dda92842a60..c90342e51d48 100644
--- a/app-backup/backintime/metadata.xml
+++ b/app-backup/backintime/metadata.xml
@@ -12,4 +12,7 @@
* When backup should be done (manual, every hour, every day, every week, every month)
</longdescription>
<stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">bit-team/backintime</remote-id>
+ </upstream>
</pkgmetadata>