summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/borgmatic')
-rw-r--r--app-backup/borgmatic/Manifest5
-rw-r--r--app-backup/borgmatic/borgmatic-1.5.13.ebuild71
-rw-r--r--app-backup/borgmatic/borgmatic-1.5.15.ebuild71
-rw-r--r--app-backup/borgmatic/borgmatic-1.8.10.ebuild79
-rw-r--r--app-backup/borgmatic/borgmatic-1.8.8.ebuild79
-rw-r--r--app-backup/borgmatic/borgmatic-1.8.9.ebuild79
-rw-r--r--app-backup/borgmatic/files/borgmatic-1.5.1-systemd_service_bin_path.patch8
-rw-r--r--app-backup/borgmatic/files/borgmatic-1.7.13-no_test_coverage.patch (renamed from app-backup/borgmatic/files/borgmatic-1.5.1-no_test_coverage.patch)4
-rw-r--r--app-backup/borgmatic/files/borgmatic-1.7.14-systemd_service_bin_path.patch8
-rw-r--r--app-backup/borgmatic/metadata.xml8
10 files changed, 256 insertions, 156 deletions
diff --git a/app-backup/borgmatic/Manifest b/app-backup/borgmatic/Manifest
index febf60c24c54..e84c5f79c33b 100644
--- a/app-backup/borgmatic/Manifest
+++ b/app-backup/borgmatic/Manifest
@@ -1,2 +1,3 @@
-DIST borgmatic-1.5.13.tar.gz 72469 BLAKE2B 3a71be201143a96968bb1ea6008b62e11f6ab199f44f38d0d66f31f24827a8f32cc7b8f50cc5d33a8bbd7046e6697afe509525be90dd9519f4c686b8737f64c5 SHA512 60bcbcc825db3f93a423ab8e44e0b0809ff4937d8e41bc56ec6226e4865c3a66fae8b6749d33cdb0692ea9dd07cfff56750ff2feee68c96791b83c9dd5f35433
-DIST borgmatic-1.5.15.tar.gz 275702 BLAKE2B c01c469a4e0b96f4a364e0e44cd26d60cf34bc1c969cbf9931ee5ec6688cf012a1c22acb20e3a434b765ef5ec68657a2507e292e5ed3b9e0587f8784e85ecfe9 SHA512 5520e2e903162caa42c66c1e172af225f5f9622c1b33e5f0854f2dc8379752865e8cb8c442e545ec4fc98509e5c7c863373b12e57cf0bbd417b4e8c0887a27fc
+DIST borgmatic-1.8.10.tar.gz 599453 BLAKE2B 1ae994d452d29139d23940500d7c9f01e7fc1ddbd36254bf0c36d7f56064ccba7fb8434741dd0114d42271eb241098a12f8a07b83046447ae2225f7cd2ab12ae SHA512 10f5d962f6d25ef42ba4d076e238e1986dcfcd9832b3eea08560f367524824fdb0f80f42962ea6a471d711c6a0e293669b85abdc160475c20eed851ce7ad7f42
+DIST borgmatic-1.8.8.tar.gz 589575 BLAKE2B 09a3ca616bd1cf5fcc6c773d8066357d764b44230d691b7afa90bb1fdbce3aa3bfaac509e921adaa9086ba60310b24d1f2ba186849853c8f04e2a85c4b0ec94f SHA512 3984f6e34f8aed5c57df22799e60724903bfcec833e5c3215ad731977b7d376f36129fabd489c166f945d7103f272bcc132a9ea49010552001794b57f27fb5d5
+DIST borgmatic-1.8.9.tar.gz 592715 BLAKE2B 3586404985b8cc0d5575f570ba6679c406e95b83453a7c2414872049067b1736010b9f8498fa92e91d281b1cdf75882bc09e40d6d9e443bff33c399ee1392ff9 SHA512 05386f6321d78e304030ebb78c495aee53a1b6f17241f101e73a097aa4208ac641d6105b1e8161cf714b2eab7c34fe682e082e9e997dc4ac6a6a4207253e8421
diff --git a/app-backup/borgmatic/borgmatic-1.5.13.ebuild b/app-backup/borgmatic/borgmatic-1.5.13.ebuild
deleted file mode 100644
index 5fd3f3e72644..000000000000
--- a/app-backup/borgmatic/borgmatic-1.5.13.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_SETUPTOOLS="rdepend"
-
-inherit distutils-r1 systemd
-
-DESCRIPTION="Automatically create, prune and verify backups with borgbackup"
-HOMEPAGE="https://torsion.org/borgmatic/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64"
-
-# Fails due to problems with dev-python/flexmock-0.10.4; see Bug #740128
-RESTRICT="test"
-
-# borg is called as an external tool, hence no pythonic stuff
-RDEPEND="app-backup/borgbackup
- $(python_gen_cond_dep '
- dev-python/colorama[${PYTHON_USEDEP}]
- >=dev-python/pykwalify-1.6.0[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- <dev-python/ruamel-yaml-0.18.0[${PYTHON_USEDEP}]
- ')"
-#BDEPEND="
-# test? (
-# $(python_gen_cond_dep '
-# dev-python/flexmock[${PYTHON_USEDEP}]
-# ')
-# )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.5.1-systemd_service_bin_path.patch
- "${FILESDIR}"/${PN}-1.5.1-no_test_coverage.patch
-)
-
-distutils_enable_tests pytest
-
-src_prepare() {
- distutils-r1_src_prepare
-
- # Unlike the other two test files in integration/commands, which use the
- # relevant modules' respective APIs, test_borgmatic.py tries to call the
- # 'borgmatic' executable - which by the time we execute src_test will
- # not have been created yet. Adding --install to distutils_enable_tests would
- # likely take care of this - but between the aforementioned behaviour
- # inconsistency and the fact the only test run from this file as of version
- # 1.5.13 is the parsing of contents of 'borgmatic --version', just skip it.
- rm -f "${S}"/tests/integration/commands/test_borgmatic.py
-}
-
-src_install() {
- distutils-r1_src_install
- systemd_dounit sample/systemd/borgmatic.{service,timer}
- keepdir /etc/borgmatic
-}
-
-pkg_postinst() {
- if [[ -z "${REPLACING_VERSIONS}" ]]; then
- elog "To generate a sample configuration file, run:"
- elog " generate-borgmatic-config"
- fi
- elog
- elog "Systemd users wishing to periodically run borgmatic can use the provided timer and service units."
-}
diff --git a/app-backup/borgmatic/borgmatic-1.5.15.ebuild b/app-backup/borgmatic/borgmatic-1.5.15.ebuild
deleted file mode 100644
index 55397ae435f9..000000000000
--- a/app-backup/borgmatic/borgmatic-1.5.15.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..9} )
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_SETUPTOOLS="rdepend"
-
-inherit distutils-r1 systemd
-
-DESCRIPTION="Automatically create, prune and verify backups with borgbackup"
-HOMEPAGE="https://torsion.org/borgmatic/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~riscv"
-
-# Fails due to problems with dev-python/flexmock-0.10.4; see Bug #740128
-RESTRICT="test"
-
-# borg is called as an external tool, hence no pythonic stuff
-RDEPEND="app-backup/borgbackup
- $(python_gen_cond_dep '
- dev-python/colorama[${PYTHON_USEDEP}]
- >=dev-python/pykwalify-1.6.0[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- <dev-python/ruamel-yaml-0.18.0[${PYTHON_USEDEP}]
- ')"
-#BDEPEND="
-# test? (
-# $(python_gen_cond_dep '
-# dev-python/flexmock[${PYTHON_USEDEP}]
-# ')
-# )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.5.1-systemd_service_bin_path.patch
- "${FILESDIR}"/${PN}-1.5.1-no_test_coverage.patch
-)
-
-distutils_enable_tests pytest
-
-src_prepare() {
- distutils-r1_src_prepare
-
- # Unlike the other two test files in integration/commands, which use the
- # relevant modules' respective APIs, test_borgmatic.py tries to call the
- # 'borgmatic' executable - which by the time we execute src_test will
- # not have been created yet. Adding --install to distutils_enable_tests would
- # likely take care of this - but between the aforementioned behaviour
- # inconsistency and the fact the only test run from this file as of version
- # 1.5.13 is the parsing of contents of 'borgmatic --version', just skip it.
- rm -f "${S}"/tests/integration/commands/test_borgmatic.py
-}
-
-src_install() {
- distutils-r1_src_install
- systemd_dounit sample/systemd/borgmatic.{service,timer}
- keepdir /etc/borgmatic
-}
-
-pkg_postinst() {
- if [[ -z "${REPLACING_VERSIONS}" ]]; then
- elog "To generate a sample configuration file, run:"
- elog " generate-borgmatic-config"
- fi
- elog
- elog "Systemd users wishing to periodically run borgmatic can use the provided timer and service units."
-}
diff --git a/app-backup/borgmatic/borgmatic-1.8.10.ebuild b/app-backup/borgmatic/borgmatic-1.8.10.ebuild
new file mode 100644
index 000000000000..09e09f4eea4c
--- /dev/null
+++ b/app-backup/borgmatic/borgmatic-1.8.10.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 systemd pypi
+
+DESCRIPTION="Automatically create, prune and verify backups with borgbackup"
+HOMEPAGE="https://torsion.org/borgmatic/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv"
+IUSE="apprise"
+
+REQUIRED_USE="test? ( apprise )"
+
+# borg is called as an external tool, hence no pythonic stuff
+RDEPEND="app-backup/borgbackup
+ $(python_gen_cond_dep '
+ <dev-python/colorama-0.5[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ ')
+ apprise? ( $(python_gen_cond_dep '
+ dev-python/apprise[${PYTHON_USEDEP}]
+ ') )"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/flexmock-0.10.10[${PYTHON_USEDEP}]
+ ')
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7.13-no_test_coverage.patch
+ "${FILESDIR}"/${PN}-1.7.14-systemd_service_bin_path.patch
+)
+
+# A fragile test whose only purpose is to make sure the NEWS file
+# has been updated for the current version.
+EPYTEST_DESELECT=(
+ tests/integration/commands/test_borgmatic.py::test_borgmatic_version_matches_news_version
+)
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+ systemd_dounit sample/systemd/borgmatic.{service,timer}
+ keepdir /etc/borgmatic
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "To generate a sample configuration file, run:"
+ elog " ${PN} config generate"
+ else
+ local oldver
+ for oldver in ${REPLACING_VERSIONS}; do
+ if ver_test "${oldver}" -lt 1.8.0; then
+ ewarn "Please be warned that ${PN}-1.8.0 has introduced several breaking changes."
+ ewarn "For details, please see"
+ ewarn
+ ewarn " https://github.com/borgmatic-collective/borgmatic/releases/tag/1.8.0"
+ ewarn
+ break
+ fi
+ done
+ fi
+ elog
+ elog "Systemd users wishing to periodically run ${PN} can use the provided timer and service units."
+}
diff --git a/app-backup/borgmatic/borgmatic-1.8.8.ebuild b/app-backup/borgmatic/borgmatic-1.8.8.ebuild
new file mode 100644
index 000000000000..0155eb3b0714
--- /dev/null
+++ b/app-backup/borgmatic/borgmatic-1.8.8.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 systemd pypi
+
+DESCRIPTION="Automatically create, prune and verify backups with borgbackup"
+HOMEPAGE="https://torsion.org/borgmatic/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~riscv"
+IUSE="apprise"
+
+REQUIRED_USE="test? ( apprise )"
+
+# borg is called as an external tool, hence no pythonic stuff
+RDEPEND="app-backup/borgbackup
+ $(python_gen_cond_dep '
+ <dev-python/colorama-0.5[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ ')
+ apprise? ( $(python_gen_cond_dep '
+ dev-python/apprise[${PYTHON_USEDEP}]
+ ') )"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/flexmock-0.10.10[${PYTHON_USEDEP}]
+ ')
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7.13-no_test_coverage.patch
+ "${FILESDIR}"/${PN}-1.7.14-systemd_service_bin_path.patch
+)
+
+# A fragile test whose only purpose is to make sure the NEWS file
+# has been updated for the current version.
+EPYTEST_DESELECT=(
+ tests/integration/commands/test_borgmatic.py::test_borgmatic_version_matches_news_version
+)
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+ systemd_dounit sample/systemd/borgmatic.{service,timer}
+ keepdir /etc/borgmatic
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "To generate a sample configuration file, run:"
+ elog " ${PN} config generate"
+ else
+ local oldver
+ for oldver in ${REPLACING_VERSIONS}; do
+ if ver_test "${oldver}" -lt 1.8.0; then
+ ewarn "Please be warned that ${PN}-1.8.0 has introduced several breaking changes."
+ ewarn "For details, please see"
+ ewarn
+ ewarn " https://github.com/borgmatic-collective/borgmatic/releases/tag/1.8.0"
+ ewarn
+ break
+ fi
+ done
+ fi
+ elog
+ elog "Systemd users wishing to periodically run ${PN} can use the provided timer and service units."
+}
diff --git a/app-backup/borgmatic/borgmatic-1.8.9.ebuild b/app-backup/borgmatic/borgmatic-1.8.9.ebuild
new file mode 100644
index 000000000000..0155eb3b0714
--- /dev/null
+++ b/app-backup/borgmatic/borgmatic-1.8.9.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 systemd pypi
+
+DESCRIPTION="Automatically create, prune and verify backups with borgbackup"
+HOMEPAGE="https://torsion.org/borgmatic/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~riscv"
+IUSE="apprise"
+
+REQUIRED_USE="test? ( apprise )"
+
+# borg is called as an external tool, hence no pythonic stuff
+RDEPEND="app-backup/borgbackup
+ $(python_gen_cond_dep '
+ <dev-python/colorama-0.5[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ ')
+ apprise? ( $(python_gen_cond_dep '
+ dev-python/apprise[${PYTHON_USEDEP}]
+ ') )"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/flexmock-0.10.10[${PYTHON_USEDEP}]
+ ')
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7.13-no_test_coverage.patch
+ "${FILESDIR}"/${PN}-1.7.14-systemd_service_bin_path.patch
+)
+
+# A fragile test whose only purpose is to make sure the NEWS file
+# has been updated for the current version.
+EPYTEST_DESELECT=(
+ tests/integration/commands/test_borgmatic.py::test_borgmatic_version_matches_news_version
+)
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+ systemd_dounit sample/systemd/borgmatic.{service,timer}
+ keepdir /etc/borgmatic
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "To generate a sample configuration file, run:"
+ elog " ${PN} config generate"
+ else
+ local oldver
+ for oldver in ${REPLACING_VERSIONS}; do
+ if ver_test "${oldver}" -lt 1.8.0; then
+ ewarn "Please be warned that ${PN}-1.8.0 has introduced several breaking changes."
+ ewarn "For details, please see"
+ ewarn
+ ewarn " https://github.com/borgmatic-collective/borgmatic/releases/tag/1.8.0"
+ ewarn
+ break
+ fi
+ done
+ fi
+ elog
+ elog "Systemd users wishing to periodically run ${PN} can use the provided timer and service units."
+}
diff --git a/app-backup/borgmatic/files/borgmatic-1.5.1-systemd_service_bin_path.patch b/app-backup/borgmatic/files/borgmatic-1.5.1-systemd_service_bin_path.patch
deleted file mode 100644
index 90e94ac1f558..000000000000
--- a/app-backup/borgmatic/files/borgmatic-1.5.1-systemd_service_bin_path.patch
+++ /dev/null
@@ -1,8 +0,0 @@
---- a/sample/systemd/borgmatic.service
-+++ b/sample/systemd/borgmatic.service
-@@ -21,4 +21,4 @@
-
- # Delay start to prevent backups running during boot.
- ExecStartPre=sleep 1m
--ExecStart=systemd-inhibit --who="borgmatic" --why="Prevent interrupting scheduled backup" /root/.local/bin/borgmatic --syslog-verbosity 1
-+ExecStart=systemd-inhibit --who="borgmatic" --why="Prevent interrupting scheduled backup" /usr/bin/borgmatic --syslog-verbosity 1
diff --git a/app-backup/borgmatic/files/borgmatic-1.5.1-no_test_coverage.patch b/app-backup/borgmatic/files/borgmatic-1.7.13-no_test_coverage.patch
index 28562398a407..a3c02598b724 100644
--- a/app-backup/borgmatic/files/borgmatic-1.5.1-no_test_coverage.patch
+++ b/app-backup/borgmatic/files/borgmatic-1.7.13-no_test_coverage.patch
@@ -6,6 +6,6 @@
testpaths = tests
-addopts = --cov-report term-missing:skip-covered --cov=borgmatic --ignore=tests/end-to-end
+addopts = --ignore=tests/end-to-end
- filterwarnings =
- ignore:Coverage disabled.*:pytest.PytestWarning
+ [flake8]
+ max-line-length = 100
diff --git a/app-backup/borgmatic/files/borgmatic-1.7.14-systemd_service_bin_path.patch b/app-backup/borgmatic/files/borgmatic-1.7.14-systemd_service_bin_path.patch
new file mode 100644
index 000000000000..5e6f8b7482b5
--- /dev/null
+++ b/app-backup/borgmatic/files/borgmatic-1.7.14-systemd_service_bin_path.patch
@@ -0,0 +1,8 @@
+--- a/sample/systemd/borgmatic.service
++++ b/sample/systemd/borgmatic.service
+@@ -61,4 +61,4 @@
+ # Delay start to prevent backups running during boot. Note that systemd-inhibit requires dbus and
+ # dbus-user-session to be installed.
+ ExecStartPre=sleep 1m
+-ExecStart=systemd-inhibit --who="borgmatic" --what="sleep:shutdown" --why="Prevent interrupting scheduled backup" /root/.local/bin/borgmatic --verbosity -2 --syslog-verbosity 1
++ExecStart=systemd-inhibit --who="borgmatic" --what="sleep:shutdown" --why="Prevent interrupting scheduled backup" /usr/bin/borgmatic --verbosity -2 --syslog-verbosity 1
diff --git a/app-backup/borgmatic/metadata.xml b/app-backup/borgmatic/metadata.xml
index e69f4b798a41..4365e7fa2b90 100644
--- a/app-backup/borgmatic/metadata.xml
+++ b/app-backup/borgmatic/metadata.xml
@@ -1,12 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>marecki@gentoo.org</email>
<name>Marek Szuba</name>
</maintainer>
<upstream>
- <remote-id type="github">witten/borgmatic</remote-id>
+ <remote-id type="github">borgmatic-collective/borgmatic</remote-id>
<remote-id type="pypi">borgmatic</remote-id>
</upstream>
+<use>
+ <flag name="apprise">Allow backup monitoring to send notification to a wide variety
+ of services, using <pkg>dev-python/apprise</pkg></flag>
+</use>
</pkgmetadata>