summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/btrbk/btrbk-9999.ebuild')
-rw-r--r--app-backup/btrbk/btrbk-9999.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/app-backup/btrbk/btrbk-9999.ebuild b/app-backup/btrbk/btrbk-9999.ebuild
index e0800b810e05..b651574dfd63 100644
--- a/app-backup/btrbk/btrbk-9999.ebuild
+++ b/app-backup/btrbk/btrbk-9999.ebuild
@@ -26,15 +26,20 @@ DEPEND="doc? ( >=dev-ruby/asciidoctor-1.5.7 )"
RDEPEND="dev-lang/perl
net-misc/openssh
pv? ( sys-apps/pv )
- >=sys-fs/btrfs-progs-3.18.2"
+ >=sys-fs/btrfs-progs-4.12"
src_compile() {
- use doc && emake -C doc
+ use doc && emake -C doc COMPRESS=no
}
src_install() {
local targets="install-bin install-etc install-share install-systemd"
use doc && targets="${targets} install-man install-doc"
- emake DESTDIR="${D}" DOCDIR="/usr/share/doc/${PF}" SYSTEMDDIR="$(systemd_get_systemunitdir)" ${targets}
+ emake \
+ COMPRESS=no \
+ DESTDIR="${D}" \
+ DOCDIR="/usr/share/doc/${PF}" \
+ SYSTEMDDIR="$(systemd_get_systemunitdir)" \
+ ${targets}
}
pkg_preinst() {
if has_version "<${CATEGORY}/${PN}-0.26.0" ; then