summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/burp')
-rw-r--r--app-backup/burp/Manifest3
-rw-r--r--app-backup/burp/burp-2.4.0-r1.ebuild118
-rw-r--r--app-backup/burp/burp-2.5.4-r1.ebuild118
-rw-r--r--app-backup/burp/burp-2.5.4.ebuild117
-rw-r--r--app-backup/burp/burp-3.1.4.ebuild (renamed from app-backup/burp/burp-2.4.0.ebuild)33
-rw-r--r--app-backup/burp/files/burp-2.1.20-protocol1_by_default.patch24
-rw-r--r--app-backup/burp/files/burp-2.4.0-fix-musl-strptime.patch86
7 files changed, 17 insertions, 482 deletions
diff --git a/app-backup/burp/Manifest b/app-backup/burp/Manifest
index 5d3db1d94a8c..b6427e2bd489 100644
--- a/app-backup/burp/Manifest
+++ b/app-backup/burp/Manifest
@@ -1,2 +1 @@
-DIST burp-2.4.0.tar.gz 624032 BLAKE2B 4a1ff48236dc631dd6d545480a33af3cdf8020c3088f1ca09ab66ac5cec8128d262b9b991bf9e3229c80f75a4746d338073a0a43fdb67a2fe21a0fd4f243469d SHA512 ea81a12e54c6d88b702dd09dc4fa5a724d1e322bdfba2643c9312a9077c9edc63f6ca0f6cb3a6ebecb6ad9feb1cc26c114277b2308d9903f4abb0442a9be7c19
-DIST burp-2.5.4.tar.gz 625018 BLAKE2B 83cb8e48c616f527b2271c6ea5855a303f2925d3d0b83182afc64fe139676a4b1b98349d0ba0636613d3409f100417c4a36b7b1f24bc64bba329940d4587cd2b SHA512 b283e34e76a6887517d72c99deac5e0299efa07dd922d1275666683cc3ba4b040b97e5ce4840cb06025926ea616778811bf4c9c6f9c7564da5122900cdd7bad0
+DIST burp-3.1.4.tar.gz 549879 BLAKE2B bf70051a658700fab60182b97b7ce8540fbd85ad1264ee09c9fa5b5a99046f391b91cd8673097ef869c6b762aea6d8fecdedb38425dca9e6bcbb1f2c2afa96fb SHA512 3aa9fb1512f985fa99e7cb9a45502bbdbf513935e0c62fa4327f0e6cb68d3840f59bfe1b38a7c2419b3e69bc04aef36c223313897c2e45e94f3be3f9d41714db
diff --git a/app-backup/burp/burp-2.4.0-r1.ebuild b/app-backup/burp/burp-2.4.0-r1.ebuild
deleted file mode 100644
index fdcea9103813..000000000000
--- a/app-backup/burp/burp-2.4.0-r1.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools systemd
-
-DESCRIPTION="Network backup and restore client and server for Unix and Windows"
-HOMEPAGE="https://burp.grke.org/"
-SRC_URI="https://github.com/grke/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="AGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="acl ipv6 test xattr"
-
-RESTRICT="!test? ( test )"
-
-COMMON_DEPEND="acct-group/burp
- acct-user/burp
- dev-libs/uthash
- dev-libs/openssl:0=
- net-libs/librsync:=
- sys-libs/ncurses:0=
- sys-libs/libcap
- sys-libs/zlib
- virtual/libcrypt:=
- acl? ( sys-apps/acl )
- xattr? ( sys-apps/attr )"
-DEPEND="${COMMON_DEPEND}
- elibc_musl? ( sys-libs/queue-standalone )
- test? ( dev-libs/check )"
-BDEPEND=">=sys-devel/autoconf-2.71
- virtual/pkgconfig"
-RDEPEND="${COMMON_DEPEND}
- virtual/logger"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.1.20-no_mkdir_run.patch
- "${FILESDIR}"/${PN}-2.1.20-protocol1_by_default.patch
- "${FILESDIR}"/${PN}-2.0.54-server_user.patch
- "${FILESDIR}"/${PN}-2.4.0-fix-musl-strptime.patch
-)
-
-src_prepare() {
- default
-
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --localstatedir=/var
- --sysconfdir=/etc/burp
- --enable-largefile
- --runstatedir=/run
- $(use_enable acl)
- $(use_enable ipv6)
- $(use_enable xattr)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_test() {
- # See https://github.com/grke/burp/issues/869
- local -x CK_DEFAULT_TIMEOUT=10
- default
-}
-
-src_install() {
- default
- keepdir /var/spool/burp
- fowners -R root:${PN} /var/spool/burp
- fperms 0770 /var/spool/burp
-
- emake DESTDIR="${D}" install-configs
- fowners -R root:${PN} /etc/burp
- fperms 0750 /etc/burp
- fperms 0640 /etc/burp/burp-server.conf
- fperms 0750 /etc/burp/clientconfdir
-
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- systemd_dounit "${FILESDIR}"/${PN}.service
-}
-
-pkg_postinst() {
- elog "Burp ebuilds now support the autoupgrade mechanism in both"
- elog "client and server mode. In both cases it is disabled by"
- elog "default. You almost certainly do NOT want to enable it in"
- elog "client mode because upgrades obtained this way will not be"
- elog "managed by Portage."
-
- if [[ ! -e ${EROOT}/etc/burp/CA/index.txt ]]; then
- elog ""
- elog "At first run burp server will generate DH parameters and SSL"
- elog "certificates. You should adjust configuration before."
- elog "Server configuration is located at"
- elog ""
- elog " ${EROOT}/etc/burp/burp-server.conf"
- elog ""
- fi
-
- # According to PMS this can be a space-separated list of version
- # numbers, even though in practice it is typically just one.
- local oldver
- for oldver in ${REPLACING_VERSIONS}; do
- if [[ $(ver_cut 1 ${oldver}) -lt 2 ]]; then
- ewarn "Starting with version 2.0.54 we no longer patch bedup to use"
- ewarn "the server config file by default. If you use bedup, please"
- ewarn "update your scripts to invoke it as"
- ewarn ""
- ewarn " bedup -c ${EROOT}/etc/burp/burp-server.conf"
- ewarn ""
- ewarn "Otherwise deduplication will not work!"
- break
- fi
- done
-}
diff --git a/app-backup/burp/burp-2.5.4-r1.ebuild b/app-backup/burp/burp-2.5.4-r1.ebuild
deleted file mode 100644
index fdcea9103813..000000000000
--- a/app-backup/burp/burp-2.5.4-r1.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools systemd
-
-DESCRIPTION="Network backup and restore client and server for Unix and Windows"
-HOMEPAGE="https://burp.grke.org/"
-SRC_URI="https://github.com/grke/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="AGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="acl ipv6 test xattr"
-
-RESTRICT="!test? ( test )"
-
-COMMON_DEPEND="acct-group/burp
- acct-user/burp
- dev-libs/uthash
- dev-libs/openssl:0=
- net-libs/librsync:=
- sys-libs/ncurses:0=
- sys-libs/libcap
- sys-libs/zlib
- virtual/libcrypt:=
- acl? ( sys-apps/acl )
- xattr? ( sys-apps/attr )"
-DEPEND="${COMMON_DEPEND}
- elibc_musl? ( sys-libs/queue-standalone )
- test? ( dev-libs/check )"
-BDEPEND=">=sys-devel/autoconf-2.71
- virtual/pkgconfig"
-RDEPEND="${COMMON_DEPEND}
- virtual/logger"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.1.20-no_mkdir_run.patch
- "${FILESDIR}"/${PN}-2.1.20-protocol1_by_default.patch
- "${FILESDIR}"/${PN}-2.0.54-server_user.patch
- "${FILESDIR}"/${PN}-2.4.0-fix-musl-strptime.patch
-)
-
-src_prepare() {
- default
-
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --localstatedir=/var
- --sysconfdir=/etc/burp
- --enable-largefile
- --runstatedir=/run
- $(use_enable acl)
- $(use_enable ipv6)
- $(use_enable xattr)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_test() {
- # See https://github.com/grke/burp/issues/869
- local -x CK_DEFAULT_TIMEOUT=10
- default
-}
-
-src_install() {
- default
- keepdir /var/spool/burp
- fowners -R root:${PN} /var/spool/burp
- fperms 0770 /var/spool/burp
-
- emake DESTDIR="${D}" install-configs
- fowners -R root:${PN} /etc/burp
- fperms 0750 /etc/burp
- fperms 0640 /etc/burp/burp-server.conf
- fperms 0750 /etc/burp/clientconfdir
-
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- systemd_dounit "${FILESDIR}"/${PN}.service
-}
-
-pkg_postinst() {
- elog "Burp ebuilds now support the autoupgrade mechanism in both"
- elog "client and server mode. In both cases it is disabled by"
- elog "default. You almost certainly do NOT want to enable it in"
- elog "client mode because upgrades obtained this way will not be"
- elog "managed by Portage."
-
- if [[ ! -e ${EROOT}/etc/burp/CA/index.txt ]]; then
- elog ""
- elog "At first run burp server will generate DH parameters and SSL"
- elog "certificates. You should adjust configuration before."
- elog "Server configuration is located at"
- elog ""
- elog " ${EROOT}/etc/burp/burp-server.conf"
- elog ""
- fi
-
- # According to PMS this can be a space-separated list of version
- # numbers, even though in practice it is typically just one.
- local oldver
- for oldver in ${REPLACING_VERSIONS}; do
- if [[ $(ver_cut 1 ${oldver}) -lt 2 ]]; then
- ewarn "Starting with version 2.0.54 we no longer patch bedup to use"
- ewarn "the server config file by default. If you use bedup, please"
- ewarn "update your scripts to invoke it as"
- ewarn ""
- ewarn " bedup -c ${EROOT}/etc/burp/burp-server.conf"
- ewarn ""
- ewarn "Otherwise deduplication will not work!"
- break
- fi
- done
-}
diff --git a/app-backup/burp/burp-2.5.4.ebuild b/app-backup/burp/burp-2.5.4.ebuild
deleted file mode 100644
index f43a92ad64bd..000000000000
--- a/app-backup/burp/burp-2.5.4.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools systemd
-
-DESCRIPTION="Network backup and restore client and server for Unix and Windows"
-HOMEPAGE="https://burp.grke.org/"
-SRC_URI="https://github.com/grke/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="AGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="acl ipv6 test xattr"
-
-RESTRICT="!test? ( test )"
-
-COMMON_DEPEND="acct-group/burp
- acct-user/burp
- dev-libs/uthash
- dev-libs/openssl:0=
- net-libs/librsync:=
- sys-libs/ncurses:0=
- sys-libs/libcap
- sys-libs/zlib
- virtual/libcrypt:=
- acl? ( sys-apps/acl )
- xattr? ( sys-apps/attr )"
-DEPEND="${COMMON_DEPEND}
- elibc_musl? ( sys-libs/queue-standalone )
- test? ( dev-libs/check )"
-BDEPEND=">=sys-devel/autoconf-2.71
- virtual/pkgconfig"
-RDEPEND="${COMMON_DEPEND}
- virtual/logger"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.1.20-no_mkdir_run.patch
- "${FILESDIR}"/${PN}-2.1.20-protocol1_by_default.patch
- "${FILESDIR}"/${PN}-2.0.54-server_user.patch
-)
-
-src_prepare() {
- default
-
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --localstatedir=/var
- --sysconfdir=/etc/burp
- --enable-largefile
- --runstatedir=/run
- $(use_enable acl)
- $(use_enable ipv6)
- $(use_enable xattr)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_test() {
- # See https://github.com/grke/burp/issues/869
- local -x CK_DEFAULT_TIMEOUT=10
- default
-}
-
-src_install() {
- default
- keepdir /var/spool/burp
- fowners -R root:${PN} /var/spool/burp
- fperms 0770 /var/spool/burp
-
- emake DESTDIR="${D}" install-configs
- fowners -R root:${PN} /etc/burp
- fperms 0750 /etc/burp
- fperms 0640 /etc/burp/burp-server.conf
- fperms 0750 /etc/burp/clientconfdir
-
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- systemd_dounit "${FILESDIR}"/${PN}.service
-}
-
-pkg_postinst() {
- elog "Burp ebuilds now support the autoupgrade mechanism in both"
- elog "client and server mode. In both cases it is disabled by"
- elog "default. You almost certainly do NOT want to enable it in"
- elog "client mode because upgrades obtained this way will not be"
- elog "managed by Portage."
-
- if [[ ! -e ${EROOT}/etc/burp/CA/index.txt ]]; then
- elog ""
- elog "At first run burp server will generate DH parameters and SSL"
- elog "certificates. You should adjust configuration before."
- elog "Server configuration is located at"
- elog ""
- elog " ${EROOT}/etc/burp/burp-server.conf"
- elog ""
- fi
-
- # According to PMS this can be a space-separated list of version
- # numbers, even though in practice it is typically just one.
- local oldver
- for oldver in ${REPLACING_VERSIONS}; do
- if [[ $(ver_cut 1 ${oldver}) -lt 2 ]]; then
- ewarn "Starting with version 2.0.54 we no longer patch bedup to use"
- ewarn "the server config file by default. If you use bedup, please"
- ewarn "update your scripts to invoke it as"
- ewarn ""
- ewarn " bedup -c ${EROOT}/etc/burp/burp-server.conf"
- ewarn ""
- ewarn "Otherwise deduplication will not work!"
- break
- fi
- done
-}
diff --git a/app-backup/burp/burp-2.4.0.ebuild b/app-backup/burp/burp-3.1.4.ebuild
index b694099ed5d7..8c7a5924016a 100644
--- a/app-backup/burp/burp-2.4.0.ebuild
+++ b/app-backup/burp/burp-3.1.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/grke/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="AGPL-3"
SLOT="0"
KEYWORDS="amd64 ~arm x86"
-IUSE="acl ipv6 test xattr"
+IUSE="acl test xattr"
RESTRICT="!test? ( test )"
@@ -30,15 +30,14 @@ COMMON_DEPEND="acct-group/burp
DEPEND="${COMMON_DEPEND}
elibc_musl? ( sys-libs/queue-standalone )
test? ( dev-libs/check )"
-BDEPEND=">=sys-devel/autoconf-2.71
+BDEPEND=">=dev-build/autoconf-2.71
virtual/pkgconfig"
RDEPEND="${COMMON_DEPEND}
virtual/logger"
PATCHES=(
- "${FILESDIR}"/${PN}-2.1.20-no_mkdir_run.patch
- "${FILESDIR}"/${PN}-2.1.20-protocol1_by_default.patch
- "${FILESDIR}"/${PN}-2.0.54-server_user.patch
+ "${FILESDIR}"/"${PN}"-2.1.20-no_mkdir_run.patch
+ "${FILESDIR}"/"${PN}"-2.0.54-server_user.patch
)
src_prepare() {
@@ -53,33 +52,33 @@ src_configure() {
--sysconfdir=/etc/burp
--enable-largefile
--runstatedir=/run
- $(use_enable acl)
- $(use_enable ipv6)
- $(use_enable xattr)
+ "$(use_enable acl)"
+ "$(use_enable xattr)"
)
econf "${myeconfargs[@]}"
}
src_test() {
- # See https://github.com/grke/burp/issues/869
- local -x CK_DEFAULT_TIMEOUT=10
+ # See https://bugs.gentoo.org/915690
+ local -x CK_DEFAULT_TIMEOUT=0
+ local -x CK_TIMEOUT_MULTIPLIER=0
default
}
src_install() {
default
keepdir /var/spool/burp
- fowners -R root:${PN} /var/spool/burp
+ fowners -R root:"${PN}" /var/spool/burp
fperms 0770 /var/spool/burp
emake DESTDIR="${D}" install-configs
- fowners -R root:${PN} /etc/burp
+ fowners -R root:"${PN}" /etc/burp
fperms 0750 /etc/burp
fperms 0640 /etc/burp/burp-server.conf
fperms 0750 /etc/burp/clientconfdir
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- systemd_dounit "${FILESDIR}"/${PN}.service
+ newinitd "${FILESDIR}"/"${PN}".initd "${PN}"
+ systemd_dounit "${FILESDIR}"/"${PN}".service
}
pkg_postinst() {
@@ -89,7 +88,7 @@ pkg_postinst() {
elog "client mode because upgrades obtained this way will not be"
elog "managed by Portage."
- if [[ ! -e ${EROOT}/etc/burp/CA/index.txt ]]; then
+ if [[ ! -e "${EROOT}"/etc/burp/CA/index.txt ]]; then
elog ""
elog "At first run burp server will generate DH parameters and SSL"
elog "certificates. You should adjust configuration before."
@@ -103,7 +102,7 @@ pkg_postinst() {
# numbers, even though in practice it is typically just one.
local oldver
for oldver in ${REPLACING_VERSIONS}; do
- if [[ $(ver_cut 1 ${oldver}) -lt 2 ]]; then
+ if [[ $(ver_cut 1 "${oldver}") -lt 2 ]]; then
ewarn "Starting with version 2.0.54 we no longer patch bedup to use"
ewarn "the server config file by default. If you use bedup, please"
ewarn "update your scripts to invoke it as"
diff --git a/app-backup/burp/files/burp-2.1.20-protocol1_by_default.patch b/app-backup/burp/files/burp-2.1.20-protocol1_by_default.patch
deleted file mode 100644
index db9e9b6a9de5..000000000000
--- a/app-backup/burp/files/burp-2.1.20-protocol1_by_default.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/configs/client/burp.conf.in
-+++ b/configs/client/burp.conf.in
-@@ -10,7 +10,8 @@
- # 0 to decide automatically, 1 to force protocol1 mode (file level granularity
- # with a pseudo mirrored storage on the server and optional rsync). 2 forces
- # protocol2 mode (inline deduplication with variable length blocks).
--# protocol = 0
-+# WARNING: as of September 2017 protocol2 is still considered experimental.
-+protocol = 1
- pidfile = @runstatedir@/@name@.client.pid
- syslog = 0
- stdout = 1
---- a/configs/server/burp.conf.in
-+++ b/configs/server/burp.conf.in
-@@ -21,7 +21,8 @@
- # protocol2 mode (inline deduplication with variable length blocks).
- # Like many other settings, this can be set per client in the clientconfdir
- # files.
--# protocol = 0
-+# WARNING: as of September 2017 protocol2 is still considered experimental.
-+protocol = 1
- pidfile = @runstatedir@/@name@.server.pid
- hardlinked_archive = 0
- working_dir_recovery_method = delete
diff --git a/app-backup/burp/files/burp-2.4.0-fix-musl-strptime.patch b/app-backup/burp/files/burp-2.4.0-fix-musl-strptime.patch
deleted file mode 100644
index e8afca8fefa7..000000000000
--- a/app-backup/burp/files/burp-2.4.0-fix-musl-strptime.patch
+++ /dev/null
@@ -1,86 +0,0 @@
-https://github.com/grke/burp/commit/76b7f1ba9f4445108059b13f3d79a7fde8a292a3
-https://github.com/grke/burp/issues/908
-https://bugs.gentoo.org/862019
-
-From 76b7f1ba9f4445108059b13f3d79a7fde8a292a3 Mon Sep 17 00:00:00 2001
-From: Graham Keeling <grke@grke.net>
-Date: Mon, 8 Aug 2022 07:53:38 +1000
-Subject: [PATCH] 908: Only glibc supports %z in strptime()
-
-Change-Id: I220e4529073c92df856b892559725b323dc84334
----
- src/times.h | 8 ++++----
- utest/client/monitor/test_json_input.c | 15 +++++++++++----
- utest/test_times.c | 7 ++++---
- 3 files changed, 19 insertions(+), 11 deletions(-)
-
-diff --git a/src/times.h b/src/times.h
-index 325419c2b..b0fd3876f 100644
---- a/src/times.h
-+++ b/src/times.h
-@@ -3,11 +3,11 @@
-
- #define DEFAULT_TIMESTAMP_FORMAT_OLD "%Y-%m-%d %H:%M:%S"
-
--// Windows does not seem to support %z.
--#ifdef HAVE_WIN32
--#define DEFAULT_TIMESTAMP_FORMAT DEFAULT_TIMESTAMP_FORMAT_OLD
--#else
-+#ifdef __GLIBC__
- #define DEFAULT_TIMESTAMP_FORMAT "%Y-%m-%d %H:%M:%S %z"
-+#else
-+// Only glibc supports %z in strptime.
-+#define DEFAULT_TIMESTAMP_FORMAT DEFAULT_TIMESTAMP_FORMAT_OLD
- #endif
-
- extern const char *getdatestr(const time_t t);
-diff --git a/utest/client/monitor/test_json_input.c b/utest/client/monitor/test_json_input.c
-index 516fc779b..aea2a4154 100644
---- a/utest/client/monitor/test_json_input.c
-+++ b/utest/client/monitor/test_json_input.c
-@@ -162,13 +162,20 @@ static struct sd sd1[] = {
-
- static void assert_bu_minimal(struct bu *bu, struct sd *s)
- {
-- const char *sd_timestamp;
-+ const char *cp;
-+ const char *cp_end;
- fail_unless(bu!=NULL);
- fail_unless(s->bno==bu->bno);
- fail_unless(s->flags==bu->flags);
-- fail_unless((sd_timestamp=strchr(s->timestamp, ' '))!=NULL);
-- sd_timestamp++;
-- ck_assert_str_eq(sd_timestamp, bu->timestamp);
-+ fail_unless((cp=strchr(s->timestamp, ' '))!=NULL);
-+ cp++;
-+#ifdef __GLIBC__
-+ cp_end=s->timestamp+strlen(s->timestamp)-1;
-+#else
-+ // Only glibc supports %z in strptime.
-+ fail_unless((cp_end=strrchr(s->timestamp, ' '))!=NULL);
-+#endif
-+ fail_unless(strncmp(cp, bu->timestamp, cp_end-cp)==0);
- }
-
- static void do_test_json_clients_with_backup(const char *path,
-diff --git a/utest/test_times.c b/utest/test_times.c
-index 98be11fd1..5a68203a6 100644
---- a/utest/test_times.c
-+++ b/utest/test_times.c
-@@ -35,12 +35,13 @@ struct ds
-
- static struct ds ds[] = {
- { 0, "", "never" },
--#ifdef HAVE_WIN32
-- { 1000, "", "1970-01-01 00:16:40" },
--#else
-+#ifdef __GLIBC__
- { 1000, "", "1970-01-01 00:16:40 +0000" },
- { 1000, "UTC+10", "1969-12-31 14:16:40 -1000" },
- { 1000, "UTC+10", "1969-12-31 14:16:40 -1000" },
-+#else
-+ // Only glibc supports %z in strptime.
-+ { 1000, "", "1970-01-01 00:16:40" },
- #endif
- };
-