summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/dar')
-rw-r--r--app-backup/dar/Manifest3
-rw-r--r--app-backup/dar/dar-2.7.1.ebuild90
-rw-r--r--app-backup/dar/dar-2.7.14.ebuild (renamed from app-backup/dar/dar-2.7.2.ebuild)26
-rw-r--r--app-backup/dar/metadata.xml9
4 files changed, 20 insertions, 108 deletions
diff --git a/app-backup/dar/Manifest b/app-backup/dar/Manifest
index 79390a742e90..06ab9425b9ea 100644
--- a/app-backup/dar/Manifest
+++ b/app-backup/dar/Manifest
@@ -1,2 +1 @@
-DIST dar-2.7.1.tar.gz 2290659 BLAKE2B 89fa7ac208eb3009f5151f27022a7a449bb204cb035f320e33ff642588b5ab0389c2ed33b71b7a7c6240d205877073f26a04f0164ce05bb370db3bc3faf25fda SHA512 404e3281b2c420088623e4c6ba262d2a7a44848986e43d4c71aff77104395f1178445d560849a73e0dbacce6b8014df2bb20bc33471ae2d07d897bb6ad577bcc
-DIST dar-2.7.2.tar.gz 2294187 BLAKE2B 6422f40aea9fe07195359d9e8d5a947fe20d1ec4d6bd866eb8e9240c153d069b5df75018c25b9e8ce6b7acbf4ce4259b50b0768cd391d8b9b1c7be72f03a56b6 SHA512 7e41adc0102806c07d644da41960b1e5bcb6b7872e6a5789506c1f2a001ffb4e3607cae6f76ccc2339d90cf4387b7645e9de6dbc4eed1306827a46e4b7c9d09d
+DIST dar-2.7.14.tar.gz 2443548 BLAKE2B a68ad06a2bf53b25a0b393f3e85eef5676382d63bfd86ba77696667786a688e326c118d937cd5dae6b1e78410e40295c67d8ba4677c37f7139bbdd2794c4efeb SHA512 0436c67e0dbd8f5e96e01a0db48a469d80fb81a7c7f37aed98308bd55d60d699b21c755d95fa83891690231fd2510eaa6c6652fb99a1bad9c8210084031391d4
diff --git a/app-backup/dar/dar-2.7.1.ebuild b/app-backup/dar/dar-2.7.1.ebuild
deleted file mode 100644
index 76ce18d6253a..000000000000
--- a/app-backup/dar/dar-2.7.1.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic
-
-DESCRIPTION="A full featured backup tool, aimed for disks"
-HOMEPAGE="http://dar.linux.free.fr/"
-SRC_URI="mirror://sourceforge/dar/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc sparc x86 ~amd64-linux"
-IUSE="argon2 curl dar32 dar64 doc gcrypt gpg lzo nls rsync threads xattr"
-
-REQUIRED_USE="?? ( dar32 dar64 )
- gpg? ( gcrypt )"
-
-RESTRICT="test" # need to be run as root
-
-RDEPEND="
- app-arch/bzip2:=
- app-arch/xz-utils:=
- sys-libs/libcap
- >=sys-libs/zlib-1.2.3:=
- argon2? ( app-crypt/argon2 )
- curl? ( net-misc/curl )
- gcrypt? ( dev-libs/libgcrypt:0= )
- gpg? ( app-crypt/gpgme )
- lzo? ( dev-libs/lzo:= )
- rsync? ( net-libs/librsync:= )
- threads? ( dev-libs/libthreadar:= )
- xattr? ( sys-apps/attr:= )
-"
-
-DEPEND="${RDEPEND}"
-
-BDEPEND="
- doc? ( app-doc/doxygen )
- nls? (
- sys-devel/gettext
- virtual/libintl
- )
-"
-
-DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
-
-src_configure() {
- # configure.ac is totally funked up regarding the AC_ARG_ENABLE
- # logic.
- # For example "--enable-dar-static" causes configure to DISABLE
- # static builds of dar.
- # Do _not_ use $(use_enable) until you have verified that the
- # logic has been fixed by upstream.
- local myconf=(
- --disable-dar-static
- --disable-python-binding
- --disable-static
- --disable-upx
- $(usex argon2 '' --disable-libargon2-linking)
- $(usex curl '' --disable-libcurl-linking)
- $(usex dar32 --enable-mode=32 '')
- $(usex dar64 --enable-mode=64 '')
- $(usex doc '' --disable-build-html)
- $(usex gcrypt '' --disable-libgcrypt-linking)
- $(usex gpg '' --disable-gpgme-linking)
- $(usex lzo '' --disable-liblzo2-linking)
- $(usex nls '' --disable-nls)
- $(usex rsync '' --disable-librsync-linking)
- $(usex threads '' --disable-threadar)
- $(usex xattr '' --disable-ea-support)
- )
-
- # Bug 103741
- filter-flags -fomit-frame-pointer
-
- econf "${myconf[@]}"
-}
-
-src_install() {
- emake DESTDIR="${D}" pkgdatadir="${EPREFIX}"/usr/share/doc/${PF}/html install
-
- einstalldocs
-
- find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
-
- # Bug 729150
- rm "${ED}/usr/share/doc/${PF}/html/samples/MyBackup.sh.tar.gz" || die
-}
diff --git a/app-backup/dar/dar-2.7.2.ebuild b/app-backup/dar/dar-2.7.14.ebuild
index 30d87e469279..88c8bb47d6cd 100644
--- a/app-backup/dar/dar-2.7.2.ebuild
+++ b/app-backup/dar/dar-2.7.14.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -7,15 +7,17 @@ inherit flag-o-matic
DESCRIPTION="A full featured backup tool, aimed for disks"
HOMEPAGE="http://dar.linux.free.fr/"
-SRC_URI="mirror://sourceforge/dar/${P}.tar.gz"
+SRC_URI="https://downloads.sourceforge.net/project/dar/dar/${PV}/${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux"
-IUSE="argon2 curl dar32 dar64 doc gcrypt gpg lz4 lzo nls rsync threads xattr"
+KEYWORDS="amd64 ppc sparc x86 ~amd64-linux"
+IUSE="argon2 curl dar32 dar64 doc gcrypt gpg lz4 lzo nls rsync xattr"
-REQUIRED_USE="?? ( dar32 dar64 )
- gpg? ( gcrypt )"
+REQUIRED_USE="
+ ?? ( dar32 dar64 )
+ gpg? ( gcrypt )
+"
RESTRICT="test" # need to be run as root
@@ -23,6 +25,7 @@ RDEPEND="
app-arch/bzip2:=
app-arch/xz-utils
app-arch/zstd:=
+ dev-libs/libthreadar
sys-libs/libcap
>=sys-libs/zlib-1.2.3:=
argon2? ( app-crypt/argon2:= )
@@ -31,22 +34,26 @@ RDEPEND="
dev-libs/libgcrypt:0=
dev-libs/libgpg-error
)
- gpg? ( app-crypt/gpgme:1= )
+ gpg? (
+ app-crypt/gpgme:=
+ dev-libs/libassuan
+ )
lz4? ( app-arch/lz4:= )
lzo? ( dev-libs/lzo:2 )
nls? ( virtual/libintl )
rsync? ( net-libs/librsync:= )
- threads? ( dev-libs/libthreadar )
xattr? ( sys-apps/attr )
"
DEPEND="${RDEPEND}"
BDEPEND="
- doc? ( app-doc/doxygen )
+ doc? ( app-text/doxygen )
nls? ( sys-devel/gettext )
"
+QA_PKGCONFIG_VERSION="" #862025 - upstream has a different numbering scheme for libdar
+
src_configure() {
# configure.ac is totally funked up regarding the AC_ARG_ENABLE
# logic.
@@ -69,7 +76,6 @@ src_configure() {
$(usev !lzo --disable-liblzo2-linking)
$(usev !nls --disable-nls)
$(usev !rsync --disable-librsync-linking)
- $(usev !threads --disable-threadar)
$(usev !xattr --disable-ea-support)
)
diff --git a/app-backup/dar/metadata.xml b/app-backup/dar/metadata.xml
index 16536c7e47e7..6cdca97c7d73 100644
--- a/app-backup/dar/metadata.xml
+++ b/app-backup/dar/metadata.xml
@@ -1,14 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person" proxied="yes">
- <email>ceamac.paragon@gmail.com</email>
+ <maintainer type="person">
+ <email>ceamac@gentoo.org</email>
<name>Viorel Munteanu</name>
</maintainer>
- <maintainer type="project" proxied="proxy">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
- </maintainer>
<longdescription>
Backup directory tree and files.
Full featured archiver with support for differential backups, slices,
@@ -27,5 +23,6 @@ operations, including with ssh.
</use>
<upstream>
<remote-id type="sourceforge">dar</remote-id>
+ <remote-id type="github">Edrusb/DAR</remote-id>
</upstream>
</pkgmetadata>