summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/duplicity')
-rw-r--r--app-backup/duplicity/Manifest5
-rw-r--r--app-backup/duplicity/duplicity-2.1.1.ebuild (renamed from app-backup/duplicity/duplicity-0.8.22.ebuild)14
-rw-r--r--app-backup/duplicity/duplicity-2.1.4.ebuild (renamed from app-backup/duplicity/duplicity-0.8.23-r1.ebuild)14
-rw-r--r--app-backup/duplicity/duplicity-2.2.3.ebuild51
-rw-r--r--app-backup/duplicity/files/duplicity-0.8.22-fix-docs-cmd.patch20
-rw-r--r--app-backup/duplicity/files/duplicity-0.8.23-fix-docs-cmd.patch20
-rw-r--r--app-backup/duplicity/files/duplicity-2.1.1-fix-docs-cmd.patch20
-rw-r--r--app-backup/duplicity/files/duplicity-2.1.4-fix-docs-cmd.patch23
-rw-r--r--app-backup/duplicity/files/duplicity-2.2.3-fix-docs-cmd.patch21
-rw-r--r--app-backup/duplicity/metadata.xml7
10 files changed, 135 insertions, 60 deletions
diff --git a/app-backup/duplicity/Manifest b/app-backup/duplicity/Manifest
index a81c6e41afa4..945214bd10d2 100644
--- a/app-backup/duplicity/Manifest
+++ b/app-backup/duplicity/Manifest
@@ -1,2 +1,3 @@
-DIST duplicity-0.8.22.tar.gz 1408482 BLAKE2B 3a8b6eb79d5f67e8f274bdaaaf0bb5b6c9f0ebf91a3b6a849b876cdf2c9af0f5435946150b5db6ab5e524cedc5b98b40c456b1de0fe8c6e33c024fe3c7d881fa SHA512 474237e3ca9876fb124baf9871f781b8347c85e76b7b4191d6993a76fb4728500091c74ed0943c6c22d69651c08094b6d155eca742d1711bebe676734c84d12a
-DIST duplicity-0.8.23.tar.gz 1385252 BLAKE2B 63042486e6e17d2d93af72f617990c879763d5921e230302f406b4f9e7c57a67284130f9f57849b9ffc8638614b55f0f8abdf6bb20201155b33b72bef952ec9f SHA512 083cf0060a8c7a8472c6ee4ffbb87e85edf0fcdaba95862a9f272cc03d8ab3d18b584a8d256473e6cfab9eed6f993382b846b692a8c0dd46fd3a2d8215e54e45
+DIST duplicity-2.1.1.tar.gz 1420132 BLAKE2B 35cfa7c6c2caa647f3b2046783185973203b5d838c0d1a1a8e24982f1c7f74a1d025e0b0740c0c7bc14d516c59d3e691a2712b19b30882e9dbb411cecb90f4be SHA512 fb19b1723e1e220ca72a41c3678ca29d889b2315c7fd043334d55cc2040d991e66480d71c6cc3f2ee5d17d9e1d9fb24ddc4c0ed771bbbefb6f1f6aa14cbe0347
+DIST duplicity-2.1.4.tar.gz 1556341 BLAKE2B d8302a7097519fd593fc05c8390101e615eaf11333e9d15e1ba7756b8ed9764709db80df41c741ee39eda0fa6de22c910b53db32d558c1ab09867c66724a056c SHA512 91804c6f4dc13d700cbe4747317f9611f530996de8a22a0907d714fb6f8a7fadc3371c270a2257c24324c0233bb4501a4b7d33aea7631862568c8530f7173ef1
+DIST duplicity-2.2.3.tar.gz 1978008 BLAKE2B 29a88eb059c3dd6faa7d08d52216cd0f9d96255eae1e613e2c5432bf8f36ad014484953e20b4a0dfaa2704dd6ac426a3285ff40a8cc82f287a8a89199df5a2c5 SHA512 b667092317899674c5e9d4b221815f24a7eae177d3d2b6d298f07d3e2d4a7badd6c976a6317331b7c6cea940a7885a3da397ab7197d5fd671d33278316f86916
diff --git a/app-backup/duplicity/duplicity-0.8.22.ebuild b/app-backup/duplicity/duplicity-2.1.1.ebuild
index 327ae4f973f4..5912d6e8f64c 100644
--- a/app-backup/duplicity/duplicity-0.8.22.ebuild
+++ b/app-backup/duplicity/duplicity-2.1.1.ebuild
@@ -1,14 +1,15 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_8 python3_9 python3_10 )
+PYTHON_COMPAT=( python3_10 python3_11 )
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_EXT=1
-inherit distutils-r1
+inherit distutils-r1 pypi
DESCRIPTION="Secure backup system using gnupg to encrypt data"
HOMEPAGE="https://duplicity.gitlab.io/"
-SRC_URI="https://code.launchpad.net/${PN}/$(ver_cut 1-2)-series/$(ver_cut 1-3)/+download/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
@@ -22,7 +23,7 @@ CDEPEND="
"
DEPEND="${CDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
test? (
app-arch/par2cmdline
dev-python/mock[${PYTHON_USEDEP}]
@@ -31,8 +32,7 @@ DEPEND="${CDEPEND}
"
RDEPEND="${CDEPEND}
dev-python/paramiko[${PYTHON_USEDEP}]
- dev-python/future[${PYTHON_USEDEP}]
- s3? ( dev-python/boto[${PYTHON_USEDEP}] )
+ s3? ( dev-python/boto3[${PYTHON_USEDEP}] )
"
RESTRICT="test"
diff --git a/app-backup/duplicity/duplicity-0.8.23-r1.ebuild b/app-backup/duplicity/duplicity-2.1.4.ebuild
index bf59fe56d88b..33edcac9bdf8 100644
--- a/app-backup/duplicity/duplicity-0.8.23-r1.ebuild
+++ b/app-backup/duplicity/duplicity-2.1.4.ebuild
@@ -1,18 +1,19 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_8 python3_9 python3_10 )
+PYTHON_COMPAT=( python3_10 python3_11 )
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_EXT=1
-inherit distutils-r1
+inherit distutils-r1 pypi
DESCRIPTION="Secure backup system using gnupg to encrypt data"
HOMEPAGE="https://duplicity.gitlab.io/"
-SRC_URI="https://code.launchpad.net/${PN}/$(ver_cut 1-2)-series/$(ver_cut 1-3)/+download/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~x64-macos"
IUSE="s3 test"
CDEPEND="
@@ -22,7 +23,7 @@ CDEPEND="
"
DEPEND="${CDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
test? (
app-arch/par2cmdline
dev-python/mock[${PYTHON_USEDEP}]
@@ -31,7 +32,6 @@ DEPEND="${CDEPEND}
"
RDEPEND="${CDEPEND}
dev-python/paramiko[${PYTHON_USEDEP}]
- dev-python/future[${PYTHON_USEDEP}]
s3? ( dev-python/boto3[${PYTHON_USEDEP}] )
"
diff --git a/app-backup/duplicity/duplicity-2.2.3.ebuild b/app-backup/duplicity/duplicity-2.2.3.ebuild
new file mode 100644
index 000000000000..76475155c786
--- /dev/null
+++ b/app-backup/duplicity/duplicity-2.2.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_10 python3_11 python3_12 )
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_EXT=1
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Secure backup system using gnupg to encrypt data"
+HOMEPAGE="https://duplicity.gitlab.io/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="s3 test"
+
+CDEPEND="
+ net-libs/librsync
+ app-crypt/gnupg
+ dev-python/fasteners[${PYTHON_USEDEP}]
+"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ app-arch/par2cmdline
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ s3? ( dev-python/boto3[${PYTHON_USEDEP}] )
+"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-docs-cmd.patch"
+)
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ elog "Duplicity has many optional dependencies to support various backends."
+ elog "Currently it's up to you to install them as necessary."
+}
diff --git a/app-backup/duplicity/files/duplicity-0.8.22-fix-docs-cmd.patch b/app-backup/duplicity/files/duplicity-0.8.22-fix-docs-cmd.patch
deleted file mode 100644
index 450c9f1d85d4..000000000000
--- a/app-backup/duplicity/files/duplicity-0.8.22-fix-docs-cmd.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- duplicity-0.8.22/setup.py 2022-03-19 15:08:36.755624771 -0400
-+++ duplicity-0.8.22/setup.py 2022-03-19 15:09:38.332763172 -0400
-@@ -94,17 +94,6 @@
- u'bin/rdiffdir.1'
- ]
- ),
-- (u'share/doc/duplicity-%s' % Version,
-- [
-- u'CHANGELOG.md',
-- u'CONTRIBUTING.md',
-- u'COPYING',
-- u'README.md',
-- u'README-LOG.md',
-- u'README-REPO.md',
-- u'README-TESTING.md',
-- ],
-- ),
- ]
-
- if not os.environ.get(u'READTHEDOCS') == u'True':
diff --git a/app-backup/duplicity/files/duplicity-0.8.23-fix-docs-cmd.patch b/app-backup/duplicity/files/duplicity-0.8.23-fix-docs-cmd.patch
deleted file mode 100644
index 2497beb25e01..000000000000
--- a/app-backup/duplicity/files/duplicity-0.8.23-fix-docs-cmd.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- duplicity-0.8.23/setup.py 2022-03-19 15:08:36.755624771 -0400
-+++ duplicity-0.8.23/setup.py 2022-03-19 15:09:38.332763172 -0400
-@@ -94,17 +94,6 @@
- u'bin/rdiffdir.1'
- ]
- ),
-- (u'share/doc/duplicity-%s' % Version,
-- [
-- u'CHANGELOG.md',
-- u'CONTRIBUTING.md',
-- u'COPYING',
-- u'README.md',
-- u'README-LOG.md',
-- u'README-REPO.md',
-- u'README-TESTING.md',
-- ],
-- ),
- ]
-
- if not os.environ.get(u'READTHEDOCS') == u'True':
diff --git a/app-backup/duplicity/files/duplicity-2.1.1-fix-docs-cmd.patch b/app-backup/duplicity/files/duplicity-2.1.1-fix-docs-cmd.patch
new file mode 100644
index 000000000000..bd8f96e6af79
--- /dev/null
+++ b/app-backup/duplicity/files/duplicity-2.1.1-fix-docs-cmd.patch
@@ -0,0 +1,20 @@
+--- duplicity-2.1.1/setup.py.orig 2023-09-14 08:33:42.698029208 -0400
++++ duplicity-2.1.1/setup.py 2023-09-14 08:34:18.730539149 -0400
+@@ -92,17 +92,6 @@
+ 'bin/duplicity.1',
+ ]
+ ),
+- (f'share/doc/duplicity-{Version}',
+- [
+- 'CHANGELOG.md',
+- 'CONTRIBUTING.md',
+- 'COPYING',
+- 'README.md',
+- 'README-LOG.md',
+- 'README-REPO.md',
+- 'README-TESTING.md',
+- ],
+- ),
+ ]
+
+ # short circuit fot READTHEDOCS
diff --git a/app-backup/duplicity/files/duplicity-2.1.4-fix-docs-cmd.patch b/app-backup/duplicity/files/duplicity-2.1.4-fix-docs-cmd.patch
new file mode 100644
index 000000000000..367f8e51c483
--- /dev/null
+++ b/app-backup/duplicity/files/duplicity-2.1.4-fix-docs-cmd.patch
@@ -0,0 +1,23 @@
+diff --git a/setup.py b/setup.py
+index 6711c8a1..2bc0bd95 100755
+--- a/setup.py
++++ b/setup.py
+@@ -108,18 +108,6 @@ def get_data_files():
+ "bin/duplicity.1",
+ ],
+ ),
+- (
+- f"share/doc/duplicity-{Version}",
+- [
+- "CHANGELOG.md",
+- "CONTRIBUTING.md",
+- "COPYING",
+- "README.md",
+- "README-LOG.md",
+- "README-REPO.md",
+- "README-TESTING.md",
+- ],
+- ),
+ ]
+
+ # short circuit fot READTHEDOCS
diff --git a/app-backup/duplicity/files/duplicity-2.2.3-fix-docs-cmd.patch b/app-backup/duplicity/files/duplicity-2.2.3-fix-docs-cmd.patch
new file mode 100644
index 000000000000..13e4d909f46a
--- /dev/null
+++ b/app-backup/duplicity/files/duplicity-2.2.3-fix-docs-cmd.patch
@@ -0,0 +1,21 @@
+--- a/setup.py 2024-03-29 07:04:27.847027200 -0400
++++ b/setup.py 2024-03-29 07:05:03.924506321 -0400
+@@ -93,18 +93,6 @@
+ "man/duplicity.1",
+ ],
+ ),
+- (
+- f"share/doc/duplicity-{Version}",
+- [
+- "CHANGELOG.md",
+- "AUTHORS.md",
+- "COPYING",
+- "README.md",
+- "README-LOG.md",
+- "README-REPO.md",
+- "README-TESTING.md",
+- ],
+- ),
+ ]
+
+ # short circuit fot READTHEDOCS
diff --git a/app-backup/duplicity/metadata.xml b/app-backup/duplicity/metadata.xml
index 9ec1a1b9dc7e..eb86afd49320 100644
--- a/app-backup/duplicity/metadata.xml
+++ b/app-backup/duplicity/metadata.xml
@@ -5,11 +5,10 @@
<email>rich0@gentoo.org</email>
<name>Rich Freeman</name>
</maintainer>
- <maintainer type="person" proxied="yes">
- <email>gentoo@seichter.de</email>
- <name>Ralph Seichter</name>
- </maintainer>
<use>
<flag name="s3">Support for backing up to the Amazon S3 system</flag>
</use>
+ <upstream>
+ <remote-id type="pypi">duplicity</remote-id>
+ </upstream>
</pkgmetadata>