summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/duplicity')
-rw-r--r--app-backup/duplicity/duplicity-0.8.09-r1.ebuild50
-rw-r--r--app-backup/duplicity/files/duplicity-0.8.09-fix-docs.patch15
2 files changed, 65 insertions, 0 deletions
diff --git a/app-backup/duplicity/duplicity-0.8.09-r1.ebuild b/app-backup/duplicity/duplicity-0.8.09-r1.ebuild
new file mode 100644
index 000000000000..f87d57f11a79
--- /dev/null
+++ b/app-backup/duplicity/duplicity-0.8.09-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_6)
+
+inherit distutils-r1
+
+DESCRIPTION="Secure backup system using gnupg to encrypt data"
+HOMEPAGE="http://www.nongnu.org/duplicity/"
+SRC_URI="https://code.launchpad.net/${PN}/$(ver_cut 1-2)-series/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="s3 test"
+
+CDEPEND="
+ net-libs/librsync
+ app-crypt/gnupg
+ dev-python/fasteners[${PYTHON_USEDEP}]
+"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ app-arch/par2cmdline
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+ s3? ( dev-python/boto[${PYTHON_USEDEP}] )
+"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-docs.patch"
+)
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ elog "Duplicity has many optional dependencies to support various backends."
+ elog "Currently it's up to you to install them as necessary."
+}
diff --git a/app-backup/duplicity/files/duplicity-0.8.09-fix-docs.patch b/app-backup/duplicity/files/duplicity-0.8.09-fix-docs.patch
new file mode 100644
index 000000000000..2141a359b896
--- /dev/null
+++ b/app-backup/duplicity/files/duplicity-0.8.09-fix-docs.patch
@@ -0,0 +1,15 @@
+--- duplicity-0.8.09/setup.py 2020-01-19 21:15:47.770168177 -0500
++++ duplicity-0.8.09/setup.py 2020-01-19 21:16:53.347709792 -0500
+@@ -51,12 +51,6 @@
+ data_files = [(u'share/man/man1',
+ [u'bin/duplicity.1',
+ u'bin/rdiffdir.1']),
+- (u'share/doc/duplicity-%s' % version_string,
+- [u'COPYING',
+- u'README',
+- u'README-REPO',
+- u'README-LOG',
+- u'CHANGELOG']),
+ ]
+
+ top_dir = os.path.dirname(os.path.abspath(__file__))