summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/duply/duply-2.3.1.ebuild')
-rw-r--r--app-backup/duply/duply-2.3.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-backup/duply/duply-2.3.1.ebuild b/app-backup/duply/duply-2.3.1.ebuild
new file mode 100644
index 000000000000..0fbf1c602199
--- /dev/null
+++ b/app-backup/duply/duply-2.3.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A shell frontend for duplicity"
+HOMEPAGE="https://duply.net"
+SRC_URI="https://jztkft.dl.sourceforge.net/project/ftplicity/${PN}%20%28simple%20duplicity%29/$(ver_cut 1-2).x/${PN}_${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+BDEPEND="app-text/txt2man"
+RDEPEND="app-backup/duplicity"
+
+S="${WORKDIR}/${PN}_${PV}"
+
+src_install() {
+ dobin ${PN}
+ ./${PN} txt2man > ${PN}.1 || die
+ doman ${PN}.1
+ dodoc CHANGELOG.txt
+}