summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/bonnie++/bonnie++-1.96.ebuild')
-rw-r--r--app-benchmarks/bonnie++/bonnie++-1.96.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-benchmarks/bonnie++/bonnie++-1.96.ebuild b/app-benchmarks/bonnie++/bonnie++-1.96.ebuild
new file mode 100644
index 000000000000..b0e81de23099
--- /dev/null
+++ b/app-benchmarks/bonnie++/bonnie++-1.96.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="Hard drive bottleneck testing benchmark suite"
+HOMEPAGE="http://www.coker.com.au/bonnie++/"
+SRC_URI="http://www.coker.com.au/bonnie++/experimental/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86"
+IUSE="debug"
+
+DEPEND=""
+RDEPEND=""
+
+src_compile() {
+ econf \
+ $(use_with debug) \
+ --disable-stripping \
+ || die
+ emake || die "emake failed"
+ emake zcav || die "emake zcav failed" # see #9073
+}
+
+src_install() {
+ dosbin bonnie++ zcav || die
+ dobin bon_csv2html bon_csv2txt || die
+ doman bon_csv2html.1 bon_csv2txt.1 bonnie++.8 zcav.8
+ dohtml readme.html
+ dodoc changelog.txt credits.txt
+}