summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/gtkperf/gtkperf-0.40-r1.ebuild')
-rw-r--r--app-benchmarks/gtkperf/gtkperf-0.40-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-benchmarks/gtkperf/gtkperf-0.40-r1.ebuild b/app-benchmarks/gtkperf/gtkperf-0.40-r1.ebuild
new file mode 100644
index 000000000000..c8b402b2e259
--- /dev/null
+++ b/app-benchmarks/gtkperf/gtkperf-0.40-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+MY_P="${PN}_${PV}"
+DESCRIPTION="Application designed to test GTK+ performance"
+HOMEPAGE="http://gtkperf.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ default
+
+ make_desktop_entry ${PN} ${PN} duck
+
+ rm -rf "${D}/usr/doc" || die
+ dodoc AUTHORS ChangeLog README TODO
+}