summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/ioping')
-rw-r--r--app-benchmarks/ioping/Manifest4
-rw-r--r--app-benchmarks/ioping/files/ioping-0.9-sysmacros.patch29
-rw-r--r--app-benchmarks/ioping/ioping-0.9.ebuild39
-rw-r--r--app-benchmarks/ioping/ioping-1.0.ebuild33
-rw-r--r--app-benchmarks/ioping/ioping-1.2.ebuild24
-rw-r--r--app-benchmarks/ioping/ioping-1.3.ebuild24
-rw-r--r--app-benchmarks/ioping/metadata.xml2
7 files changed, 51 insertions, 104 deletions
diff --git a/app-benchmarks/ioping/Manifest b/app-benchmarks/ioping/Manifest
index 5cddcbf192e9..3e64362c4df6 100644
--- a/app-benchmarks/ioping/Manifest
+++ b/app-benchmarks/ioping/Manifest
@@ -1,3 +1,3 @@
-DIST ioping-0.9.tar.gz 23695 BLAKE2B 41b37ad8dabd2c2e16f26798d878807c38e0d03bc4964a001f8800d0f398ba48335b1187e1f04cd235a980c5dce7e864c471fce8d46ca24a65f2022847eb8ebd SHA512 609e19c31a16a5961be0e468255f2853311162ad988d07404a8198042bec1e20cab37e192ad148536a0772efe8034a94d594671ec6fde7d37badee859796de1c
-DIST ioping-1.0.tar.gz 28824 BLAKE2B bb0f28e560419167450b27846650ff131c9cbb23c5df7f518afa8cea6a83bd97142d7ad8920b9ec86754deea0dcbf36af923223c78df6488f3623f2df852b59c SHA512 a6763ac800e98c819a74af80634ac723f413ffa183297918389e1e1f5fc83713b683d53b594f5bd20f11d168c21de5da9d42a215d78531ee8b619aff8b9b0b84
DIST ioping-1.1.tar.gz 29251 BLAKE2B 2f0ec642c3545b8e603f90187f48bf44e1ef665a99bc04af4d5e6441016c9509875e8e05c1cc8715fd080c8a498c7374cf5db562a3203d7075edbe85683ccdbb SHA512 67802a6ab552ad1fdb8894f4d814601c2f66154f4bfc50fa0001d881694864c1a70882b4ba2d0f50cbd484472dc649a22b312f802a3bacc3317671971bdc0201
+DIST ioping-1.2.tar.gz 30819 BLAKE2B 5f46ee783d51e4bea88a6036fba97c053e507f53183344d17fbfa6dd304d6cb76737ccff23c46ccce1fff8107d94e4e192264a3bf22062a7ea96b2a4475fb311 SHA512 4029f1b50dc292734088dc741e594c56021610aad16a0b9f42875b5fe91fbdf8d566a41dab0384aa739350f74e62688efdaf88168ab0d838b9c848ddd1c5dd96
+DIST ioping-1.3.tar.gz 33507 BLAKE2B 91d5eb2337aa4d403f9b335a2212ae3eec5c8786f382abec5bce852f5fd79cb0e0f25d83856cb42b1598032d10630b49bf1905eaa04856b5438e9e1e494c0c7d SHA512 52ca9596d0d54a02e58e40b777d31b44a3f10fd45b76d25ab491f7e6d126dfb9c4205c9b427b69bdc2012282ec8c5846db964d420913f4d91fa5101baa99089d
diff --git a/app-benchmarks/ioping/files/ioping-0.9-sysmacros.patch b/app-benchmarks/ioping/files/ioping-0.9-sysmacros.patch
deleted file mode 100644
index 837d395201b7..000000000000
--- a/app-benchmarks/ioping/files/ioping-0.9-sysmacros.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-https://bugs.gentoo.org/579982
-
-From c56a8a442e79a8837074e0e573f6319efa492ba8 Mon Sep 17 00:00:00 2001
-From: Mike Frysinger <vapier@gentoo.org>
-Date: Tue, 19 Apr 2016 02:44:33 -0400
-Subject: [PATCH] ioping: include sys/sysmacros.h for makedev
-
-The makedev prototype is in sys/sysmacros.h, so include it.
-
-Signed-off-by: Mike Frysinger <vapier@gentoo.org>
----
- ioping.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/ioping.c b/ioping.c
-index aae4704..80f4bb4 100644
---- a/ioping.c
-+++ b/ioping.c
-@@ -48,6 +48,7 @@
- #ifdef __linux__
- # include <sys/ioctl.h>
- # include <sys/mount.h>
-+# include <sys/sysmacros.h>
- # define HAVE_POSIX_FADVICE
- # define HAVE_POSIX_MEMALIGN
- # define HAVE_DIRECT_IO
---
-2.7.4
-
diff --git a/app-benchmarks/ioping/ioping-0.9.ebuild b/app-benchmarks/ioping/ioping-0.9.ebuild
deleted file mode 100644
index 29eae974e711..000000000000
--- a/app-benchmarks/ioping/ioping-0.9.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Simple disk I/0 latency measuring tool"
-HOMEPAGE="https://github.com/koct9i/ioping"
-SRC_URI="https://github.com/koct9i/ioping/releases/download/v${PV}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-3"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-PATCHES=( "${FILESDIR}"/${P}-sysmacros.patch )
-
-src_prepare() {
- default
- sed \
- -e 's: -g : :g' \
- -e 's: $(LDFLAGS) : :g' \
- -e 's: -o : $(LDFLAGS) -o :g' \
- -e 's:-s -m:-m:g' \
- -e 's:LICENSE::g' \
- -e 's:-O2.*::g' \
- -i Makefile || die
-}
-
-src_compile() {
- emake \
- CC="$(tc-getCC)" \
- PREFIX="${EPREFIX}/usr"
-}
-
-src_install() {
- emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
-}
diff --git a/app-benchmarks/ioping/ioping-1.0.ebuild b/app-benchmarks/ioping/ioping-1.0.ebuild
deleted file mode 100644
index 3a9d7324601c..000000000000
--- a/app-benchmarks/ioping/ioping-1.0.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Simple disk I/0 latency measuring tool"
-HOMEPAGE="https://github.com/koct9i/ioping"
-SRC_URI="https://github.com/koct9i/ioping/archive/v1.0.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-3"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-src_prepare() {
- default
- sed \
- -e 's:LICENSE::g' \
- -i Makefile || die
-}
-
-src_compile() {
- emake \
- CFLAGS="${CFLAGS}" \
- CC="$(tc-getCC)" \
- PREFIX="${EPREFIX}/usr"
-}
-
-src_install() {
- emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
-}
diff --git a/app-benchmarks/ioping/ioping-1.2.ebuild b/app-benchmarks/ioping/ioping-1.2.ebuild
new file mode 100644
index 000000000000..4be915c0f72e
--- /dev/null
+++ b/app-benchmarks/ioping/ioping-1.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simple disk I/0 latency measuring tool"
+HOMEPAGE="https://github.com/koct9i/ioping"
+SRC_URI="https://github.com/koct9i/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+
+ dodoc changelog README.md
+}
diff --git a/app-benchmarks/ioping/ioping-1.3.ebuild b/app-benchmarks/ioping/ioping-1.3.ebuild
new file mode 100644
index 000000000000..d466ce4f1b5c
--- /dev/null
+++ b/app-benchmarks/ioping/ioping-1.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simple disk I/0 latency measuring tool"
+HOMEPAGE="https://github.com/koct9i/ioping"
+SRC_URI="https://github.com/koct9i/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+
+ dodoc changelog README.md
+}
diff --git a/app-benchmarks/ioping/metadata.xml b/app-benchmarks/ioping/metadata.xml
index 55ad5be23a2b..25d98b1f3af9 100644
--- a/app-benchmarks/ioping/metadata.xml
+++ b/app-benchmarks/ioping/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>shell-tools@gentoo.org</email>