summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/pipebench')
-rw-r--r--app-benchmarks/pipebench/files/pipebench-0.40-fix-build-clang16.patch12
-rw-r--r--app-benchmarks/pipebench/metadata.xml2
-rw-r--r--app-benchmarks/pipebench/pipebench-0.40-r2.ebuild11
-rw-r--r--app-benchmarks/pipebench/pipebench-0.40-r3.ebuild24
4 files changed, 42 insertions, 7 deletions
diff --git a/app-benchmarks/pipebench/files/pipebench-0.40-fix-build-clang16.patch b/app-benchmarks/pipebench/files/pipebench-0.40-fix-build-clang16.patch
new file mode 100644
index 000000000000..1cc891bd7f08
--- /dev/null
+++ b/app-benchmarks/pipebench/files/pipebench-0.40-fix-build-clang16.patch
@@ -0,0 +1,12 @@
+Bug: https://bugs.gentoo.org/894336
+--- a/pipebench.c
++++ b/pipebench.c
+@@ -28,6 +28,8 @@
+ */
+ #include <stdio.h>
+ #include <unistd.h>
++#include <stdlib.h>
++#include <string.h>
+ #include <time.h>
+ #include <signal.h>
+ #include <sys/time.h>
diff --git a/app-benchmarks/pipebench/metadata.xml b/app-benchmarks/pipebench/metadata.xml
index 6f49eba8f496..85e4ed814fa2 100644
--- a/app-benchmarks/pipebench/metadata.xml
+++ b/app-benchmarks/pipebench/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!-- maintainer-needed -->
</pkgmetadata>
diff --git a/app-benchmarks/pipebench/pipebench-0.40-r2.ebuild b/app-benchmarks/pipebench/pipebench-0.40-r2.ebuild
index 6058d8d81f6a..6d15d1fa612f 100644
--- a/app-benchmarks/pipebench/pipebench-0.40-r2.ebuild
+++ b/app-benchmarks/pipebench/pipebench-0.40-r2.ebuild
@@ -1,18 +1,17 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit flag-o-matic toolchain-funcs
DESCRIPTION="Measures the speed of stdin/stdout communication"
-HOMEPAGE="http://www.habets.pp.se/synscan/programs.php?prog=pipebench"
-SRC_URI="ftp://ftp.habets.pp.se/pub/synscan/${P}.tar.gz"
+HOMEPAGE="https://www.habets.pp.se/synscan/programs_pipebench.html"
+SRC_URI="https://www.habets.pp.se/synscan/files/${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~alpha amd64 ppc ppc64 x86 ~x86-linux"
-IUSE=""
PATCHES=( "${FILESDIR}"/${PN}-0.40-fix-build-system.patch )
diff --git a/app-benchmarks/pipebench/pipebench-0.40-r3.ebuild b/app-benchmarks/pipebench/pipebench-0.40-r3.ebuild
new file mode 100644
index 000000000000..d4538c458b53
--- /dev/null
+++ b/app-benchmarks/pipebench/pipebench-0.40-r3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Measures the speed of stdin/stdout communication"
+HOMEPAGE="https://www.habets.pp.se/synscan/programs_pipebench.html"
+SRC_URI="https://www.habets.pp.se/synscan/files/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ppc ppc64 x86 ~x86-linux"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.40-fix-build-system.patch
+ "${FILESDIR}"/${PN}-0.40-fix-build-clang16.patch
+)
+
+src_configure() {
+ append-cflags -Wall -w -pedantic
+ tc-export CC
+}