summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/siege')
-rw-r--r--app-benchmarks/siege/Manifest1
-rw-r--r--app-benchmarks/siege/files/siege-4.1.6-clang16-build-fix.patch32
-rw-r--r--app-benchmarks/siege/siege-4.1.6-r1.ebuild55
-rw-r--r--app-benchmarks/siege/siege-4.1.6.ebuild51
4 files changed, 139 insertions, 0 deletions
diff --git a/app-benchmarks/siege/Manifest b/app-benchmarks/siege/Manifest
index 6f17afa96ce7..56038a7c6472 100644
--- a/app-benchmarks/siege/Manifest
+++ b/app-benchmarks/siege/Manifest
@@ -1 +1,2 @@
DIST siege-4.1.0.tar.gz 541331 BLAKE2B c3e8e0f101e27a0902de80478e7c6595f44b4d129cfb265d66c48fcacef4129f587f9ca9ddd0c4d5016513ba19d7635135add1cb02290c4d2bbed5cea501a816 SHA512 15b3b82877153f044524cedc96750a6dab4d21ccbef1be53c0069adade6c3b4204287852a30a57275eea0f51c702857dff59648bd885c28ce65feae141cf6593
+DIST siege-4.1.6.tar.gz 527103 BLAKE2B aea71c93d0243113f8d9087ab4ea02ad1c64e10d8a10918139473ba865230a8e945d5371f19234bce22c95f8a412f68e94792ea0ea00eb451f208a17a37467f4 SHA512 cc674c9dc33aac35988708cd73b5061343cb1939e8a10b4dc50ceab42e65647b58557b6f3b48a03f5c992109bcac233425bf363e1f899135cfd9333d2517cfb2
diff --git a/app-benchmarks/siege/files/siege-4.1.6-clang16-build-fix.patch b/app-benchmarks/siege/files/siege-4.1.6-clang16-build-fix.patch
new file mode 100644
index 000000000000..1d36fdfd22d8
--- /dev/null
+++ b/app-benchmarks/siege/files/siege-4.1.6-clang16-build-fix.patch
@@ -0,0 +1,32 @@
+Bug: https://bugs.gentoo.org/894338
+--- a/src/cookies.c
++++ b/src/cookies.c
+@@ -66,7 +66,7 @@ cookies_destroy(COOKIES this)
+ BOOLEAN
+ cookies_add(COOKIES this, char *str, char *host)
+ {
+- size_t id = pthread_self();
++ size_t id = (size_t) pthread_self();
+ //int hlen = 0;
+ //int dlen = 0;
+ NODE *cur = NULL;
+@@ -169,7 +169,7 @@ cookies_header(COOKIES this, char *host, char *newton)
+ time_t now;
+ struct tm tm;
+ char oreo[MAX_COOKIES_SIZE];
+- size_t id = pthread_self();
++ size_t id = (size_t) pthread_self();
+
+ memset(oreo, '\0', sizeof oreo);
+
+--- a/src/ftp.c
++++ b/src/ftp.c
+@@ -151,7 +151,7 @@ ftp_stor(CONN *C, URL U)
+ {
+ size_t len;
+ char *file;
+- size_t id = pthread_self();
++ size_t id = (size_t) pthread_self();
+ int num = 2;
+ char **parts;
+
diff --git a/app-benchmarks/siege/siege-4.1.6-r1.ebuild b/app-benchmarks/siege/siege-4.1.6-r1.ebuild
new file mode 100644
index 000000000000..41bb48b2bedf
--- /dev/null
+++ b/app-benchmarks/siege/siege-4.1.6-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools bash-completion-r1
+
+DESCRIPTION="A HTTP regression testing and benchmarking utility"
+HOMEPAGE="https://www.joedog.org/siege-home https://github.com/JoeDog/siege"
+SRC_URI="http://download.joedog.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ~mips ppc x86 ~x64-macos"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND="
+ sys-libs/zlib
+ ssl? ( dev-libs/openssl:0= )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.1.6-clang16-build-fix.patch
+)
+
+src_prepare() {
+ default
+ # bundled macros break recent libtool
+ # remove /usr/lib from LDFLAGS, bug #732886
+ sed -i \
+ -e '/AC_PROG_SHELL/d' \
+ -e 's/SSL_LDFLAGS="-L.*lib"/SSL_LDFLAGS=""/g' \
+ -e 's/Z_LDFLAGS="-L.*lib"/Z_LDFLAGS=""/g' \
+ configure.ac || die "Failed to sed configure.ac"
+ rm *.m4 || die "failed to remove bundled macros"
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=( $(use_with ssl ssl "${EPREFIX}/usr") )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ dodoc AUTHORS ChangeLog INSTALL README* doc/siegerc doc/urls.txt
+
+ newbashcomp "${FILESDIR}/${PN}".bash-completion "${PN}"
+}
+
+pkg_postinst() {
+ elog "An example ~/.siegerc file has been installed in"
+ elog "${EPREFIX}/usr/share/doc/${PF}/"
+}
diff --git a/app-benchmarks/siege/siege-4.1.6.ebuild b/app-benchmarks/siege/siege-4.1.6.ebuild
new file mode 100644
index 000000000000..3afa0f47ca99
--- /dev/null
+++ b/app-benchmarks/siege/siege-4.1.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools bash-completion-r1
+
+DESCRIPTION="A HTTP regression testing and benchmarking utility"
+HOMEPAGE="https://www.joedog.org/siege-home https://github.com/JoeDog/siege"
+SRC_URI="http://download.joedog.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ~mips ppc x86 ~x64-macos"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND="
+ sys-libs/zlib
+ ssl? ( dev-libs/openssl:0= )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ # bundled macros break recent libtool
+ # remove /usr/lib from LDFLAGS, bug #732886
+ sed -i \
+ -e '/AC_PROG_SHELL/d' \
+ -e 's/SSL_LDFLAGS="-L.*lib"/SSL_LDFLAGS=""/g' \
+ -e 's/Z_LDFLAGS="-L.*lib"/Z_LDFLAGS=""/g' \
+ configure.ac || die "Failed to sed configure.ac"
+ rm *.m4 || die "failed to remove bundled macros"
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=( $(use_with ssl ssl "${EPREFIX}/usr") )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ dodoc AUTHORS ChangeLog INSTALL README* doc/siegerc doc/urls.txt
+
+ newbashcomp "${FILESDIR}/${PN}".bash-completion "${PN}"
+}
+
+pkg_postinst() {
+ elog "An example ~/.siegerc file has been installed in"
+ elog "${EPREFIX}/usr/share/doc/${PF}/"
+}