summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/stress/stress-1.0.7.ebuild')
-rw-r--r--app-benchmarks/stress/stress-1.0.7.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-benchmarks/stress/stress-1.0.7.ebuild b/app-benchmarks/stress/stress-1.0.7.ebuild
new file mode 100644
index 000000000000..59d1d63cc898
--- /dev/null
+++ b/app-benchmarks/stress/stress-1.0.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A deliberately simple workload generator for POSIX systems"
+HOMEPAGE="https://salsa.debian.org/debian/stress"
+SRC_URI="mirror://debian/pool/main/s/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv sparc x86"
+IUSE="static"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable static)
+ )
+
+ econf "${myeconfargs[@]}"
+}