summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/wrk/files')
-rw-r--r--app-benchmarks/wrk/files/wrk-4.2.0-makefile.patch (renamed from app-benchmarks/wrk/files/wrk-4.1.0-r100-makefile.patch)16
1 files changed, 3 insertions, 13 deletions
diff --git a/app-benchmarks/wrk/files/wrk-4.1.0-r100-makefile.patch b/app-benchmarks/wrk/files/wrk-4.2.0-makefile.patch
index d3c838d08003..b5a32ae9b5eb 100644
--- a/app-benchmarks/wrk/files/wrk-4.1.0-r100-makefile.patch
+++ b/app-benchmarks/wrk/files/wrk-4.2.0-makefile.patch
@@ -1,13 +1,11 @@
--- a/Makefile
+++ b/Makefile
-@@ -1,5 +1,5 @@
+@@ -1,4 +1,4 @@
-CFLAGS += -std=c99 -Wall -O2 -D_REENTRANT
--LIBS := -lpthread -lm -lssl -lcrypto
+CFLAGS += -std=c99 -Wall -D_REENTRANT
-+LIBS := -lm -lssl -lcrypto -lpthread
+ LIBS := -lm -lssl -lcrypto -lpthread
TARGET := $(shell uname -s | tr '[A-Z]' '[a-z]' 2>/dev/null || echo unknown)
-
@@ -24,15 +24,13 @@
ODIR := obj
@@ -34,7 +32,7 @@
else
DEPS += $(ODIR)/lib/libssl.a
endif
-@@ -51,15 +48,14 @@
+@@ -51,8 +48,7 @@
$(RM) -rf $(BIN) obj/*
$(BIN): $(OBJ)
@@ -44,14 +42,6 @@
$(OBJ): config.h Makefile $(DEPS) | $(ODIR)
- $(ODIR):
- @mkdir -p $@
-
--$(ODIR)/bytecode.o: src/wrk.lua
-+$(ODIR)/bytecode.c: src/wrk.lua
- @echo LUAJIT $<
- @$(SHELL) -c 'PATH=obj/bin:$(PATH) luajit -b $(CURDIR)/$< $(CURDIR)/$@'
-
@@ -67,8 +63,7 @@
@echo 'const char *VERSION="$(VER)";' | $(CC) -xc -c -o $@ -