summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr/cdck')
-rw-r--r--app-cdr/cdck/cdck-0.7.0-r3.ebuild (renamed from app-cdr/cdck/cdck-0.7.0-r2.ebuild)26
-rw-r--r--app-cdr/cdck/files/cdck-0.7.0-automake.patch42
-rw-r--r--app-cdr/cdck/files/cdck-0.7.0-cross.patch20
-rw-r--r--app-cdr/cdck/files/cdck-0.7.0-gcc-10.patch18
-rw-r--r--app-cdr/cdck/files/cdck-0.7.0-man.patch50
-rw-r--r--app-cdr/cdck/files/cdck-0.7.0-wording.patch25
-rw-r--r--app-cdr/cdck/metadata.xml2
7 files changed, 170 insertions, 13 deletions
diff --git a/app-cdr/cdck/cdck-0.7.0-r2.ebuild b/app-cdr/cdck/cdck-0.7.0-r3.ebuild
index cfbbfbbd6480..ca0805885897 100644
--- a/app-cdr/cdck/cdck-0.7.0-r2.ebuild
+++ b/app-cdr/cdck/cdck-0.7.0-r3.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
+inherit autotools
DESCRIPTION="Measure the read time per sector on CD or DVD to check the quality"
HOMEPAGE="http://swaj.net/unix/index.html#cdck"
@@ -10,21 +12,21 @@ SRC_URI="http://swaj.net/unix/cdck/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+
+PATCHES=(
+ "${FILESDIR}"/${P}-man.patch
+ "${FILESDIR}"/${P}-wording.patch
+ "${FILESDIR}"/${P}-automake.patch
+ "${FILESDIR}"/${P}-cross.patch
+ "${FILESDIR}"/${P}-gcc-10.patch
+)
src_prepare() {
default
-
- sed -e '1d' -i man/cdck_man.in || die "sed failed"
-}
-
-src_configure() {
- econf --disable-shared
+ eautoreconf
}
src_install() {
default
-
- dobin src/cdck
- doman man/cdck.1
+ find "${ED}" -type f -name '*.la' -delete || die
}
diff --git a/app-cdr/cdck/files/cdck-0.7.0-automake.patch b/app-cdr/cdck/files/cdck-0.7.0-automake.patch
new file mode 100644
index 000000000000..629b48d8b4a4
--- /dev/null
+++ b/app-cdr/cdck/files/cdck-0.7.0-automake.patch
@@ -0,0 +1,42 @@
+Description: allow libtool to auto(re)conf
+Origin: vendor
+Forwarded: no
+Author: tony mancill <tmancill@debian.org>
+Last-Update: 2015-03-04
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -16,7 +16,6 @@
+
+ AC_SYS_LARGEFILE
+
+-AC_DISABLE_SHARED
+ AM_PROG_LIBTOOL
+ AC_SUBST(LIBTOOL_DEPS)
+
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -10,12 +10,12 @@ CLEANFILES = *~ *.o *.la *.lo *.a
+ EXTRA_DIST = config.h cdck template.plot template-ps.plot
+
+ INCLUDES = @CPPFLAGS@
+-CFLAGS = @CFLAGS@ -DBUILD=\"@target@\" -DDATE=\""`date`"\"
++AM_CFLAGS = @CFLAGS@ -DBUILD=\"@target@\" -DDATE=\""`date`"\"
+
+ CXXLINK = $(LIBTOOL) --mode=link $(CC) $(AM_CXXFLAGS) $(CXXFLAGS) $(AM_LDFLAGS) $(LDFLAGS) -o $@
+
+ lib_LTLIBRARIES = libcdck.la
+-noinst_LIBRARIES = libcdck.a
++#noinst_LIBRARIES = libcdck.a
+
+ LIBCDCK_SRCS = \
+ lib_main.cpp \
+@@ -28,7 +28,7 @@ LIBCDCK_SRCS = \
+ lib_cdinfo.h
+
+ libcdck_la_SOURCES = $(LIBCDCK_SRCS)
+-libcdck_a_SOURCES = $(LIBCDCK_SRCS)
++#libcdck_a_SOURCES = $(LIBCDCK_SRCS)
+
+ bin_PROGRAMS = cdck
+
diff --git a/app-cdr/cdck/files/cdck-0.7.0-cross.patch b/app-cdr/cdck/files/cdck-0.7.0-cross.patch
new file mode 100644
index 000000000000..dae65e604898
--- /dev/null
+++ b/app-cdr/cdck/files/cdck-0.7.0-cross.patch
@@ -0,0 +1,20 @@
+Description: replace hard-coded `gcc' with $CC in configure.ac
+ to allow cross-building.
+Origin: vendor
+Bug-Debian: https://bugs.debian.org/901177
+Forwarded: not-yet
+Author: Helmut Grohne <helmut@subdivi.de>
+Reviewed-by: gregor herrmann <gregoa@debian.org>
+Last-Update: 2018-06-09
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -96,7 +96,7 @@
+ CXXFLAGS="$CXXFLAGS -Wall -Wwrite-strings -Woverloaded-virtual -fno-exceptions -fno-rtti -export-dynamic "
+ fi
+
+-SUPCXX=`gcc -print-file-name=libsupc++.a`
++SUPCXX=`$CC -print-file-name=libsupc++.a`
+
+ LIBS="$SUPCXX $LIBS"
+
diff --git a/app-cdr/cdck/files/cdck-0.7.0-gcc-10.patch b/app-cdr/cdck/files/cdck-0.7.0-gcc-10.patch
new file mode 100644
index 000000000000..145503096b0b
--- /dev/null
+++ b/app-cdr/cdck/files/cdck-0.7.0-gcc-10.patch
@@ -0,0 +1,18 @@
+Description: Fix detection of gcc version.
+ Use numeric instead of string comparison, then gcc version 10 is greater then 3.
+Origin: vendor
+Bug-Debian: https://bugs.debian.org/957073
+Author: gregor herrmann <gregoa@debian.org>
+Last-Update: 2020-04-17
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -50,7 +50,7 @@
+ echo $_echo_n "checking version of ${CC} ... $_echo_c"
+ exec 15> ./.gcc.test
+ cat >&15 <<EOF
+-${CC} -v 2>&1 | perl -e '\$/=undef;\$_=<STDIN>;s/.*ver.+?([[0-9\.]]+).*//s;\$_=\$1;print; s/\.//sg;s/^.*?(\d{0,4}).*\$/\$1/; exit 0 if (\$_ gt 300); exit -1'
++${CC} -v 2>&1 | perl -e '\$/=undef;\$_=<STDIN>;s/.*ver.+?([[0-9\.]]+).*//s;\$_=\$1;print; s/\.//sg;s/^.*?(\d{0,4}).*\$/\$1/; exit 0 if (\$_ >= 300); exit -1'
+ EOF
+ sh ./.gcc.test 2>/dev/null
+ if test $? -ne 0 ; then
diff --git a/app-cdr/cdck/files/cdck-0.7.0-man.patch b/app-cdr/cdck/files/cdck-0.7.0-man.patch
new file mode 100644
index 000000000000..664b5e77872d
--- /dev/null
+++ b/app-cdr/cdck/files/cdck-0.7.0-man.patch
@@ -0,0 +1,50 @@
+Author: gregor herrmann <gregoa@debian.org>
+Last-Update: 2015-03-04
+Description:
+ - fix calls to pod2man
+ - remove stray "=cut", leads to pod2man errors
+ - add a note about using the gnuplot datafile
+Bugs-Ubuntu: https://bugs.launchpad.net/bugs/476591
+
+--- a/man/Makefile.am
++++ b/man/Makefile.am
+@@ -11,7 +11,7 @@
+ EXTRA_DIST = cdck_man.in
+
+ cdck.1:
+- pod2man --section=cdck.1 --verbose cdck_man.in > cdck.1
++ pod2man --section=1 --verbose --name=cdck cdck_man.in > cdck.1
+
+
+ #
+--- a/man/cdck_man.in
++++ b/man/cdck_man.in
+@@ -1,5 +1,3 @@
+-=cut
+-
+ =head1 NAME
+
+ cdck - simple CD/DVD check program
+@@ -17,6 +15,8 @@
+ -i Print CD/DVD information and quit, perform no timings (default mode)
+
+ -t Perform timing test
++
++ Note: this option will not work for audio CDs.
+
+ -p Save data for gnuplot(1) program
+
+@@ -26,7 +26,11 @@
+
+ -v Verbose operations
+
++ To actually plot your data you have to start gnuplot and plot the datafile:
++ $ gnuplot
++ gnuplot> plot "cdck-plot.dat"
++
+ =head1 COPYRIGHT
+
+- This manpage was written by gregor herrmann <gregor+debian@comodo.priv.at> for the
+- Debian project but may be used by others.
++ This manpage was written by gregor herrmann <gregoa@debian.org>
++ for the Debian project, but may be used by others.
diff --git a/app-cdr/cdck/files/cdck-0.7.0-wording.patch b/app-cdr/cdck/files/cdck-0.7.0-wording.patch
new file mode 100644
index 000000000000..74e91c1f6bb6
--- /dev/null
+++ b/app-cdr/cdck/files/cdck-0.7.0-wording.patch
@@ -0,0 +1,25 @@
+Description: improve wording
+Author: DenverD
+Reviewed-by: gregor herrmann <gregoa@debian.org>
+Last-Update: 2010-05-25
+
+--- a/src/lib_main.cpp
++++ b/src/lib_main.cpp
+@@ -566,7 +566,7 @@
+ fprintf (stdout, "\nConclusion:\n");
+
+ if (bad_sectors > 0) {
+- fprintf (stdout, " Disc contains BAD or even readable sectors, put it into trash can!\n");
++ fprintf (stdout, " Disc contains BAD or even unreadable sectors, put it into trash can!\n");
+ return;
+ }
+
+@@ -580,7 +580,7 @@
+ return;
+ }
+
+- fprintf (stdout, " Even there is no unreadable sectors, disc is unstable!\n");
++ fprintf (stdout, " Even though there are no unreadable sectors, disc is unstable!\n");
+ }
+
+ void Ccdrom::DeallocateTimings()
diff --git a/app-cdr/cdck/metadata.xml b/app-cdr/cdck/metadata.xml
index e09e5268ee34..6521a840a02e 100644
--- a/app-cdr/cdck/metadata.xml
+++ b/app-cdr/cdck/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!-- maintainer-needed -->
<longdescription>