summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr/cdemu/cdemu-3.2.5.ebuild')
-rw-r--r--app-cdr/cdemu/cdemu-3.2.5.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/app-cdr/cdemu/cdemu-3.2.5.ebuild b/app-cdr/cdemu/cdemu-3.2.5.ebuild
index 35a46b90f6ed..ae8d6c535a29 100644
--- a/app-cdr/cdemu/cdemu-3.2.5.ebuild
+++ b/app-cdr/cdemu/cdemu-3.2.5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit bash-completion-r1 cmake python-single-r1 xdg-utils
@@ -19,16 +19,20 @@ KEYWORDS="amd64 x86"
IUSE="+cdemu-daemon"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND="${PYTHON_DEPS}
+RDEPEND="
+ ${PYTHON_DEPS}
$(python_gen_cond_dep '
- dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
')
- cdemu-daemon? ( app-cdr/cdemu-daemon:0/7 )"
-BDEPEND="${PYTHON_DEPS}
+ cdemu-daemon? ( app-cdr/cdemu-daemon:0/7 )
+"
+BDEPEND="
+ ${PYTHON_DEPS}
dev-util/desktop-file-utils
>=dev-util/intltool-0.21
>=sys-devel/gettext-0.18
- virtual/pkgconfig"
+ virtual/pkgconfig
+"
DOCS=( AUTHORS README )