summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr/cdemu')
-rw-r--r--app-cdr/cdemu/Manifest1
-rw-r--r--app-cdr/cdemu/cdemu-3.2.5-r1.ebuild (renamed from app-cdr/cdemu/cdemu-3.2.4.ebuild)30
-rw-r--r--app-cdr/cdemu/cdemu-3.2.5.ebuild16
3 files changed, 30 insertions, 17 deletions
diff --git a/app-cdr/cdemu/Manifest b/app-cdr/cdemu/Manifest
index ee5e3c48a6c8..65c46fc743c5 100644
--- a/app-cdr/cdemu/Manifest
+++ b/app-cdr/cdemu/Manifest
@@ -1,2 +1 @@
-DIST cdemu-client-3.2.4.tar.bz2 44284 BLAKE2B c57fe09bef7112933a93fac9944eaff957e01692ec1ddec7fd443aa780f8b3d85d0bd640611337d896843de3ab00d09e093c293776a52afa85f781bdde7f4250 SHA512 2e10cb345e261ddaa6da68ee626770ed65749b1ea64c2bbbf0f3a2e96184c2906834886754e87e3161c3056473e5ee0dc20672ce7cb48232e6bef1c93cb80550
DIST cdemu-client-3.2.5.tar.xz 41596 BLAKE2B 5b3e5a16f9daa0ab2c670a8cba54af380894e668c87a64a5e2126777d6725420d9bb7f41290ca69eba12e20db97b00cc74aea3df9694ef331e7a571b913820b1 SHA512 d143705607507503cd7828f02e7a0fbe5d33f15e28ce61f453567d8635ed863c5b508ed2b1964f034d846ecdea752bd3dfb565350174db3e06cf7d29c2f828bf
diff --git a/app-cdr/cdemu/cdemu-3.2.4.ebuild b/app-cdr/cdemu/cdemu-3.2.5-r1.ebuild
index 17ee2d607be7..c697a93a5418 100644
--- a/app-cdr/cdemu/cdemu-3.2.4.ebuild
+++ b/app-cdr/cdemu/cdemu-3.2.5-r1.ebuild
@@ -1,34 +1,38 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_8 )
+PYTHON_COMPAT=( python3_{10..12} )
inherit bash-completion-r1 cmake python-single-r1 xdg-utils
MY_P=cdemu-client-${PV}
DESCRIPTION="Command-line tool for controlling cdemu-daemon"
HOMEPAGE="https://cdemu.sourceforge.io"
-SRC_URI="https://download.sourceforge.net/cdemu/cdemu-client/${MY_P}.tar.bz2"
+SRC_URI="https://download.sourceforge.net/cdemu/cdemu-client/${MY_P}.tar.xz"
S=${WORKDIR}/${MY_P}
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="amd64 x86"
+KEYWORDS="~amd64 ~x86"
IUSE="+cdemu-daemon"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND="${PYTHON_DEPS}
+RDEPEND="
+ ${PYTHON_DEPS}
$(python_gen_cond_dep '
dev-python/pygobject:3[${PYTHON_USEDEP}]
')
- cdemu-daemon? ( app-cdr/cdemu-daemon:0/7 )"
-BDEPEND="${PYTHON_DEPS}
+ cdemu-daemon? ( app-cdr/cdemu-daemon:0/7 )
+"
+BDEPEND="
+ ${PYTHON_DEPS}
dev-util/desktop-file-utils
>=dev-util/intltool-0.21
>=sys-devel/gettext-0.18
- virtual/pkgconfig"
+ virtual/pkgconfig
+"
DOCS=( AUTHORS README )
@@ -41,11 +45,17 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
-DPOST_INSTALL_HOOKS=OFF
- -DCMAKE_INSTALL_COMPLETIONSDIR="$(get_bashcompdir)"
+ # requires bash-completion as BDEPEND, better install it manually
+ -DENABLE_BASH_COMPLETION=OFF
)
cmake_src_configure
}
+src_install() {
+ cmake_src_install
+ newbashcomp data/cdemu-bash-completion.sh cdemu
+}
+
pkg_postinst() {
xdg_desktop_database_update
}
diff --git a/app-cdr/cdemu/cdemu-3.2.5.ebuild b/app-cdr/cdemu/cdemu-3.2.5.ebuild
index 6815cec94bc3..ae8d6c535a29 100644
--- a/app-cdr/cdemu/cdemu-3.2.5.ebuild
+++ b/app-cdr/cdemu/cdemu-3.2.5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit bash-completion-r1 cmake python-single-r1 xdg-utils
@@ -19,16 +19,20 @@ KEYWORDS="amd64 x86"
IUSE="+cdemu-daemon"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND="${PYTHON_DEPS}
+RDEPEND="
+ ${PYTHON_DEPS}
$(python_gen_cond_dep '
dev-python/pygobject:3[${PYTHON_USEDEP}]
')
- cdemu-daemon? ( app-cdr/cdemu-daemon:0/7 )"
-BDEPEND="${PYTHON_DEPS}
+ cdemu-daemon? ( app-cdr/cdemu-daemon:0/7 )
+"
+BDEPEND="
+ ${PYTHON_DEPS}
dev-util/desktop-file-utils
>=dev-util/intltool-0.21
>=sys-devel/gettext-0.18
- virtual/pkgconfig"
+ virtual/pkgconfig
+"
DOCS=( AUTHORS README )