summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr/cdrdao/files')
-rw-r--r--app-cdr/cdrdao/files/cdrdao-1.2.4-ax_pthread2.patch (renamed from app-cdr/cdrdao/files/cdrdao-1.2.4-ax_pthread.patch)79
-rw-r--r--app-cdr/cdrdao/files/cdrdao-1.2.5-fix-uninit.patch27
-rw-r--r--app-cdr/cdrdao/files/cdrdao-1.2.5-remove-gconf-dep.patch10
3 files changed, 62 insertions, 54 deletions
diff --git a/app-cdr/cdrdao/files/cdrdao-1.2.4-ax_pthread.patch b/app-cdr/cdrdao/files/cdrdao-1.2.4-ax_pthread2.patch
index fe052db02af7..8412708d4cb2 100644
--- a/app-cdr/cdrdao/files/cdrdao-1.2.4-ax_pthread.patch
+++ b/app-cdr/cdrdao/files/cdrdao-1.2.4-ax_pthread2.patch
@@ -3,9 +3,20 @@ to CFLAGS, CXXFLAGS and LIBS.
Also use AM_PROG_AR to detect proper ar
See also: https://bugs.gentoo.org/548004
---- cdrdao-1.2.4/configure.ac
-+++ cdrdao-1.2.4/configure.ac
-@@ -2,6 +2,7 @@
+--- cdrdao-rel_1_2_4.orig/autogen.sh
++++ cdrdao-rel_1_2_4/autogen.sh
+@@ -48,4 +48,7 @@
+ # Calls aclocal, automake, autoconf and al. for you
+ echo "Running autoreconf"
+ rm -fr autom4te.cache
+-autoreconf
++aclocal
++autoheader
++automake --add-missing --copy --foreign --force-missing
++autoconf
+--- cdrdao-rel_1_2_4.orig/configure.ac
++++ cdrdao-rel_1_2_4/configure.ac
+@@ -2,13 +2,13 @@
AC_REVISION($Revision: 1.26 $)dnl
AC_INIT(cdrdao, 1.2.4)
@@ -13,7 +24,14 @@ See also: https://bugs.gentoo.org/548004
AC_CONFIG_SRCDIR(dao/main.cc)
AM_INIT_AUTOMAKE
-@@ -32,7 +33,7 @@
+ AM_CONFIG_HEADER(config.h)
+ AM_MAINTAINER_MODE
+ AC_CANONICAL_HOST
+-AM_GCONF_SOURCE_2
+
+ AC_ARG_WITH(pcctsbin,[ --with-pcctsbin=dir set directory of PCCTS parser generator executables],[pcctsbin=$withval],[pcctsbin=default])
+
+@@ -32,7 +32,7 @@
AC_PROG_CPP
AC_PROG_INSTALL
AC_PROG_RANLIB
@@ -22,7 +40,7 @@ See also: https://bugs.gentoo.org/548004
AC_PROG_MAKE_SET
AC_PATH_TOOL([PKG_CONFIG], [pkg-config])
-@@ -113,7 +114,10 @@
+@@ -113,7 +113,10 @@
fi
if test "$use_pthreads" = yes; then
@@ -34,8 +52,8 @@ See also: https://bugs.gentoo.org/548004
if test "$have_pthread_std" = yes; then
AC_DEFINE(USE_POSIX_THREADS,1,"")
---- cdrdao-1.2.4/m4/ax_pthread.m4
-+++ cdrdao-1.2.4/m4/ax_pthread.m4
+--- cdrdao-rel_1_2_4.orig/m4/ax_pthread.m4
++++ cdrdao-rel_1_2_4/m4/ax_pthread.m4
@@ -0,0 +1,332 @@
+# ===========================================================================
+# http://www.gnu.org/software/autoconf-archive/ax_pthread.html
@@ -369,50 +387,3 @@ See also: https://bugs.gentoo.org/548004
+fi
+AC_LANG_POP
+])dnl AX_PTHREAD
---- cdrdao-1.2.4/m4/gconf-2.m4
-+++ cdrdao-1.2.4/m4/gconf-2.m4
-@@ -0,0 +1,44 @@
-+dnl AM_GCONF_SOURCE_2
-+dnl Defines GCONF_SCHEMA_CONFIG_SOURCE which is where you should install schemas
-+dnl (i.e. pass to gconftool-2
-+dnl Defines GCONF_SCHEMA_FILE_DIR which is a filesystem directory where
-+dnl you should install foo.schemas files
-+dnl
-+
-+AC_DEFUN([AM_GCONF_SOURCE_2],
-+[
-+ if test "x$GCONF_SCHEMA_INSTALL_SOURCE" = "x"; then
-+ GCONF_SCHEMA_CONFIG_SOURCE=`gconftool-2 --get-default-source`
-+ else
-+ GCONF_SCHEMA_CONFIG_SOURCE=$GCONF_SCHEMA_INSTALL_SOURCE
-+ fi
-+
-+ AC_ARG_WITH([gconf-source],
-+ AC_HELP_STRING([--with-gconf-source=sourceaddress],
-+ [Config database for installing schema files.]),
-+ [GCONF_SCHEMA_CONFIG_SOURCE="$withval"],)
-+
-+ AC_SUBST(GCONF_SCHEMA_CONFIG_SOURCE)
-+ AC_MSG_RESULT([Using config source $GCONF_SCHEMA_CONFIG_SOURCE for schema installation])
-+
-+ if test "x$GCONF_SCHEMA_FILE_DIR" = "x"; then
-+ GCONF_SCHEMA_FILE_DIR='$(sysconfdir)/gconf/schemas'
-+ fi
-+
-+ AC_ARG_WITH([gconf-schema-file-dir],
-+ AC_HELP_STRING([--with-gconf-schema-file-dir=dir],
-+ [Directory for installing schema files.]),
-+ [GCONF_SCHEMA_FILE_DIR="$withval"],)
-+
-+ AC_SUBST(GCONF_SCHEMA_FILE_DIR)
-+ AC_MSG_RESULT([Using $GCONF_SCHEMA_FILE_DIR as install directory for schema files])
-+
-+ AC_ARG_ENABLE(schemas-install,
-+ AC_HELP_STRING([--disable-schemas-install],
-+ [Disable the schemas installation]),
-+ [case ${enableval} in
-+ yes|no) ;;
-+ *) AC_MSG_ERROR([bad value ${enableval} for --enable-schemas-install]) ;;
-+ esac])
-+ AM_CONDITIONAL([GCONF_SCHEMAS_INSTALL], [test "$enable_schemas_install" != no])
-+])
diff --git a/app-cdr/cdrdao/files/cdrdao-1.2.5-fix-uninit.patch b/app-cdr/cdrdao/files/cdrdao-1.2.5-fix-uninit.patch
new file mode 100644
index 000000000000..6748dba34cf6
--- /dev/null
+++ b/app-cdr/cdrdao/files/cdrdao-1.2.5-fix-uninit.patch
@@ -0,0 +1,27 @@
+https://bugs.gentoo.org/915133
+https://github.com/cdrdao/cdrdao/issues/22
+https://github.com/cdrdao/cdrdao/pull/21
+
+From 251a40ab42305c412674c7c2d391374d91e91c95 Mon Sep 17 00:00:00 2001
+From: Ole Bertram <git@bertr.am>
+Date: Thu, 23 Mar 2023 17:08:48 +0100
+Subject: [PATCH] Fix uninitialized TOC data file name
+
+This caused spurious garbled TOC files and/or segfaults when not using
+the `--datafile` option.
+---
+ dao/main.cc | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/dao/main.cc b/dao/main.cc
+index 8bf4590..d09fc69 100644
+--- a/dao/main.cc
++++ b/dao/main.cc
+@@ -219,6 +219,7 @@ DaoCommandLine::DaoCommandLine() :
+ fullBurn(false), withCddb(false), taoSource(false), keepImage(false), overburn(false),
+ writeSpeedControl(false), keep(false), printQuery(false), no_utf8(false)
+ {
++ dataFilename = NULL;
+ readingSpeed = -1;
+ writingSpeed = -1;
+ command = UNKNOWN;
diff --git a/app-cdr/cdrdao/files/cdrdao-1.2.5-remove-gconf-dep.patch b/app-cdr/cdrdao/files/cdrdao-1.2.5-remove-gconf-dep.patch
new file mode 100644
index 000000000000..fc493abc71f2
--- /dev/null
+++ b/app-cdr/cdrdao/files/cdrdao-1.2.5-remove-gconf-dep.patch
@@ -0,0 +1,10 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -9,7 +9,6 @@
+ AC_CONFIG_HEADERS(config.h)
+ AM_MAINTAINER_MODE
+ AC_CANONICAL_HOST
+-AM_GCONF_SOURCE_2
+ AM_ICONV
+
+ AC_ARG_WITH(pcctsbin,[ --with-pcctsbin=dir set directory of PCCTS parser generator executables],[pcctsbin=$withval],[pcctsbin=default])