summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr/cdrdao')
-rw-r--r--app-cdr/cdrdao/Manifest3
-rw-r--r--app-cdr/cdrdao/cdrdao-1.2.4-r2.ebuild57
-rw-r--r--app-cdr/cdrdao/cdrdao-1.2.4.ebuild63
-rw-r--r--app-cdr/cdrdao/cdrdao-1.2.5-r1.ebuild55
-rw-r--r--app-cdr/cdrdao/cdrdao-1.2.5.ebuild53
-rw-r--r--app-cdr/cdrdao/files/cdrdao-1.2.4-ax_pthread2.patch (renamed from app-cdr/cdrdao/files/cdrdao-1.2.4-ax_pthread.patch)79
-rw-r--r--app-cdr/cdrdao/files/cdrdao-1.2.5-fix-uninit.patch27
-rw-r--r--app-cdr/cdrdao/files/cdrdao-1.2.5-remove-gconf-dep.patch10
-rw-r--r--app-cdr/cdrdao/metadata.xml14
9 files changed, 239 insertions, 122 deletions
diff --git a/app-cdr/cdrdao/Manifest b/app-cdr/cdrdao/Manifest
index 69cebed78afe..c66587c5f8c2 100644
--- a/app-cdr/cdrdao/Manifest
+++ b/app-cdr/cdrdao/Manifest
@@ -1 +1,2 @@
-DIST cdrdao-1.2.4.tar.bz2 1442181 BLAKE2B e1163b25c165a7acd7ec8c53069794724d93f09a486150255a58985e3fd0a222ba7ac5c124cb7a6991cf440ac701651be38754615fd3d0d295affa93595dc388 SHA512 41f20275ca44ec9003d0e3ed280cc98012353005cda6f544ebfa44f3f79f991845c0ef17af74db9456f1bacc342a7fd48c9e942d757927a4a9ff91808f7bbb09
+DIST cdrdao-1.2.4.tar.gz 1603363 BLAKE2B 9c22d21a391b6b1b6ded19f88506acd22e681a43ed91b1c71d20de27ce93cc74381d4efe8574adc929a189143c81f5838ca8d8227ec0e2e05a593f0df9547964 SHA512 decdc9d83fe380a4a05443ac26366eb3288d24bd7ed6c16d006707abb616dab91858a59af6638f2d7a72bc7bb6425dbfddd119ca492d18f07afbb27341b23d0b
+DIST cdrdao-1.2.5.tar.gz 858440 BLAKE2B 6b7f11968335f3c07df2bfc8cbfd53d65a42413026206c47f9bdc792d30faa91f3e9285fd36d884ee42cb31103f666097fb55c8f382202f4e9d2d4ddd4685527 SHA512 790468a28e5ba96421c83c2101f61f479099782bc28677c7f52b94990de258e3caf7f77d3105e3e826d848b9488182880857335b1bcfbfca033d9e1fc56d193b
diff --git a/app-cdr/cdrdao/cdrdao-1.2.4-r2.ebuild b/app-cdr/cdrdao/cdrdao-1.2.4-r2.ebuild
new file mode 100644
index 000000000000..e53adf8b4c31
--- /dev/null
+++ b/app-cdr/cdrdao/cdrdao-1.2.4-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+MY_PV="rel_${PV//./_}"
+DESCRIPTION="Burn CDs in disk-at-once mode with a command line interface"
+HOMEPAGE="https://github.com/cdrdao/cdrdao/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ~loong ppc ppc64 ~riscv sparc x86"
+IUSE="encode mad vorbis"
+
+DEPEND="app-cdr/cdrtools
+ encode? ( >=media-sound/lame-3.99 )
+ mad? (
+ media-libs/libao
+ media-libs/libmad
+ )
+ vorbis? (
+ media-libs/libao
+ media-libs/libvorbis
+ )"
+RDEPEND="${DEPEND}
+ !app-cdr/cue2toc"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-ax_pthread2.patch"
+ "${FILESDIR}/${P}-wformat-security.patch"
+)
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ default
+
+ ./autogen.sh || die
+ eautoreconf
+}
+
+src_configure() {
+ append-cxxflags -std=c++11
+
+ filter-lto # https://bugs.gentoo.org/854219
+
+ local myeconfargs=(
+ --without-gcdmaster
+ $(use_with vorbis ogg-support)
+ $(use_with mad mp3-support)
+ $(use_with encode lame)
+ )
+ econf "${myeconfargs[@]}"
+}
diff --git a/app-cdr/cdrdao/cdrdao-1.2.4.ebuild b/app-cdr/cdrdao/cdrdao-1.2.4.ebuild
deleted file mode 100644
index f2a3bb1783d6..000000000000
--- a/app-cdr/cdrdao/cdrdao-1.2.4.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools flag-o-matic
-
-DESCRIPTION="Burn CDs in disk-at-once mode -- with optional GUI frontend"
-HOMEPAGE="http://cdrdao.sourceforge.net/"
-if [[ ${PV/*_rc*} ]]
-then
- SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-else
- SRC_URI="http://www.poolshark.org/src/${P/_}.tar.bz2"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv sparc x86"
-IUSE="encode mad vorbis"
-
-COMMON_DEPEND="
- app-cdr/cdrtools
- encode? ( >=media-sound/lame-3.99 )
- mad? (
- media-libs/libmad
- media-libs/libao
- )
- vorbis? (
- media-libs/libvorbis
- media-libs/libao
- )"
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig"
-RDEPEND="${COMMON_DEPEND}
- !app-cdr/cue2toc
- !dev-util/pccts"
-
-PATCHES=(
- "${FILESDIR}/${P}-ax_pthread.patch"
- "${FILESDIR}/${P}-wformat-security.patch"
-)
-
-S="${WORKDIR}/${P/_}"
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- # Fix building with latest libsigc++
- append-cxxflags -std=c++11
- find -name '*.h' -exec sed -i '/sigc++\/object.h/d' {} + || die
-
- local myeconfargs=(
- --without-gcdmaster
- $(use_with vorbis ogg-support)
- $(use_with mad mp3-support)
- $(use_with encode lame)
- )
- econf "${myeconfargs[@]}"
-}
diff --git a/app-cdr/cdrdao/cdrdao-1.2.5-r1.ebuild b/app-cdr/cdrdao/cdrdao-1.2.5-r1.ebuild
new file mode 100644
index 000000000000..219170ed12f8
--- /dev/null
+++ b/app-cdr/cdrdao/cdrdao-1.2.5-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+MY_PV="rel_${PV//./_}"
+DESCRIPTION="Burn CDs in disk-at-once mode with a command line interface"
+HOMEPAGE="https://github.com/cdrdao/cdrdao/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ~loong ppc ppc64 ~riscv sparc x86"
+IUSE="encode mad vorbis"
+
+DEPEND="app-cdr/cdrtools
+ encode? ( >=media-sound/lame-3.99 )
+ mad? (
+ media-libs/libao
+ media-libs/libmad
+ )
+ vorbis? (
+ media-libs/libao
+ media-libs/libvorbis
+ )"
+RDEPEND="${DEPEND}
+ !app-cdr/cue2toc"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-remove-gconf-dep.patch"
+ "${FILESDIR}/${PN}-1.2.5-fix-uninit.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-cxxflags -std=c++11
+
+ filter-lto # https://bugs.gentoo.org/854219
+
+ local myeconfargs=(
+ --without-gcdmaster
+ $(use_with vorbis ogg-support)
+ $(use_with mad mp3-support)
+ $(use_with encode lame)
+ )
+ econf "${myeconfargs[@]}"
+}
diff --git a/app-cdr/cdrdao/cdrdao-1.2.5.ebuild b/app-cdr/cdrdao/cdrdao-1.2.5.ebuild
new file mode 100644
index 000000000000..67ce9118cd2d
--- /dev/null
+++ b/app-cdr/cdrdao/cdrdao-1.2.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+MY_PV="rel_${PV//./_}"
+DESCRIPTION="Burn CDs in disk-at-once mode with a command line interface"
+HOMEPAGE="https://github.com/cdrdao/cdrdao/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ~loong ppc ppc64 ~riscv sparc x86"
+IUSE="encode mad vorbis"
+
+DEPEND="app-cdr/cdrtools
+ encode? ( >=media-sound/lame-3.99 )
+ mad? (
+ media-libs/libao
+ media-libs/libmad
+ )
+ vorbis? (
+ media-libs/libao
+ media-libs/libvorbis
+ )"
+RDEPEND="${DEPEND}
+ !app-cdr/cue2toc"
+BDEPEND="virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}/${P}-remove-gconf-dep.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-cxxflags -std=c++11
+
+ filter-lto # https://bugs.gentoo.org/854219
+
+ local myeconfargs=(
+ --without-gcdmaster
+ $(use_with vorbis ogg-support)
+ $(use_with mad mp3-support)
+ $(use_with encode lame)
+ )
+ econf "${myeconfargs[@]}"
+}
diff --git a/app-cdr/cdrdao/files/cdrdao-1.2.4-ax_pthread.patch b/app-cdr/cdrdao/files/cdrdao-1.2.4-ax_pthread2.patch
index fe052db02af7..8412708d4cb2 100644
--- a/app-cdr/cdrdao/files/cdrdao-1.2.4-ax_pthread.patch
+++ b/app-cdr/cdrdao/files/cdrdao-1.2.4-ax_pthread2.patch
@@ -3,9 +3,20 @@ to CFLAGS, CXXFLAGS and LIBS.
Also use AM_PROG_AR to detect proper ar
See also: https://bugs.gentoo.org/548004
---- cdrdao-1.2.4/configure.ac
-+++ cdrdao-1.2.4/configure.ac
-@@ -2,6 +2,7 @@
+--- cdrdao-rel_1_2_4.orig/autogen.sh
++++ cdrdao-rel_1_2_4/autogen.sh
+@@ -48,4 +48,7 @@
+ # Calls aclocal, automake, autoconf and al. for you
+ echo "Running autoreconf"
+ rm -fr autom4te.cache
+-autoreconf
++aclocal
++autoheader
++automake --add-missing --copy --foreign --force-missing
++autoconf
+--- cdrdao-rel_1_2_4.orig/configure.ac
++++ cdrdao-rel_1_2_4/configure.ac
+@@ -2,13 +2,13 @@
AC_REVISION($Revision: 1.26 $)dnl
AC_INIT(cdrdao, 1.2.4)
@@ -13,7 +24,14 @@ See also: https://bugs.gentoo.org/548004
AC_CONFIG_SRCDIR(dao/main.cc)
AM_INIT_AUTOMAKE
-@@ -32,7 +33,7 @@
+ AM_CONFIG_HEADER(config.h)
+ AM_MAINTAINER_MODE
+ AC_CANONICAL_HOST
+-AM_GCONF_SOURCE_2
+
+ AC_ARG_WITH(pcctsbin,[ --with-pcctsbin=dir set directory of PCCTS parser generator executables],[pcctsbin=$withval],[pcctsbin=default])
+
+@@ -32,7 +32,7 @@
AC_PROG_CPP
AC_PROG_INSTALL
AC_PROG_RANLIB
@@ -22,7 +40,7 @@ See also: https://bugs.gentoo.org/548004
AC_PROG_MAKE_SET
AC_PATH_TOOL([PKG_CONFIG], [pkg-config])
-@@ -113,7 +114,10 @@
+@@ -113,7 +113,10 @@
fi
if test "$use_pthreads" = yes; then
@@ -34,8 +52,8 @@ See also: https://bugs.gentoo.org/548004
if test "$have_pthread_std" = yes; then
AC_DEFINE(USE_POSIX_THREADS,1,"")
---- cdrdao-1.2.4/m4/ax_pthread.m4
-+++ cdrdao-1.2.4/m4/ax_pthread.m4
+--- cdrdao-rel_1_2_4.orig/m4/ax_pthread.m4
++++ cdrdao-rel_1_2_4/m4/ax_pthread.m4
@@ -0,0 +1,332 @@
+# ===========================================================================
+# http://www.gnu.org/software/autoconf-archive/ax_pthread.html
@@ -369,50 +387,3 @@ See also: https://bugs.gentoo.org/548004
+fi
+AC_LANG_POP
+])dnl AX_PTHREAD
---- cdrdao-1.2.4/m4/gconf-2.m4
-+++ cdrdao-1.2.4/m4/gconf-2.m4
-@@ -0,0 +1,44 @@
-+dnl AM_GCONF_SOURCE_2
-+dnl Defines GCONF_SCHEMA_CONFIG_SOURCE which is where you should install schemas
-+dnl (i.e. pass to gconftool-2
-+dnl Defines GCONF_SCHEMA_FILE_DIR which is a filesystem directory where
-+dnl you should install foo.schemas files
-+dnl
-+
-+AC_DEFUN([AM_GCONF_SOURCE_2],
-+[
-+ if test "x$GCONF_SCHEMA_INSTALL_SOURCE" = "x"; then
-+ GCONF_SCHEMA_CONFIG_SOURCE=`gconftool-2 --get-default-source`
-+ else
-+ GCONF_SCHEMA_CONFIG_SOURCE=$GCONF_SCHEMA_INSTALL_SOURCE
-+ fi
-+
-+ AC_ARG_WITH([gconf-source],
-+ AC_HELP_STRING([--with-gconf-source=sourceaddress],
-+ [Config database for installing schema files.]),
-+ [GCONF_SCHEMA_CONFIG_SOURCE="$withval"],)
-+
-+ AC_SUBST(GCONF_SCHEMA_CONFIG_SOURCE)
-+ AC_MSG_RESULT([Using config source $GCONF_SCHEMA_CONFIG_SOURCE for schema installation])
-+
-+ if test "x$GCONF_SCHEMA_FILE_DIR" = "x"; then
-+ GCONF_SCHEMA_FILE_DIR='$(sysconfdir)/gconf/schemas'
-+ fi
-+
-+ AC_ARG_WITH([gconf-schema-file-dir],
-+ AC_HELP_STRING([--with-gconf-schema-file-dir=dir],
-+ [Directory for installing schema files.]),
-+ [GCONF_SCHEMA_FILE_DIR="$withval"],)
-+
-+ AC_SUBST(GCONF_SCHEMA_FILE_DIR)
-+ AC_MSG_RESULT([Using $GCONF_SCHEMA_FILE_DIR as install directory for schema files])
-+
-+ AC_ARG_ENABLE(schemas-install,
-+ AC_HELP_STRING([--disable-schemas-install],
-+ [Disable the schemas installation]),
-+ [case ${enableval} in
-+ yes|no) ;;
-+ *) AC_MSG_ERROR([bad value ${enableval} for --enable-schemas-install]) ;;
-+ esac])
-+ AM_CONDITIONAL([GCONF_SCHEMAS_INSTALL], [test "$enable_schemas_install" != no])
-+])
diff --git a/app-cdr/cdrdao/files/cdrdao-1.2.5-fix-uninit.patch b/app-cdr/cdrdao/files/cdrdao-1.2.5-fix-uninit.patch
new file mode 100644
index 000000000000..6748dba34cf6
--- /dev/null
+++ b/app-cdr/cdrdao/files/cdrdao-1.2.5-fix-uninit.patch
@@ -0,0 +1,27 @@
+https://bugs.gentoo.org/915133
+https://github.com/cdrdao/cdrdao/issues/22
+https://github.com/cdrdao/cdrdao/pull/21
+
+From 251a40ab42305c412674c7c2d391374d91e91c95 Mon Sep 17 00:00:00 2001
+From: Ole Bertram <git@bertr.am>
+Date: Thu, 23 Mar 2023 17:08:48 +0100
+Subject: [PATCH] Fix uninitialized TOC data file name
+
+This caused spurious garbled TOC files and/or segfaults when not using
+the `--datafile` option.
+---
+ dao/main.cc | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/dao/main.cc b/dao/main.cc
+index 8bf4590..d09fc69 100644
+--- a/dao/main.cc
++++ b/dao/main.cc
+@@ -219,6 +219,7 @@ DaoCommandLine::DaoCommandLine() :
+ fullBurn(false), withCddb(false), taoSource(false), keepImage(false), overburn(false),
+ writeSpeedControl(false), keep(false), printQuery(false), no_utf8(false)
+ {
++ dataFilename = NULL;
+ readingSpeed = -1;
+ writingSpeed = -1;
+ command = UNKNOWN;
diff --git a/app-cdr/cdrdao/files/cdrdao-1.2.5-remove-gconf-dep.patch b/app-cdr/cdrdao/files/cdrdao-1.2.5-remove-gconf-dep.patch
new file mode 100644
index 000000000000..fc493abc71f2
--- /dev/null
+++ b/app-cdr/cdrdao/files/cdrdao-1.2.5-remove-gconf-dep.patch
@@ -0,0 +1,10 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -9,7 +9,6 @@
+ AC_CONFIG_HEADERS(config.h)
+ AM_MAINTAINER_MODE
+ AC_CANONICAL_HOST
+-AM_GCONF_SOURCE_2
+ AM_ICONV
+
+ AC_ARG_WITH(pcctsbin,[ --with-pcctsbin=dir set directory of PCCTS parser generator executables],[pcctsbin=$withval],[pcctsbin=default])
diff --git a/app-cdr/cdrdao/metadata.xml b/app-cdr/cdrdao/metadata.xml
index 7dc22fa1c02f..6a5c72acfb05 100644
--- a/app-cdr/cdrdao/metadata.xml
+++ b/app-cdr/cdrdao/metadata.xml
@@ -1,12 +1,18 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person" proxied="yes">
+ <email>martin.dummer@gmx.net</email>
+ <name>Martin Dummer</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<longdescription>
- CD command line recording, ripping and copying tool. Especially ISOs- and
- bin/cue-files are handled very well.
+ CD command line recording, ripping and copying tool. Especially ISOs and bin/cue-files are handled very well.
</longdescription>
<upstream>
- <remote-id type="sourceforge">cdrdao</remote-id>
+ <remote-id type="github">cdrdao/cdrdao</remote-id>
</upstream>
</pkgmetadata>