summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr/cuegen/files')
-rw-r--r--app-cdr/cuegen/files/cuegen-1.2.0-fix-build-system.patch5
-rw-r--r--app-cdr/cuegen/files/cuegen-1.2.0-missing-includes.patch17
2 files changed, 20 insertions, 2 deletions
diff --git a/app-cdr/cuegen/files/cuegen-1.2.0-fix-build-system.patch b/app-cdr/cuegen/files/cuegen-1.2.0-fix-build-system.patch
index 614ec59f905d..fa54235d0e4f 100644
--- a/app-cdr/cuegen/files/cuegen-1.2.0-fix-build-system.patch
+++ b/app-cdr/cuegen/files/cuegen-1.2.0-fix-build-system.patch
@@ -1,11 +1,12 @@
--- a/Makefile
+++ b/Makefile
-@@ -1,9 +1 @@
+@@ -1,9 +1,3 @@
-TARGET := cuegen
-CC := gcc
-CFLAGS := -O2 -pipe -fomit-frame-pointer
-WARN := -W -Wall -Wstrict-prototypes -Wmissing-prototypes
--
++CFLAGS += -W -Wall -Wstrict-prototypes -Wmissing-prototypes
+
all: cuegen
-
-cuegen: cuegen.o
diff --git a/app-cdr/cuegen/files/cuegen-1.2.0-missing-includes.patch b/app-cdr/cuegen/files/cuegen-1.2.0-missing-includes.patch
new file mode 100644
index 000000000000..98a273cddb13
--- /dev/null
+++ b/app-cdr/cuegen/files/cuegen-1.2.0-missing-includes.patch
@@ -0,0 +1,17 @@
+--- a/cuegen.c
++++ b/cuegen.c
+@@ -10,12 +10,14 @@
+ */
+
+
++#include <fcntl.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <linux/cdrom.h>
+ #include <sys/ioctl.h>
+ #include <sys/file.h>
+ #include <sys/types.h>
++#include <sys/stat.h>
+ #include <unistd.h>
+ #include <string.h>
+