summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr/gcdemu/gcdemu-3.2.6.ebuild')
-rw-r--r--app-cdr/gcdemu/gcdemu-3.2.6.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/app-cdr/gcdemu/gcdemu-3.2.6.ebuild b/app-cdr/gcdemu/gcdemu-3.2.6.ebuild
index acd1390fe915..178755cb9636 100644
--- a/app-cdr/gcdemu/gcdemu-3.2.6.ebuild
+++ b/app-cdr/gcdemu/gcdemu-3.2.6.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit cmake gnome2-utils python-single-r1 xdg-utils
@@ -13,12 +13,13 @@ SRC_URI="https://download.sourceforge.net/cdemu/gcdemu/${P}.tar.xz"
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
# librsvg for pixbuf-loader
-RDEPEND="${PYTHON_DEPS}
+RDEPEND="
+ ${PYTHON_DEPS}
app-cdr/cdemu-daemon:0/7
$(python_gen_cond_dep '
dev-python/pygobject:3[${PYTHON_USEDEP}]
@@ -26,12 +27,15 @@ RDEPEND="${PYTHON_DEPS}
gnome-base/librsvg:2
x11-libs/gdk-pixbuf[introspection]
x11-libs/gtk+:3[introspection]
- x11-libs/libnotify[introspection]"
-BDEPEND="${PYTHON_DEPS}
+ x11-libs/libnotify[introspection]
+"
+BDEPEND="
+ ${PYTHON_DEPS}
dev-util/desktop-file-utils
>=dev-util/intltool-0.21
sys-devel/gettext
- virtual/pkgconfig"
+ virtual/pkgconfig
+"
DOCS=( AUTHORS README )