summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr/gcdemu')
-rw-r--r--app-cdr/gcdemu/gcdemu-3.2.6-r1.ebuild60
-rw-r--r--app-cdr/gcdemu/gcdemu-3.2.6.ebuild16
2 files changed, 70 insertions, 6 deletions
diff --git a/app-cdr/gcdemu/gcdemu-3.2.6-r1.ebuild b/app-cdr/gcdemu/gcdemu-3.2.6-r1.ebuild
new file mode 100644
index 000000000000..10f7298db619
--- /dev/null
+++ b/app-cdr/gcdemu/gcdemu-3.2.6-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit cmake gnome2-utils python-single-r1 xdg-utils
+
+DESCRIPTION="Gtk+ GUI for controlling cdemu-daemon"
+HOMEPAGE="https://cdemu.sourceforge.io"
+SRC_URI="https://download.sourceforge.net/cdemu/gcdemu/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# librsvg for pixbuf-loader
+RDEPEND="
+ ${PYTHON_DEPS}
+ app-cdr/cdemu-daemon:0/7
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ gnome-base/librsvg:2
+ x11-libs/gdk-pixbuf[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-util/desktop-file-utils
+ >=dev-util/intltool-0.21
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS README )
+
+src_prepare() {
+ cmake_src_prepare
+ python_fix_shebang src/gcdemu
+}
+
+src_configure() {
+ local mycmakeargs=( -DPOST_INSTALL_HOOKS=OFF )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_schemas_update
+}
diff --git a/app-cdr/gcdemu/gcdemu-3.2.6.ebuild b/app-cdr/gcdemu/gcdemu-3.2.6.ebuild
index cc0619e2c133..178755cb9636 100644
--- a/app-cdr/gcdemu/gcdemu-3.2.6.ebuild
+++ b/app-cdr/gcdemu/gcdemu-3.2.6.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit cmake gnome2-utils python-single-r1 xdg-utils
@@ -18,7 +18,8 @@ IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
# librsvg for pixbuf-loader
-RDEPEND="${PYTHON_DEPS}
+RDEPEND="
+ ${PYTHON_DEPS}
app-cdr/cdemu-daemon:0/7
$(python_gen_cond_dep '
dev-python/pygobject:3[${PYTHON_USEDEP}]
@@ -26,12 +27,15 @@ RDEPEND="${PYTHON_DEPS}
gnome-base/librsvg:2
x11-libs/gdk-pixbuf[introspection]
x11-libs/gtk+:3[introspection]
- x11-libs/libnotify[introspection]"
-BDEPEND="${PYTHON_DEPS}
+ x11-libs/libnotify[introspection]
+"
+BDEPEND="
+ ${PYTHON_DEPS}
dev-util/desktop-file-utils
>=dev-util/intltool-0.21
sys-devel/gettext
- virtual/pkgconfig"
+ virtual/pkgconfig
+"
DOCS=( AUTHORS README )