summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/dvdisaster/Manifest1
-rw-r--r--app-cdr/dvdisaster/dvdisaster-0.72.2.ebuild88
2 files changed, 0 insertions, 89 deletions
diff --git a/app-cdr/dvdisaster/Manifest b/app-cdr/dvdisaster/Manifest
index 9a187cf63e5b..fe29ad2df0aa 100644
--- a/app-cdr/dvdisaster/Manifest
+++ b/app-cdr/dvdisaster/Manifest
@@ -1,2 +1 @@
-DIST dvdisaster-0.72.2.tar.bz2 4145193 SHA256 62d00c399c99a3bba493405174aeb96bd8c2d428d01d24b46858a55531b725ae SHA512 5283c5a0f9120a02434c8561f130d497db8eb7dab646f12d9cba9bc3a3ffa97974d783a9a8c67fb0669bba9ab5306545457c29e64b6a6e7a2722d1833dbcba11 WHIRLPOOL b1732e89f11e3e2f29bfa0fc661502eae4c10eb27d6186ca0a79405ca3e40388a2499b9990046fe002717b76332437978b0bcc8ef1cc421fbcbb1abf85198d2e
DIST dvdisaster_0.72.4.orig.tar.bz2 5097738 SHA256 444763bc40bcc8c396ecd7af0d5d6dd8c458009d4ed62af74ef54074541aa05e SHA512 aa0a9f3040d45b16a9117b2b6756d2423cf55db4a00e8314a164f6dc32863cd4e5a5b5ec009a56782aa2afe6031e3a32954014101abc67291428e9edea1b5272 WHIRLPOOL 888b9643e4102e4c7f237b336bbead60fd02833357775f586766672ea182ce680615a74f9547cf015b3e0edb269fe905a4dd5f28cbf765f3c7f114e097736208
diff --git a/app-cdr/dvdisaster/dvdisaster-0.72.2.ebuild b/app-cdr/dvdisaster/dvdisaster-0.72.2.ebuild
deleted file mode 100644
index e07468438ae0..000000000000
--- a/app-cdr/dvdisaster/dvdisaster-0.72.2.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-inherit eutils gnome2-utils versionator
-
-MY_P=${PN}-$(replace_version_separator 2 '.')
-
-DESCRIPTION="Data-protection and recovery tool for DVDs"
-HOMEPAGE="http://dvdisaster.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-KEYWORDS="amd64 ppc x86"
-SLOT="0"
-IUSE="debug linguas_cs linguas_de linguas_it linguas_ru cpu_flags_x86_sse2"
-
-RDEPEND=">=x11-libs/gtk+-2.6:2
- media-libs/libpng
- sys-libs/zlib"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.72.1-libpng15.patch
-}
-
-# - There is no autotools, use_ functions won't work
-# - NLS disabled because sys-devel/gettext fails, if you enable it
-# you need also virtual/libintl because it links to it for FreeBSD
-src_configure() {
- local myconf
-
- if use cpu_flags_x86_sse2; then
- myconf+=" --with-sse2=yes"
- else
- myconf+=" --with-sse2=no"
- fi
-
- use debug && myconf+=" --with-memdebug=yes"
-
- ./configure \
- --prefix=/usr \
- --bindir=/usr/bin \
- --mandir=/usr/share/man \
- --docdir=/usr/share/doc \
- --docsubdir=${PF} \
- --localedir=/usr/share/locale \
- --buildroot="${D}" \
- --with-nls=no \
- ${myconf} || die
-}
-
-src_install() {
- emake install
-
- newicon contrib/${PN}48.png ${PN}.png
- make_desktop_entry ${PN} ${PN} ${PN} "System;Utility"
-
- for res in 16 32 48 64; do
- insinto /usr/share/icons/hicolor/${res}x${res}/apps
- newins contrib/${PN}${res}.png ${PN}.png
- done
-
- local dest="${D}/usr/share"
-
- for lang in cs de it ru; do
- use linguas_${lang} || rm -rf ${dest}/doc/${PF}/${lang} \
- ${dest}/doc/${PF}/CREDITS.${lang} ${dest}/man/${lang}
- done
-
- rm -f "${D}"/usr/bin/*.sh
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}