summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/containers-image/files/fix-warnings.patch')
-rw-r--r--app-containers/containers-image/files/fix-warnings.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/app-containers/containers-image/files/fix-warnings.patch b/app-containers/containers-image/files/fix-warnings.patch
new file mode 100644
index 000000000000..c68cffa8584b
--- /dev/null
+++ b/app-containers/containers-image/files/fix-warnings.patch
@@ -0,0 +1,14 @@
+--- a/Makefile
++++ b/Makefile
+@@ -5,7 +5,2 @@
+
+-GOBIN := $(shell go env GOBIN)
+-ifeq ($(GOBIN),)
+-GOBIN := $(shell go env GOPATH)/bin
+-endif
+-
+ # when cross compiling _for_ a Darwin or windows host, then we must use openpgp
+@@ -17,3 +12,2 @@
+
+-PACKAGES := $(shell GO111MODULE=on go list $(BUILDFLAGS) ./...)
+ SOURCE_DIRS = $(shell echo $(PACKAGES) | awk 'BEGIN{FS="/"; RS=" "}{print $$4}' | uniq)