summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/containers-shortnames')
-rw-r--r--app-containers/containers-shortnames/Manifest1
-rw-r--r--app-containers/containers-shortnames/containers-shortnames-2023.02.20.ebuild36
-rw-r--r--app-containers/containers-shortnames/containers-shortnames-9999.ebuild36
-rw-r--r--app-containers/containers-shortnames/metadata.xml21
4 files changed, 94 insertions, 0 deletions
diff --git a/app-containers/containers-shortnames/Manifest b/app-containers/containers-shortnames/Manifest
new file mode 100644
index 000000000000..af3f5371bc0f
--- /dev/null
+++ b/app-containers/containers-shortnames/Manifest
@@ -0,0 +1 @@
+DIST containers-shortnames-2023.02.20.tar.gz 13527 BLAKE2B 165a4c51bd284078990c94059145bb6b4bd5de4d8595eb2ccd2acc6fe8561e7edc300b7edadc684675ee281d7ada1c3a6d5aa0117c640ec22c2d2ef7e46486b5 SHA512 856dbbeb2acda276e9605bd1ecec0f8d65952c597ee2af61dd8909d7d3c04e5ef06c40b69ec4a98f79e623c536850f614c1b0af3a19637e300e7d3a285933193
diff --git a/app-containers/containers-shortnames/containers-shortnames-2023.02.20.ebuild b/app-containers/containers-shortnames/containers-shortnames-2023.02.20.ebuild
new file mode 100644
index 000000000000..bf48bb1f16f0
--- /dev/null
+++ b/app-containers/containers-shortnames/containers-shortnames-2023.02.20.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Configures default shortnames (aliases) for Containers"
+HOMEPAGE="https://github.com/containers/shortnames"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/containers/shortnames.git"
+else
+ SRC_URI="https://github.com/containers/shortnames/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${P#containers-}"
+ KEYWORDS="amd64 arm64 ~riscv"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+src_configure() {
+ return
+}
+
+src_compile() {
+ return
+}
+
+src_test() {
+ return
+}
+
+src_install() {
+ insinto /etc/containers/registries.conf.d
+ newins shortnames.conf 000-shortnames.conf
+}
diff --git a/app-containers/containers-shortnames/containers-shortnames-9999.ebuild b/app-containers/containers-shortnames/containers-shortnames-9999.ebuild
new file mode 100644
index 000000000000..fc6e0837c92f
--- /dev/null
+++ b/app-containers/containers-shortnames/containers-shortnames-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Configures default shortnames (aliases) for Containers"
+HOMEPAGE="https://github.com/containers/shortnames"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/containers/shortnames.git"
+else
+ SRC_URI="https://github.com/containers/shortnames/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${P#containers-}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+src_configure() {
+ return
+}
+
+src_compile() {
+ return
+}
+
+src_test() {
+ return
+}
+
+src_install() {
+ insinto /etc/containers/registries.conf.d
+ newins shortnames.conf 000-shortnames.conf
+}
diff --git a/app-containers/containers-shortnames/metadata.xml b/app-containers/containers-shortnames/metadata.xml
new file mode 100644
index 000000000000..6fbce4b1e2e0
--- /dev/null
+++ b/app-containers/containers-shortnames/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>me@rahil.rocks</email>
+ <name>Rahil Bhimjiani</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ <name>Zac Medico</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">containers/shortnames</remote-id>
+ <bugs-to>https://github.com/containers/shortnames/issues</bugs-to>
+ <doc>https://github.com/containers/shortnames/blob/main/README.md</doc>
+ </upstream>
+</pkgmetadata>