summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/cri-tools/cri-tools-1.24.0.ebuild')
-rw-r--r--app-containers/cri-tools/cri-tools-1.24.0.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/app-containers/cri-tools/cri-tools-1.24.0.ebuild b/app-containers/cri-tools/cri-tools-1.24.0.ebuild
deleted file mode 100644
index 0a580bdda110..000000000000
--- a/app-containers/cri-tools/cri-tools-1.24.0.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit bash-completion-r1 go-module
-
-DESCRIPTION="CLI and validation tools for Kubelet Container Runtime (CRI)"
-HOMEPAGE="https://github.com/kubernetes-sigs/cri-tools"
-SRC_URI="https://github.com/kubernetes-sigs/cri-tools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-DEPEND="dev-lang/go"
-
-RESTRICT+=" test"
-
-src_compile() {
- emake VERSION="${PV}"
- ./build/bin/crictl completion bash > "${PN}.bash" || die
- ./build/bin/crictl completion zsh > "${PN}.zsh" || die
-}
-
-src_install() {
- dobin ./build/bin/crictl
-
- newbashcomp ${PN}.bash ${PN}
- insinto /usr/share/zsh/site-functions
- newins ${PN}.zsh _${PN}
-
- dodoc -r docs {README,RELEASE,CHANGELOG,CONTRIBUTING}.md
-}